summaryrefslogtreecommitdiffstats
path: root/python/pyasn1
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyasn1')
-rw-r--r--python/pyasn1/README1
-rw-r--r--python/pyasn1/pyasn1.SlackBuild92
-rw-r--r--python/pyasn1/pyasn1.info10
-rw-r--r--python/pyasn1/slack-desc19
4 files changed, 0 insertions, 122 deletions
diff --git a/python/pyasn1/README b/python/pyasn1/README
deleted file mode 100644
index e8c7885ff0..0000000000
--- a/python/pyasn1/README
+++ /dev/null
@@ -1 +0,0 @@
-pyasn1 implements ASN.1 types and codecs (BER, CER, DER) in Python.
diff --git a/python/pyasn1/pyasn1.SlackBuild b/python/pyasn1/pyasn1.SlackBuild
deleted file mode 100644
index 98956f9ea4..0000000000
--- a/python/pyasn1/pyasn1.SlackBuild
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyasn1
-
-# Copyright 2011-2018 Markus Reichelt, Aachen, DE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Markus Reichelt, slackbuilds@mareichelt.de, 0xCCEEF115
-
-PRGNAM=pyasn1
-VERSION=${VERSION:-0.4.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-# Add Python3 support
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ar *.rst *.md docs/ $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pyasn1/pyasn1.info b/python/pyasn1/pyasn1.info
deleted file mode 100644
index e0bc445269..0000000000
--- a/python/pyasn1/pyasn1.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyasn1"
-VERSION="0.4.4"
-HOMEPAGE="https://github.com/etingof/pyasn1"
-DOWNLOAD="https://files.pythonhosted.org/packages/10/46/059775dc8e50f722d205452bced4b3cc965d27e8c3389156acd3b1123ae3/pyasn1-0.4.4.tar.gz"
-MD5SUM="0d182b71e1f72fe147d7957bc90be7f2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Markus Reichelt"
-EMAIL="slackbuilds@mareichelt.de"
diff --git a/python/pyasn1/slack-desc b/python/pyasn1/slack-desc
deleted file mode 100644
index 9be1ee3f13..0000000000
--- a/python/pyasn1/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyasn1: pyasn1 (ASN.1 types and codecs in Python)
-pyasn1:
-pyasn1: pyasn1 implements ASN.1 types and codecs (BER, CER, DER) in Python.
-pyasn1:
-pyasn1: Some features include:
-pyasn1: - Generic implementation of ASN.1 types (X.208)
-pyasn1: - Fully standard compliant BER/CER/DER codecs
-pyasn1: - 100% Python, works with Python 2.2 and later
-pyasn1:
-pyasn1: Homepage: https://github.com/etingof/pyasn1
-pyasn1: