summaryrefslogtreecommitdiffstats
path: root/python/ptyprocess
diff options
context:
space:
mode:
Diffstat (limited to 'python/ptyprocess')
-rw-r--r--python/ptyprocess/README2
-rw-r--r--python/ptyprocess/ptyprocess.SlackBuild21
-rw-r--r--python/ptyprocess/ptyprocess.info6
3 files changed, 15 insertions, 14 deletions
diff --git a/python/ptyprocess/README b/python/ptyprocess/README
index 3891591654..e80b0e9429 100644
--- a/python/ptyprocess/README
+++ b/python/ptyprocess/README
@@ -6,5 +6,3 @@ Sometimes, piping stdin and stdout is not enough. There might be
a password prompt that doesn’t read from stdin, output that changes
when it’s going to a pipe rather than a terminal, or curses-style
interfaces that rely on a terminal.
-
-NOTE: python3 support will be added if python3 is installed.
diff --git a/python/ptyprocess/ptyprocess.SlackBuild b/python/ptyprocess/ptyprocess.SlackBuild
index 1a6b6ecac1..b5f76dc00e 100644
--- a/python/ptyprocess/ptyprocess.SlackBuild
+++ b/python/ptyprocess/ptyprocess.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for ptyprocess
-# Copyright 2016-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2016-2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=ptyprocess
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-0.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -71,10 +78,6 @@ find -L . \
python setup.py install --root=$PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -88,4 +91,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/ptyprocess/ptyprocess.info b/python/ptyprocess/ptyprocess.info
index 50670da7a8..2920d6c84a 100644
--- a/python/ptyprocess/ptyprocess.info
+++ b/python/ptyprocess/ptyprocess.info
@@ -1,8 +1,8 @@
PRGNAM="ptyprocess"
-VERSION="0.6.0"
+VERSION="0.7.0"
HOMEPAGE="https://pypi.python.org/pypi/ptyprocess"
-DOWNLOAD="https://files.pythonhosted.org/packages/7d/2d/e4b8733cf79b7309d84c9081a4ab558c89d8c89da5961bf4ddb050ca1ce0/ptyprocess-0.6.0.tar.gz"
-MD5SUM="37402d69f3b50913d4d483587bffad8f"
+DOWNLOAD="https://files.pythonhosted.org/packages/20/e5/16ff212c1e452235a90aeb09066144d0c5a6a8c0834397e03f5224495c4e/ptyprocess-0.7.0.tar.gz"
+MD5SUM="9da200c397cb1752209a6b718b6cfc68"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""