summaryrefslogtreecommitdiffstats
path: root/python/psutil
diff options
context:
space:
mode:
Diffstat (limited to 'python/psutil')
-rw-r--r--python/psutil/README11
-rw-r--r--python/psutil/psutil.SlackBuild76
-rw-r--r--python/psutil/psutil.info10
-rw-r--r--python/psutil/slack-desc19
4 files changed, 0 insertions, 116 deletions
diff --git a/python/psutil/README b/python/psutil/README
deleted file mode 100644
index 8ba3203e56..0000000000
--- a/python/psutil/README
+++ /dev/null
@@ -1,11 +0,0 @@
-psutil is a module providing an interface for retrieving information on all
-running processes and system utilization (CPU, memory, disks, network, users) in
-a portable way by using Python, implementing many functionalities offered by
-command line tools such as: ps, top, df, kill, free, lsof, netstat, ifconfig,
-nice, ionice, iostat, iotop, uptime, pidof, tty, who, taskset, and pmap.
-
-Optional dependencies: python3, mock and ipaddress
-
-To install python3 bindings run the slackbuild with PYTHON3=yes.
-
- # PYTHON3=yes ./psutil.SlackBuild
diff --git a/python/psutil/psutil.SlackBuild b/python/psutil/psutil.SlackBuild
deleted file mode 100644
index c37311562e..0000000000
--- a/python/psutil/psutil.SlackBuild
+++ /dev/null
@@ -1,76 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for psutil
-
-# Copyright 2012-2019 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=psutil
-VERSION=${VERSION:-5.6.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-# Install python3 bindings for psutil. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CREDITS LICENSE *.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/psutil/psutil.info b/python/psutil/psutil.info
deleted file mode 100644
index e5cc2f3a79..0000000000
--- a/python/psutil/psutil.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="psutil"
-VERSION="5.6.3"
-HOMEPAGE="https://github.com/giampaolo/psutil"
-DOWNLOAD="https://pypi.io/packages/source/p/psutil/psutil-5.6.3.tar.gz"
-MD5SUM="1bbc1788588cc3c2c461cd98a830ba72"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/psutil/slack-desc b/python/psutil/slack-desc
deleted file mode 100644
index 6592d21f1a..0000000000
--- a/python/psutil/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-psutil: psutil (python interface for process and system info)
-psutil:
-psutil: psutil is a module providing an interface for retrieving information
-psutil: on all running processes and system utilization (CPU, memory, disks,
-psutil: network, users) in a portable way by using Python, implementing many
-psutil: functionalities offered by command line tools such as: ps, top, df,
-psutil: kill, free, lsof, netstat, ifconfig, nice, ionice, iostat, iotop,
-psutil: uptime, pidof, tty, who, taskset, and pmap
-psutil:
-psutil: Homepage: http://code.google.com/p/psutil/
-psutil: