summaryrefslogtreecommitdiffstats
path: root/python/llfuse
diff options
context:
space:
mode:
Diffstat (limited to 'python/llfuse')
-rw-r--r--python/llfuse/README12
-rw-r--r--python/llfuse/llfuse.SlackBuild38
-rw-r--r--python/llfuse/llfuse.info12
-rw-r--r--python/llfuse/slack-desc2
4 files changed, 34 insertions, 30 deletions
diff --git a/python/llfuse/README b/python/llfuse/README
index 1d3fb5f581..6aa9be22c9 100644
--- a/python/llfuse/README
+++ b/python/llfuse/README
@@ -1,8 +1,8 @@
-LLFUSE is a set of Python bindings for the low level FUSE API. It requires at
-least FUSE 2.8.0 and supports both Python 2.x and 3.x.
+LLFUSE is a set of Python bindings for the low level FUSE API. It
+requires at least FUSE 2.8.0 and supports both Python 2.x and 3.x.
-LLFUSE was originally part of S3QL, but has been factored out so that it can
-be used by other projects as well.
+LLFUSE was originally part of S3QL, but has been factored out so that
+it can be used by other projects as well.
-The SlackBuild detects presence of Python 3.x and if found,
-then also bindings for Python 3.x are built.
+The SlackBuild detects presence of Python 3.x and if found, then also
+bindings for Python 3.x are built.
diff --git a/python/llfuse/llfuse.SlackBuild b/python/llfuse/llfuse.SlackBuild
index c0a50fdccd..1f59dcd46a 100644
--- a/python/llfuse/llfuse.SlackBuild
+++ b/python/llfuse/llfuse.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for "llfuse".
@@ -25,26 +25,36 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=llfuse
-VERSION=${VERSION:-1.1}
+VERSION=${VERSION:-1.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -63,7 +73,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -72,25 +82,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py build_cython
+python3 setup.py build_ext --inplace
+python3 setup.py install --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
cp -a examples Changes.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a doc/html/*.html doc/html/searchindex.js doc/html/_static \
- $PKG/usr/doc/$PRGNAM-$VERSION/html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/llfuse/llfuse.info b/python/llfuse/llfuse.info
index bee4213616..8edb793437 100644
--- a/python/llfuse/llfuse.info
+++ b/python/llfuse/llfuse.info
@@ -1,10 +1,10 @@
PRGNAM="llfuse"
-VERSION="1.1"
-HOMEPAGE="https://bitbucket.org/nikratio/python-llfuse/"
-DOWNLOAD="https://bitbucket.org/nikratio/python-llfuse/downloads/llfuse-1.1.tar.bz2"
-MD5SUM="a11a1bc606511fe0933c3e3d41237f0e"
+VERSION="1.4.1"
+HOMEPAGE="https://github.com/python-llfuse/python-llfuse"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/llfuse-1.4.1.tar.xz"
+MD5SUM="0d1668468601c1a927fa162b99c5c6e8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Marcel Saegebarth"
-EMAIL="marc@mos6581.de"
+MAINTAINER="Andrzej Telszewski"
+EMAIL="atelszewski@gmail.com"
diff --git a/python/llfuse/slack-desc b/python/llfuse/slack-desc
index c34c16103c..574ab75f76 100644
--- a/python/llfuse/slack-desc
+++ b/python/llfuse/slack-desc
@@ -11,7 +11,7 @@ llfuse:
llfuse: LLFUSE is a set of Python bindings for the low level FUSE API.
llfuse: It requires at least FUSE 2.8.0 and supports both Python 2.x and 3.x.
llfuse:
-llfuse: Homepage: https://bitbucket.org/nikratio/python-llfuse/
+llfuse: Homepage: https://github.com/python-llfuse/python-llfuse
llfuse:
llfuse:
llfuse: