summaryrefslogtreecommitdiffstats
path: root/python/jsonpatch
diff options
context:
space:
mode:
Diffstat (limited to 'python/jsonpatch')
-rw-r--r--python/jsonpatch/README19
-rw-r--r--python/jsonpatch/jsonpatch.SlackBuild93
-rw-r--r--python/jsonpatch/jsonpatch.info10
-rw-r--r--python/jsonpatch/slack-desc19
4 files changed, 141 insertions, 0 deletions
diff --git a/python/jsonpatch/README b/python/jsonpatch/README
new file mode 100644
index 0000000000..76b3279e33
--- /dev/null
+++ b/python/jsonpatch/README
@@ -0,0 +1,19 @@
+Applying JSON Patches in Python
+
+Library to apply JSON Patches according to RFC 6902
+
+See source code for examples
+
+ Website: https://github.com/stefankoegl/python-json-patch
+ Repository: https://github.com/stefankoegl/python-json-patch.git
+ Documentation: https://python-json-patch.readthedocs.org/
+ PyPI: https://pypi.python.org/pypi/jsonpatch
+ Travis CI: https://travis-ci.org/stefankoegl/python-json-patch
+ Coveralls: https://coveralls.io/r/stefankoegl/python-json-patch
+
+Running external tests
+
+To run external tests (such as those from
+https://github.com/json-patch/json-patch-tests) use ext_test.py
+
+./ext_tests.py ../json-patch-tests/tests.json
diff --git a/python/jsonpatch/jsonpatch.SlackBuild b/python/jsonpatch/jsonpatch.SlackBuild
new file mode 100644
index 0000000000..6c7da5a7ca
--- /dev/null
+++ b/python/jsonpatch/jsonpatch.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/bash
+
+# Slackware build script for jsonpatch
+
+# Copyright 2020 Alan Aversa <alan_avNOersa@lSPAMavabit.com>
+# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=jsonpatch
+VERSION=${VERSION:-1.33}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/jsonpatch/jsonpatch.info b/python/jsonpatch/jsonpatch.info
new file mode 100644
index 0000000000..8113300f83
--- /dev/null
+++ b/python/jsonpatch/jsonpatch.info
@@ -0,0 +1,10 @@
+PRGNAM="jsonpatch"
+VERSION="1.33"
+HOMEPAGE="https://pypi.org/project/jsonpatch/"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/jsonpatch/jsonpatch-1.33.tar.gz"
+MD5SUM="ed3e8eaa5cce105ad02509d185f0889f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jsonpointer"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"
diff --git a/python/jsonpatch/slack-desc b/python/jsonpatch/slack-desc
new file mode 100644
index 0000000000..6c46b4f613
--- /dev/null
+++ b/python/jsonpatch/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+jsonpatch: jsonpatch (Library to apply JSON Patches according to RFC 6902)
+jsonpatch:
+jsonpatch: https://pypi.org/project/jsonpatch/
+jsonpatch:
+jsonpatch:
+jsonpatch:
+jsonpatch:
+jsonpatch:
+jsonpatch:
+jsonpatch:
+jsonpatch: