summaryrefslogtreecommitdiffstats
path: root/python/decorator/decorator.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/decorator/decorator.SlackBuild')
-rw-r--r--python/decorator/decorator.SlackBuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/python/decorator/decorator.SlackBuild b/python/decorator/decorator.SlackBuild
index b5935c1c03..1290474821 100644
--- a/python/decorator/decorator.SlackBuild
+++ b/python/decorator/decorator.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for decorator
# Copyright 2013 Mikko Värri, Finland
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=decorator
-VERSION=${VERSION:-4.2.1}
+VERSION=${VERSION:-4.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -51,15 +51,17 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.md LICENSE.txt docs/README.rst $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a \
+ CHANGES.md LICENSE.txt docs/README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install