summaryrefslogtreecommitdiffstats
path: root/python/cssutils/cssutils.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/cssutils/cssutils.SlackBuild')
-rw-r--r--python/cssutils/cssutils.SlackBuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/python/cssutils/cssutils.SlackBuild b/python/cssutils/cssutils.SlackBuild
index 6f87b9b307..6b5b98cb72 100644
--- a/python/cssutils/cssutils.SlackBuild
+++ b/python/cssutils/cssutils.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for cssutils
-# Copyright 2009-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=cssutils
-VERSION=${VERSION:-1.0}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,18 +46,20 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Change files from DOS to unix.
for FILE in $(find . -type f -exec grep -Pl '\r$' {} \;); do
- sed -i 's/\r//g' $FILE
+ sed -e 's/\r//g' $FILE > ${FILE}.new
+ touch -r $FILE ${FILE}.new
+ mv ${FILE}.new $FILE
done
# Don't use ez_setup. Use system setuptools or fail.
@@ -65,12 +67,12 @@ sed -i '/ez_setup/d' setup.py
python setup.py install --root=$PKG
-if $(python3 -c 'import setuptools' 2>/dev/null); then
+if [ "${PYTHON3:-no}" == "yes" ]; then
rm -rf build
python3 setup.py install --root=$PKG
fi
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION