summaryrefslogtreecommitdiffstats
path: root/python/backcall
diff options
context:
space:
mode:
Diffstat (limited to 'python/backcall')
-rw-r--r--python/backcall/README7
-rw-r--r--python/backcall/backcall.SlackBuild21
-rw-r--r--python/backcall/backcall.info8
3 files changed, 23 insertions, 13 deletions
diff --git a/python/backcall/README b/python/backcall/README
index e3a5896482..7fb4acb0fb 100644
--- a/python/backcall/README
+++ b/python/backcall/README
@@ -1,3 +1,4 @@
-backcall is a Python module to write backwards compatible callback APIs. That
-is, you can add parameters to your calls without breaking third party callback
-functions that don't expect those newer parameters.
+backcall is a Python module to write backwards compatible callback
+APIs. That is, you can add parameters to your calls without breaking
+third party callback functions that don't expect those newer
+parameters.
diff --git a/python/backcall/backcall.SlackBuild b/python/backcall/backcall.SlackBuild
index bfde1381e4..b8a232e5ea 100644
--- a/python/backcall/backcall.SlackBuild
+++ b/python/backcall/backcall.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for backcall
-# Copyright 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2018-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=backcall
-VERSION=${VERSION:-0.1.0}
+VERSION=${VERSION:-0.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,7 +79,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -85,4 +94,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/backcall/backcall.info b/python/backcall/backcall.info
index 989b462454..2d6d2695b5 100644
--- a/python/backcall/backcall.info
+++ b/python/backcall/backcall.info
@@ -1,10 +1,10 @@
PRGNAM="backcall"
-VERSION="0.1.0"
+VERSION="0.2.0"
HOMEPAGE="https://github.com/takluyver/backcall"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/b/backcall/backcall-0.1.0.tar.gz"
-MD5SUM="87ce0c7839808e6a3427d57df6a792e7"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/b/backcall/backcall-0.2.0.tar.gz"
+MD5SUM="1f4c9a370c78743406296f48e56e8821"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3"
+REQUIRES=""
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"