summaryrefslogtreecommitdiffstats
path: root/python/babel/babel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/babel/babel.SlackBuild')
-rw-r--r--python/babel/babel.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/python/babel/babel.SlackBuild b/python/babel/babel.SlackBuild
index d2620a6aad..e7df1501c2 100644
--- a/python/babel/babel.SlackBuild
+++ b/python/babel/babel.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=babel
VERSION=${VERSION:-1.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -54,6 +54,8 @@ else
LIBDIRSUFFIX=""
fi
+CLDRVER=${CLDRVER:-23.1}
+
set -e
rm -rf $PKG
@@ -64,11 +66,13 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ln -s $CWD/core.zip cldr/core-$CLDRVER.zip
+python setup.py import_cldr
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \