summaryrefslogtreecommitdiffstats
path: root/python/artifacts/artifacts.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/artifacts/artifacts.SlackBuild')
-rw-r--r--python/artifacts/artifacts.SlackBuild31
1 files changed, 21 insertions, 10 deletions
diff --git a/python/artifacts/artifacts.SlackBuild b/python/artifacts/artifacts.SlackBuild
index fdef0ad23f..a0d3ad51d3 100644
--- a/python/artifacts/artifacts.SlackBuild
+++ b/python/artifacts/artifacts.SlackBuild
@@ -1,7 +1,7 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for artifacts
-# Copyright 2016-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2016-2023 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,18 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated to version 20190113, March 2019
+# Updated to version 20230413, July 2023
+
+# 20220408 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - get rid of /usr/share/doc.
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=artifacts
-VERSION=${VERSION:-20190113}
+VERSION=${VERSION:-20230413}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +42,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -66,21 +76,22 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+rm -rf $PKG/usr/share/doc
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKNOWLEDGEMENTS AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE