summaryrefslogtreecommitdiffstats
path: root/python/arrow
diff options
context:
space:
mode:
Diffstat (limited to 'python/arrow')
-rw-r--r--python/arrow/README12
-rw-r--r--python/arrow/arrow.SlackBuild24
-rw-r--r--python/arrow/arrow.info8
3 files changed, 27 insertions, 17 deletions
diff --git a/python/arrow/README b/python/arrow/README
index eff6722e05..211b7fe68b 100644
--- a/python/arrow/README
+++ b/python/arrow/README
@@ -1,6 +1,6 @@
-Arrow is a Python library that offers a sensible, human-friendly approach to
-creating, manipulating, formatting and converting dates, times, and
-timestamps. It implements and updates the datetime type, plugging gaps in
-functionality, and provides an intelligent module API that supports many
-common creation scenarios. Simply put, it helps you work with dates and times
-with fewer imports and a lot less code.
+Arrow is a Python library that offers a sensible, human-friendly
+approach to creating, manipulating, formatting and converting dates,
+times, and timestamps. It implements and updates the datetime type,
+plugging gaps in functionality, and provides an intelligent module API
+that supports many common creation scenarios. Simply put, it helps you
+work with dates and times with fewer imports and a lot less code.
diff --git a/python/arrow/arrow.SlackBuild b/python/arrow/arrow.SlackBuild
index f074f422d7..0529989a9d 100644
--- a/python/arrow/arrow.SlackBuild
+++ b/python/arrow/arrow.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for arrow
-# Copyright 2018-2019 Jostein Berntsen <jbernts@broadpark.no>
+# Copyright 2018-2021 Jostein Berntsen <jvbernts@online.no>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,12 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Written by Jostein Berntsen <jbernts@broadpark.no>
+# Written by Jostein Berntsen <jvbernts@onlne.no>
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=arrow
-VERSION=${VERSION:-0.15.2}
+VERSION=${VERSION:-0.17.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -37,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -71,7 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -84,4 +94,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/arrow/arrow.info b/python/arrow/arrow.info
index 3feb0f1089..cdb8d13ca9 100644
--- a/python/arrow/arrow.info
+++ b/python/arrow/arrow.info
@@ -1,10 +1,10 @@
PRGNAM="arrow"
-VERSION="0.15.2"
+VERSION="0.17.0"
HOMEPAGE="https://github.com/crsmithdev/arrow"
-DOWNLOAD="https://github.com/crsmithdev/arrow/archive/0.15.2/arrow-0.15.2.tar.gz"
-MD5SUM="33bc3e0628cc3dfaa6b3817998b1f9b2"
+DOWNLOAD="https://github.com/crsmithdev/arrow/archive/0.17.0/arrow-0.17.0.tar.gz"
+MD5SUM="a8795efc47828c59d0a9724dcefc3e44"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="functools-lru-cache"
MAINTAINER="Jostein Berntsen"
-EMAIL="jbernts@broadpark.no"
+EMAIL="jvbernts@online.no"