summaryrefslogtreecommitdiffstats
path: root/perl/perl-Net-Pcap
diff options
context:
space:
mode:
Diffstat (limited to 'perl/perl-Net-Pcap')
-rw-r--r--perl/perl-Net-Pcap/README10
-rw-r--r--perl/perl-Net-Pcap/makefile.patch43
-rw-r--r--perl/perl-Net-Pcap/pcapapi.patch11
-rw-r--r--perl/perl-Net-Pcap/perl-Net-Pcap.SlackBuild26
-rw-r--r--perl/perl-Net-Pcap/perl-Net-Pcap.info6
5 files changed, 37 insertions, 59 deletions
diff --git a/perl/perl-Net-Pcap/README b/perl/perl-Net-Pcap/README
index 44d3bf7f20..76c9266d87 100644
--- a/perl/perl-Net-Pcap/README
+++ b/perl/perl-Net-Pcap/README
@@ -1,5 +1,5 @@
-Net::Pcap is a Perl binding to the LBL pcap(3) library. The README for libpcap
-describes itself as "a system-independent interface for user-level packet
-capture. libpcap provides a portable framework for low-level network
-monitoring. Applications include network statistics collection, security
-monitoring, network debugging, etc."
+Net::Pcap is a Perl binding to the LBL pcap(3) library. The README
+for libpcap describes itself as "a system-independent interface for
+user-level packet capture. libpcap provides a portable framework for
+low-level network monitoring. Applications include network statistics
+collection, security monitoring, network debugging, etc."
diff --git a/perl/perl-Net-Pcap/makefile.patch b/perl/perl-Net-Pcap/makefile.patch
deleted file mode 100644
index 4825457cde..0000000000
--- a/perl/perl-Net-Pcap/makefile.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff -up Net-Pcap-0.17/Makefile.PL.orig Net-Pcap-0.17/Makefile.PL
---- Net-Pcap-0.17/Makefile.PL.orig 2013-03-15 21:00:34.000000000 -0600
-+++ Net-Pcap-0.17/Makefile.PL 2013-03-15 21:00:47.000000000 -0600
-@@ -63,39 +63,6 @@ Or get and install the WinPcap developer
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- REASON
-
--} else { # other systems (Unix)
-- warn <<"REASON" and exit unless have_library('pcap');
-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--You appear to lack the pcap(3) library. \a
--
--If it is installed in a non-standard location, please try setting the LIBS
--and INC values on the command line.
--
--Or get the sources and install the pcap library from http://www.tcpdump.org/
--
--If you install the pcap library using a system package, make sure to also
--install the corresponding -devel package, which contains the C headers needed
--to compile this module.
-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--REASON
--
-- warn <<"REASON" unless have_library('pcap', 'pcap_lib_version');
-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--You appear to have an old version of the pcap library. \a
--
--This module need a recent version of the pcap library in order to provide
--access to all its features. You can still compile it with your old pcap
--library but some functions won't be available, and trying to use them in
--Perl programs will generate errors. Programs only using the old functions
--should perform as previously. If not, don't hesitate to fill a bug.
--
--You can get the latest sources of the pcap library at http://www.tcpdump.org/
--
--If you install the pcap library using a system package, make sure to also
--install the corresponding -devel package, which contains the C headers needed
--to compile this module.
-- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
--REASON
- }
-
- # Now trying to detect which functions are actually available.
diff --git a/perl/perl-Net-Pcap/pcapapi.patch b/perl/perl-Net-Pcap/pcapapi.patch
new file mode 100644
index 0000000000..0ac25c3201
--- /dev/null
+++ b/perl/perl-Net-Pcap/pcapapi.patch
@@ -0,0 +1,11 @@
+diff -up Net-Pcap-0.18/Makefile.PL.orig Net-Pcap-0.18/Makefile.PL
+--- Net-Pcap-0.18/Makefile.PL.orig 2019-06-13 00:50:15.000000000 -0600
++++ Net-Pcap-0.18/Makefile.PL 2019-06-13 01:00:15.000000000 -0600
+@@ -107,6 +107,7 @@ REASON
+ # corresponding tests.
+ my @funcs = have_functions(find_functions());
+ $options{DEFINE} .= cpp_defines(@funcs);
++$options{DEFINE} .= " -DPCAP_API=\"\" -DHAVE_PCAP_OPEN -DHAVE_PCAP_SETSAMPLING";
+ open(FUNCS, '>funcs.txt') or warn "warning: can't write 'funcs.txt': $!\n";
+ print FUNCS join("\n", @funcs), "\n";
+ close(FUNCS);
diff --git a/perl/perl-Net-Pcap/perl-Net-Pcap.SlackBuild b/perl/perl-Net-Pcap/perl-Net-Pcap.SlackBuild
index 7004a0b6dc..75e33e6f97 100644
--- a/perl/perl-Net-Pcap/perl-Net-Pcap.SlackBuild
+++ b/perl/perl-Net-Pcap/perl-Net-Pcap.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for perl-Net-Pcap
@@ -22,29 +22,39 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=perl-Net-Pcap
-VERSION=${VERSION:-0.17}
+VERSION=${VERSION:-0.18}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
SRC_PRGNAM=Net-Pcap
DOCS="README"
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -72,8 +82,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/makefile.patch
patch -p1 < $CWD/listdatalinks.patch
+patch -p1 < $CWD/pcapapi.patch
PERL_MM_USE_DEFAULT=1 perl Makefile.PL \
PREFIX=/usr \
@@ -100,4 +110,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/perl/perl-Net-Pcap/perl-Net-Pcap.info b/perl/perl-Net-Pcap/perl-Net-Pcap.info
index 5e2e21439c..fa0a784452 100644
--- a/perl/perl-Net-Pcap/perl-Net-Pcap.info
+++ b/perl/perl-Net-Pcap/perl-Net-Pcap.info
@@ -1,8 +1,8 @@
PRGNAM="perl-Net-Pcap"
-VERSION="0.17"
+VERSION="0.18"
HOMEPAGE="https://metacpan.org/pod/Net::Pcap"
-DOWNLOAD="https://cpan.metacpan.org/authors/id/S/SA/SAPER/Net-Pcap-0.17.tar.gz"
-MD5SUM="fbe911ba5f57d5ba43494434ffb828a0"
+DOWNLOAD="https://cpan.metacpan.org/authors/id/S/SA/SAPER/Net-Pcap-0.18.tar.gz"
+MD5SUM="18d7298dca72b53271d68646c34b6a39"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="perl-IO-Interface"