summaryrefslogtreecommitdiffstats
path: root/office/wps-office
diff options
context:
space:
mode:
Diffstat (limited to 'office/wps-office')
-rw-r--r--office/wps-office/README41
-rw-r--r--office/wps-office/desktop/et.desktop8
-rw-r--r--office/wps-office/desktop/wpdf.desktop8
-rw-r--r--office/wps-office/desktop/wpp.desktop8
-rw-r--r--office/wps-office/desktop/wps.desktop8
-rw-r--r--office/wps-office/slack-desc2
-rw-r--r--office/wps-office/wps-office.SlackBuild90
-rw-r--r--office/wps-office/wps-office.info18
8 files changed, 133 insertions, 50 deletions
diff --git a/office/wps-office/README b/office/wps-office/README
index 83be8d58ea..5f97be812f 100644
--- a/office/wps-office/README
+++ b/office/wps-office/README
@@ -1,6 +1,37 @@
-WPS Office (an office productivity suite for Linux)
+WPS Office: One of the Best Office Solutions for Linux
-WPS Office, including Writer, Presentation and spreadsheets, is a
-powerful office suite. It is deeply compatible with all of the
-latest Microsoft Office file formats. It can easily open and read
-the documents created with Microsoft Office.
+* Free All-in-One Office Suite
+Writer, Spreadsheet, Presentation, and the PDF Toolkit can help you
+solve issues in viewing and editing common document types. Meanwhile,
+the small but feature-rich PDF toolkit can help you convert PDFs from
+and to Word, Excel, PPT, and image files with ease.
+
+Compatible with Various File Formats
+WPS Office supports common document formats. The four components of WPS
+Office will boost your productivity in text processing, data analysis,
+and animation creation.
+
+Excellent Productivity Application for Free
+Writer provides powerful solutions for setting the layout of graphics
+and texts. Spreadsheet possesses an accurate and efficient calculation
+engine. Presentation delivers professional animations and exquisite
+online templates.
+
+NOTE: webcore-fonts
+Having webcore-fonts installed is recommended, otherwise the program
+will complain about missing fonts upon start.
+
+NOTE: themes
+The button for changing themes does not work at the moment.
+
+TROUBLESHOOTING: WPS Office Overriding/Breaks Mime
+* Close all WPS Office programs
+* Open ~/.config/Kingsoft/Office.conf
+* Add the following, just before [kdcsdk]:
+
+ common\do_not_detect_file_association_while_startup=true
+
+* Save the file
+* You may need to also clean WPS Office associated stuff from:
+
+ ~/.local/share/mime/
diff --git a/office/wps-office/desktop/et.desktop b/office/wps-office/desktop/et.desktop
new file mode 100644
index 0000000000..23333c2306
--- /dev/null
+++ b/office/wps-office/desktop/et.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=WPS Spreadsheet
+Comment=WPS Office Spreadsheet
+Exec=et
+Icon=wps-office2019-etmain
+StartupNotify=false
+Type=Application
+Categories=Office
diff --git a/office/wps-office/desktop/wpdf.desktop b/office/wps-office/desktop/wpdf.desktop
new file mode 100644
index 0000000000..009652e8a7
--- /dev/null
+++ b/office/wps-office/desktop/wpdf.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=WPS PDF
+Comment=WPS Office PDF
+Exec=wpspdf
+Icon=wps-office2019-pdfmain
+StartupNotify=false
+Type=Application
+Categories=Office
diff --git a/office/wps-office/desktop/wpp.desktop b/office/wps-office/desktop/wpp.desktop
new file mode 100644
index 0000000000..a053b07809
--- /dev/null
+++ b/office/wps-office/desktop/wpp.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=WPS Presentations
+Comment=WPS Office Presentations
+Exec=wpp
+Icon=wps-office2019-wppmain
+StartupNotify=false
+Type=Application
+Categories=Office
diff --git a/office/wps-office/desktop/wps.desktop b/office/wps-office/desktop/wps.desktop
new file mode 100644
index 0000000000..40b2a3f802
--- /dev/null
+++ b/office/wps-office/desktop/wps.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=WPS Writer
+Comment=WPS Office Writer
+Exec=wps
+Icon=wps-office2019-wpsmain
+StartupNotify=false
+Type=Application
+Categories=Office
diff --git a/office/wps-office/slack-desc b/office/wps-office/slack-desc
index 504125ebdc..9965fe408d 100644
--- a/office/wps-office/slack-desc
+++ b/office/wps-office/slack-desc
@@ -13,7 +13,7 @@ wps-office: powerful office suite. It is deeply compatible with all of the
wps-office: latest Microsoft Office file formats. It can easily open and read
wps-office: the documents created with Microsoft Office.
wps-office:
+wps-office: Homepage: https://linux.wps.com/
wps-office:
wps-office:
-wps-office: Homepage: http://wps-community.org/
wps-office:
diff --git a/office/wps-office/wps-office.SlackBuild b/office/wps-office/wps-office.SlackBuild
index bd007aa160..e77d76e0f5 100644
--- a/office/wps-office/wps-office.SlackBuild
+++ b/office/wps-office/wps-office.SlackBuild
@@ -1,7 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for wps-office
+# Copyright 2023 Petar Petrov, slackalaxy at gmail dot com
# Copyright 2016 Andre Fernando, Indonesia
# All rights reserved.
#
@@ -22,62 +23,81 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230627 bkw: Modified by SlackBuilds.org, BUILD=3:
+# - install all shared libaries with +x permission.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=wps-office
-VERSION=${VERSION:-10.1.0.6758}
+VERSION=${VERSION:-11.1.0.11711.XA}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
-ARCH=${ARCH:-$(uname -m)}
-case "$ARCH" in
- i?86) ARCH=i586; SRCARCH=x86 ;;
- x86_64) SRCARCH=x86_64 ;;
- *) echo "$ARCH is not supported"; exit 1 ;;
-esac
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=x86_64 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
-CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" != "x86_64" ]; then
+ printf "\n\n$ARCH is not supported... \n"
+ exit 1
+fi
+
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-
-SRCNAM=wps-office
-SRCVER=_10.1.0.6758_$SRCARCH
-DESTDIR=$PKG/opt/kingsoft
-
-mkdir -p $DESTDIR/$PRGNAM
cd $TMP
-tar xJvf $CWD/$PRGNAM$SRCVER.tar.xz
-chown -R root:root $PRGNAM$SRCVER
-find -L $PRGNAM$SRCVER \
+rm -rf $PRGNAM
+mkdir -p $PRGNAM
+cd $PRGNAM
+ar -x $CWD/${PRGNAM}_${VERSION}_amd64.deb
+tar xvf data.tar.xz
+
+chown -R root:root .
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+# No WPS submenus, automatic file associations or redundant fonts (DejaVuMathTeXGyre.ttf)
+cp -a opt $PKG
-mkdir -p $PKG/usr/bin/
-install -D -m 0755 $PRGNAM$SRCVER/wps $PKG/usr/bin/wps
-install -D -m 0755 $PRGNAM$SRCVER/wpp $PKG/usr/bin/wpp
-install -D -m 0755 $PRGNAM$SRCVER/et $PKG/usr/bin/et
+mkdir -p $PKG/usr
+cp -a usr/bin $PKG/usr
-mkdir -p $PKG/usr/share/applications
-mv $PRGNAM$SRCVER/resource/applications/* $PKG/usr/share/applications
+# use our desktop files
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+cp --no-preserve=mode,ownership $CWD/desktop/*.desktop $PKG/usr/share/applications
+cp -a usr/share/icons/hicolor/48x48/mimetypes/wps-office2019-* $PKG/usr/share/pixmaps
-mkdir -p $PKG/usr/share/icons
-mv $PRGNAM$SRCVER/resource/icons/* $PKG/usr/share/icons
+chmod 0644 $PKG/usr/share/pixmaps/wps-office2019-*
-mkdir -p $PKG/usr/share/mime
-mv $PRGNAM$SRCVER/resource/mime/* $PKG/usr/share/mime
+find $PKG -print0 | xargs -0 file -m /etc/file/magic/elf \
+ | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : > .tmpfind.$$
+xargs strip --strip-unneeded < .tmpfind.$$ 2> /dev/null || true
+xargs chmod 755 < .tmpfind.$$ 2> /dev/null || true
-mkdir -p $PKG/usr/share/licenses/$PRGNAM-$VERSION
-install -D -m 0644 $PRGNAM$SRCVER/office6/mui/default/EULA.txt $PKG/usr/share/licenses/$PRGNAM-$VERSION/EULA.txt
-mv $PRGNAM$SRCVER/office6 $DESTDIR/$PRGNAM
+# Thanks to NixOS (https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/office/wpsoffice/default.nix)
+# distribution is missing libkappessframework.so, so remove the following dead libraries
+rm -r $PKG/opt/kingsoft/wps-office/office6/addons/pdfbatchcompression
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $PRGNAM$SRCVER/README.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -85,4 +105,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/wps-office/wps-office.info b/office/wps-office/wps-office.info
index 020a58123a..4f9a82beac 100644
--- a/office/wps-office/wps-office.info
+++ b/office/wps-office/wps-office.info
@@ -1,10 +1,10 @@
PRGNAM="wps-office"
-VERSION="10.1.0.6758"
-HOMEPAGE="http://wps-community.org/"
-DOWNLOAD="http://kdl.cc.ksosoft.com/wps-community/download/6758/wps-office_10.1.0.6758_x86.tar.xz"
-MD5SUM="81c65baf56618df39de24969ce02395b"
-DOWNLOAD_x86_64="http://kdl.cc.ksosoft.com/wps-community/download/6758/wps-office_10.1.0.6758_x86_64.tar.xz"
-MD5SUM_x86_64="2e488dffaa5cb56457b938b85f6349bf"
-REQUIRES="libpng-legacy12"
-MAINTAINER="Andre Fernando"
-EMAIL="ando344@gmail.com"
+VERSION="11.1.0.11711.XA"
+HOMEPAGE="https://linux.wps.com/"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://wdl1.pcfg.cache.wpscdn.com/wpsdl/wpsoffice/download/linux/11711/wps-office_11.1.0.11711.XA_amd64.deb"
+MD5SUM_x86_64="0b9546537df86d63c1f08e0d2ae20b5e"
+REQUIRES=""
+MAINTAINER="Petar Petrov"
+EMAIL="slackalaxy@gmail.com"