summaryrefslogtreecommitdiffstats
path: root/office/task
diff options
context:
space:
mode:
Diffstat (limited to 'office/task')
-rw-r--r--office/task/README10
-rw-r--r--office/task/task.SlackBuild42
-rw-r--r--office/task/task.info8
3 files changed, 46 insertions, 14 deletions
diff --git a/office/task/README b/office/task/README
index 492df083fc..8c4fafc6fa 100644
--- a/office/task/README
+++ b/office/task/README
@@ -1,4 +1,6 @@
-task (a.k.a taskwarrior) is an advanced task manager for the console with an
-extensive set of features. task manages your TODO list from the command line.
-It is flexible, fast, and unobtrusive. It does its job then gets out of your
-way.
+task (a.k.a taskwarrior) is an advanced task manager for the console
+with an extensive set of features. task manages your TODO list from the
+command line.
+
+It is flexible, fast, and unobtrusive. It does its job then gets out of
+your way.
diff --git a/office/task/task.SlackBuild b/office/task/task.SlackBuild
index 672c63caef..65511ff223 100644
--- a/office/task/task.SlackBuild
+++ b/office/task/task.SlackBuild
@@ -1,13 +1,36 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for task
-# Written by Jostein Berntsen <jbernts@broadpark.no>
+# Copyright 2018-2022 by Jostein Berntsen <jvbernts@online.no>
+
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=task
-VERSION=${VERSION:-2.5.1}
+VERSION=${VERSION:-2.6.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -17,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -71,7 +101,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
find $PKG -depth -type d -empty -delete || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CMakeLists.txt COPYING ChangeLog DEVELOPER EXPOSITION INSTALL LICENSE NEWS README.md \
+cp -a AUTHORS CMakeLists.txt COPYING ChangeLog INSTALL LICENSE NEWS README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -79,4 +109,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/task/task.info b/office/task/task.info
index a92e20c587..fb9f01efd5 100644
--- a/office/task/task.info
+++ b/office/task/task.info
@@ -1,10 +1,10 @@
PRGNAM="task"
-VERSION="2.5.1"
+VERSION="2.6.2"
HOMEPAGE="http://www.taskwarrior.org"
-DOWNLOAD="https://taskwarrior.org/download/task-2.5.1.tar.gz"
-MD5SUM="bcd984a00d6d1eb6b40faf567419f784"
+DOWNLOAD="https://taskwarrior.org/download/task-2.6.2.tar.gz"
+MD5SUM="a9e69fd612e8ad538b9f512c80b18122"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="lua"
MAINTAINER="Jostein Berntsen"
-EMAIL="jbernts@broadpark.no"
+EMAIL="jvbernts@online.no"