summaryrefslogtreecommitdiffstats
path: root/office/minidjvu
diff options
context:
space:
mode:
Diffstat (limited to 'office/minidjvu')
-rw-r--r--office/minidjvu/README16
-rw-r--r--office/minidjvu/minidjvu.SlackBuild35
-rw-r--r--office/minidjvu/minidjvu.info6
-rw-r--r--office/minidjvu/minidjvu.patch66
4 files changed, 35 insertions, 88 deletions
diff --git a/office/minidjvu/README b/office/minidjvu/README
index c61205d059..077fceba3e 100644
--- a/office/minidjvu/README
+++ b/office/minidjvu/README
@@ -1,9 +1,11 @@
-Minidjvu is a command line utility which encodes and decodes single page
-black-and-white DjVu files, and can compress multiple pages, taking advantage
-from similarities between pages.
+Minidjvu is a command line utility which encodes and decodes single
+page black-and-white DjVu files, and can compress multiple pages,
+taking advantage from similarities between pages.
-Supported bitmap formats are PBM, Windows BMP, and TIFF (through libtiff).
+Supported bitmap formats are PBM, Windows BMP, and TIFF (through
+libtiff).
-Minidjvu is based on DjVuLibre, which is the primary DjVu support library.
-Minidjvu is not going to support all DjVu functionality; the idea is rather to
-take the black-and-white part (also called JB2) and experiment with it.
+Minidjvu is based on DjVuLibre, which is the primary DjVu support
+library. Minidjvu is not going to support all DjVu functionality;
+the idea is rather to take the black-and-white part (also called JB2)
+and experiment with it.
diff --git a/office/minidjvu/minidjvu.SlackBuild b/office/minidjvu/minidjvu.SlackBuild
index 55c24739b9..89fa014622 100644
--- a/office/minidjvu/minidjvu.SlackBuild
+++ b/office/minidjvu/minidjvu.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for minidjvu
-# Copyright 2015-2016 Alexander Verbovetsky, Moscow, Russia
+# Copyright 2015-2022 Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=minidjvu
-VERSION=${VERSION:-0.8.svn.2010.05.06}
+VERSION=${VERSION:-0.8.svn.2010.05.06_20210826_2202ebc}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+COMMIT=2202ebc8eac5804521bd943fe65b8453d0ceb7d9
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +39,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -59,9 +67,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,17 +77,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/minidjvu.patch
-
+autoreconf --install
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --mandir=/usr/man \
--enable-static=no \
--build=$ARCH-slackware-linux
-make -j1
+make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -89,11 +98,13 @@ find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING INSTALL NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -f $PKG/usr/lib*/*.la
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/minidjvu/minidjvu.info b/office/minidjvu/minidjvu.info
index dae3f1cb1f..ad650f44a9 100644
--- a/office/minidjvu/minidjvu.info
+++ b/office/minidjvu/minidjvu.info
@@ -1,8 +1,8 @@
PRGNAM="minidjvu"
-VERSION="0.8.svn.2010.05.06"
+VERSION="0.8.svn.2010.05.06_20210826_2202ebc"
HOMEPAGE="http://minidjvu.sourceforge.net"
-DOWNLOAD="http://sourceforge.net/projects/slackbuildsdirectlinks/files/minidjvu/minidjvu_0.8.svn.2010.05.06.orig.tar.gz"
-MD5SUM="c29f5c86267824f6c9047f2759a4ad5f"
+DOWNLOAD="https://github.com/barak/minidjvu/archive/2202ebc/minidjvu-2202ebc8eac5804521bd943fe65b8453d0ceb7d9.tar.gz"
+MD5SUM="cb565dc8028b4cd1fc3357f9c54d7650"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/office/minidjvu/minidjvu.patch b/office/minidjvu/minidjvu.patch
deleted file mode 100644
index fc3111422b..0000000000
--- a/office/minidjvu/minidjvu.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-diff -Naur minidjvu-0.8.svn.2010.05.06.orig/include/minidjvu/alg/smooth.h minidjvu-0.8.svn.2010.05.06/include/minidjvu/alg/smooth.h
---- minidjvu-0.8.svn.2010.05.06.orig/include/minidjvu/alg/smooth.h 2010-08-02 17:15:58.000000000 +0400
-+++ minidjvu-0.8.svn.2010.05.06/include/minidjvu/alg/smooth.h 2015-12-02 03:12:43.000000000 +0300
-@@ -4,7 +4,7 @@
-
-
- /*
-- * `smooth' is applied to a bitmap even before it's splitted.
-+ * `smooth' is applied to a bitmap even before it's split.
- *
- * Right now, the algorithm flips pixels which are surrounded
- * by at least 3 of 4 neighboring pixels of another color.
-diff -Naur minidjvu-0.8.svn.2010.05.06.orig/Makefile.in minidjvu-0.8.svn.2010.05.06/Makefile.in
---- minidjvu-0.8.svn.2010.05.06.orig/Makefile.in 2010-08-02 17:15:58.000000000 +0400
-+++ minidjvu-0.8.svn.2010.05.06/Makefile.in 2015-12-02 02:18:36.000000000 +0300
-@@ -8,7 +8,7 @@
- manpage:=@PACKAGE_NAME@
-
- DOCDIR:=doc
--MANDIR:=$(prefix)/share/man/man1
-+MANDIR:=$(prefix)/man/man1
- INCLUDEDIR:=$(prefix)/include
- SUBDIRS:=src \
- po \
-@@ -71,7 +71,7 @@
- ${GZIP} -nf -9 ${DESTDIR}$(MANDIR)/$(manpage).1
- for dir in $(DOCDIR)/*/; do \
- if [ -f $${dir}$(manpage).1 ]; then \
-- LOCMANDIR=${DESTDIR}$(prefix)/share/man$${dir#$(DOCDIR)}/man1 &&\
-+ LOCMANDIR=${DESTDIR}$(prefix)/man$${dir#$(DOCDIR)}/man1 &&\
- ${INSTALL} -d $${LOCMANDIR} &&\
- ${INSTALL_DATA} $${dir}$(manpage).1 $${LOCMANDIR} && \
- ${GZIP} -nf -9 $${LOCMANDIR}/$(manpage).1; \
-@@ -91,7 +91,7 @@
- ${RM} ${DESTDIR}$(MANDIR)/$(manpage).1.gz
- for dir in $(DOCDIR)/*/; do \
- if [ -f $${dir}$(manpage).1 ]; then \
-- LOCMANDIR=${DESTDIR}$(prefix)/share/man$${dir#$(DOCDIR)}/man1 &&\
-+ LOCMANDIR=${DESTDIR}$(prefix)/man$${dir#$(DOCDIR)}/man1 &&\
- ${RM} $${LOCMANDIR}/$(manpage).1.gz; \
- fi; \
- done
-diff -Naur minidjvu-0.8.svn.2010.05.06.orig/po/ru.po minidjvu-0.8.svn.2010.05.06/po/ru.po
---- minidjvu-0.8.svn.2010.05.06.orig/po/ru.po 2010-08-02 17:15:58.000000000 +0400
-+++ minidjvu-0.8.svn.2010.05.06/po/ru.po 2015-12-02 03:12:43.000000000 +0300
-@@ -239,7 +239,7 @@
-
- #: minidjvu.c:361
- #, c-format
--msgid "the splitted image has %d pieces\n"
-+msgid "the split image has %d pieces\n"
- msgstr "после разбиения картинка состоит из %d участков\n"
-
- #: minidjvu.c:366
-diff -Naur minidjvu-0.8.svn.2010.05.06.orig/tools/minidjvu.c minidjvu-0.8.svn.2010.05.06/tools/minidjvu.c
---- minidjvu-0.8.svn.2010.05.06.orig/tools/minidjvu.c 2010-08-02 17:15:58.000000000 +0400
-+++ minidjvu-0.8.svn.2010.05.06/tools/minidjvu.c 2015-12-02 03:12:43.000000000 +0300
-@@ -360,7 +360,7 @@
- mdjvu_bitmap_destroy(bitmap);
- if (verbose)
- {
-- printf(_("the splitted image has %d pieces\n"),
-+ printf(_("the split image has %d pieces\n"),
- mdjvu_image_get_blit_count(image));
- }
- if (clean)