summaryrefslogtreecommitdiffstats
path: root/office/krop
diff options
context:
space:
mode:
Diffstat (limited to 'office/krop')
-rw-r--r--office/krop/README15
-rw-r--r--office/krop/krop.SlackBuild49
-rw-r--r--office/krop/krop.info8
-rw-r--r--office/krop/slack-desc8
4 files changed, 40 insertions, 40 deletions
diff --git a/office/krop/README b/office/krop/README
index 780083460d..c6c208c595 100644
--- a/office/krop/README
+++ b/office/krop/README
@@ -1,7 +1,16 @@
-Krop is a simple graphical tool to crop the pages of PDF files. It is
-written in Python and relies on PyQt, python-poppler-qt4, and PyPDF for
-its functionality. It features automatic margin cropping.
+krop is a simple graphical tool to crop the pages of PDF files.
+
+It is written in Python and relies on python-poppler-qt5 or
+python3-PyMuPDF for rendering, and pypdf/python3-PyPDF2 or pikepdf or
+python3-PyMuPDF for cropping. It features automatic margin cropping.
Krop can automatically split pages into subpages to fit the limited
screen size of devices such as eReaders. This is particularly useful, if
your eReader does not support convenient scrolling.
+
+This script has no build dependencies.
+
+Two runtime dependencies to be choosen from the following options:
+* python-poppler-qt5 or python3-PyMuPDF
+* pypdf (version > 3) or python3-PyPDF2 or pikepdf or python3-PyMuPDF
+They are autodetected or set manually using options.
diff --git a/office/krop/krop.SlackBuild b/office/krop/krop.SlackBuild
index 9c49d8e7cd..44d0c56cb5 100644
--- a/office/krop/krop.SlackBuild
+++ b/office/krop/krop.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for krop
-# Copyright 2018, Alexander Verbovetsky, Moscow, Russia
+# Copyright 2018-2024, Alexander Verbovetsky, Moscow, Russia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=krop
-VERSION=${VERSION:-0.5.1}
+VERSION=${VERSION:-0.6.1_e96d42b}
+COMMIT="e96d42b2f1ab4317efe37cab498b708663bc104c"
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,33 +39,23 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,11 +63,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-sed -i 's/import sys.*/&\nsys.argv.append("--no-qt5")/' krop/config.py
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -81,8 +71,9 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/share/applications
install -m 0644 -o root -g root krop.desktop $PKG/usr/share/applications/
-mkdir -p $PKG/usr/man/man1
-gzip -c9 krop.1 > $PKG/usr/man/man1/krop.1.gz
+mv $PKG/usr/share/man $PKG/usr
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ChangeLog README.md TODO $PKG/usr/doc/$PRGNAM-$VERSION
@@ -93,4 +84,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/krop/krop.info b/office/krop/krop.info
index 27b6f3f9de..bd03c0a489 100644
--- a/office/krop/krop.info
+++ b/office/krop/krop.info
@@ -1,10 +1,10 @@
PRGNAM="krop"
-VERSION="0.5.1"
+VERSION="0.6.1_e96d42b"
HOMEPAGE="http://arminstraub.com/computer/krop"
-DOWNLOAD="https://github.com/arminstraub/krop/archive/v0.5.1/krop-0.5.1.tar.gz"
-MD5SUM="ce3043ce29462d89c69e37d08097ab73"
+DOWNLOAD="https://github.com/arminstraub/krop/archive/e96d42b/krop-e96d42b2f1ab4317efe37cab498b708663bc104c.tar.gz"
+MD5SUM="9ddb0caa00585882e4d3b081bf5b3b4f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-poppler-qt4 PyPDF2"
+REQUIRES="%README% python-poppler-qt5 python3-pypdf"
MAINTAINER="Alexander Verbovetsky"
EMAIL="alik@ejik.org"
diff --git a/office/krop/slack-desc b/office/krop/slack-desc
index 70a7966932..16e3c34354 100644
--- a/office/krop/slack-desc
+++ b/office/krop/slack-desc
@@ -8,12 +8,12 @@
|-----handy-ruler------------------------------------------------------|
krop: krop (a tool to crop pdf files)
krop:
-krop: Krop is a simple graphical tool to crop the pages of PDF files. It is
-krop: written in Python and relies on PyQt, python-poppler-qt4, and PyPDF
-krop: for its functionality. It features automatic margin cropping.
+krop: krop is a simple graphical tool to crop the pages of PDF files. It is
+krop: written in Python and relies on python-poppler-qt5 or PyMuPDF for
+krop: rendering, and pypdf/PyPDF2 or pikepdf or PyMuPDF for cropping. It
+krop: features automatic margin cropping.
krop:
krop:
krop: Homepage: http://arminstraub.com/computer/krop
krop:
krop:
-krop: