summaryrefslogtreecommitdiffstats
path: root/office/hunspell-en
diff options
context:
space:
mode:
Diffstat (limited to 'office/hunspell-en')
-rw-r--r--office/hunspell-en/README3
-rw-r--r--office/hunspell-en/hunspell-en.SlackBuild19
-rw-r--r--office/hunspell-en/hunspell-en.info26
3 files changed, 30 insertions, 18 deletions
diff --git a/office/hunspell-en/README b/office/hunspell-en/README
index 83348c76d6..20a66b833e 100644
--- a/office/hunspell-en/README
+++ b/office/hunspell-en/README
@@ -1,7 +1,8 @@
In this package are five dictionaries of English usage - Australian,
Canadian, United States, and two forms of British English.
-The reason I've included two forms of British English dictionaries are:
+The reason the previous maintainer, Donald Cooley <chytraeu@sdf.org>,
+included two forms of British English dictionaries are:
1. The -ise suffix is more commonly used by British speakers and all
other forms such as en_DK, en_IE, en_IN, etc are symbolic links to
en_GB-ise.
diff --git a/office/hunspell-en/hunspell-en.SlackBuild b/office/hunspell-en/hunspell-en.SlackBuild
index 2f7c757d63..70b58ce65d 100644
--- a/office/hunspell-en/hunspell-en.SlackBuild
+++ b/office/hunspell-en/hunspell-en.SlackBuild
@@ -1,9 +1,10 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for hunspell-en
# Copyright 2014, Pablo Santamaria (pablosantamaria@gmail.com)
# Copyright 2017-2019 Donald Cooley South Haven, IN USA
+# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,13 +26,23 @@
# Based on the Arch PKGBUILD
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=hunspell-en
-VERSION=${VERSION:-2018.04.16}
+VERSION=${VERSION:-2020.12.07}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
ARCH="noarch"
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -85,4 +96,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/hunspell-en/hunspell-en.info b/office/hunspell-en/hunspell-en.info
index 91968fc37f..9f12507dfa 100644
--- a/office/hunspell-en/hunspell-en.info
+++ b/office/hunspell-en/hunspell-en.info
@@ -1,18 +1,18 @@
PRGNAM="hunspell-en"
-VERSION="2018.04.16"
+VERSION="2020.12.07"
HOMEPAGE="http://wordlist.aspell.net/dicts/"
-DOWNLOAD="http://downloads.sourceforge.net/wordlist/hunspell-en_AU-2018.04.16.zip \
- http://downloads.sourceforge.net/wordlist/hunspell-en_CA-2018.04.16.zip \
- http://sourceforge.net/projects/wordlist/files/speller/2018.04.16/hunspell-en_GB-ise-2018.04.16.zip \
- http://sourceforge.net/projects/wordlist/files/speller/2018.04.16/hunspell-en_GB-ize-2018.04.16.zip \
- http://downloads.sourceforge.net/wordlist/hunspell-en_US-2018.04.16.zip"
-MD5SUM="e1a9c9cf76effc073354688ba86c7702 \
- 3cded9c03cbed3422ad51bbd8199ee42 \
- 2c7cc43290b5a7e25397227a285bab6f \
- 06e61c1ff7a23e33daa1a7d4b4e37928 \
- 266fae31d899f7682bc81d9b0aa5832e"
+DOWNLOAD="http://downloads.sourceforge.net/wordlist/hunspell-en_AU-2020.12.07.zip \
+ http://downloads.sourceforge.net/wordlist/hunspell-en_CA-2020.12.07.zip \
+ http://sourceforge.net/projects/wordlist/files/speller/2020.12.07/hunspell-en_GB-ise-2020.12.07.zip \
+ http://sourceforge.net/projects/wordlist/files/speller/2020.12.07/hunspell-en_GB-ize-2020.12.07.zip \
+ http://downloads.sourceforge.net/wordlist/hunspell-en_US-2020.12.07.zip"
+MD5SUM="da1c2bfb35010f7345925acd29596d13 \
+ f28b8cb3e6dad9d4f53e849b5df80184 \
+ 1c0d38766cd35c41e80b50f42ceecfba \
+ a42fdc0df347800f2db26566a30ab3e5 \
+ 38bfa805038da266c37d3a2d2db23972"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Donald Cooley"
-EMAIL="chytraeu@sdf.org"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"