summaryrefslogtreecommitdiffstats
path: root/office/calibre
diff options
context:
space:
mode:
Diffstat (limited to 'office/calibre')
-rw-r--r--office/calibre/calibre.SlackBuild6
-rw-r--r--office/calibre/calibre.info8
-rw-r--r--office/calibre/patches/remove-desktop-integration.patch13
3 files changed, 12 insertions, 15 deletions
diff --git a/office/calibre/calibre.SlackBuild b/office/calibre/calibre.SlackBuild
index 048798bcf9..488e897249 100644
--- a/office/calibre/calibre.SlackBuild
+++ b/office/calibre/calibre.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=calibre
-VERSION=${VERSION:-3.34.0}
+VERSION=${VERSION:-3.48.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -79,10 +79,6 @@ patch -p1 < $CWD/patches/calibre-no-update.patch
# Remove calibre portable scripts.
rm -f resources/calibre-portable.*
-PYTHONVER=$(python -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
-export SIP_BIN=/usr/bin/python2-sip
-export SIP_INC_DIR="/usr/include/python$PYTHONVER/python2-sip"
-
OVERRIDE_CFLAGS="$SLKCFLAGS" \
OVERRIDE_LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
python setup.py build
diff --git a/office/calibre/calibre.info b/office/calibre/calibre.info
index ef7454be15..5b3b3402c3 100644
--- a/office/calibre/calibre.info
+++ b/office/calibre/calibre.info
@@ -1,10 +1,10 @@
PRGNAM="calibre"
-VERSION="3.34.0"
+VERSION="3.48.0"
HOMEPAGE="https://calibre-ebook.com"
-DOWNLOAD="https://download.calibre-ebook.com/3.34.0/calibre-3.34.0.tar.xz"
-MD5SUM="8d462959dba64b829529b63fd3f78b8c"
+DOWNLOAD="https://download.calibre-ebook.com/3.48.0/calibre-3.48.0.tar.xz"
+MD5SUM="ec7431dcdeea8a9d8eca3edc83bdec42"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="cssutils dnspython mechanize podofo python-dateutil netifaces psutil cssselect apsw optipng PyQt5 Pygments msgpack-python regex html5-parser dukpy unrardll"
+REQUIRES="css-parser dnspython mechanize podofo python-dateutil netifaces psutil cssselect apsw optipng pyhton2-PyQt5 Pygments msgpack-python regex html5-parser dukpy unrardll"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/office/calibre/patches/remove-desktop-integration.patch b/office/calibre/patches/remove-desktop-integration.patch
index dbf54d6cb0..0272a7c6eb 100644
--- a/office/calibre/patches/remove-desktop-integration.patch
+++ b/office/calibre/patches/remove-desktop-integration.patch
@@ -1,13 +1,14 @@
-diff -Naur calibre.orig/src/calibre/linux.py calibre/src/calibre/linux.py
---- calibre.orig/src/calibre/linux.py 2012-06-29 04:53:39.000000000 +0000
-+++ calibre/src/calibre/linux.py 2012-07-03 02:57:13.834849391 +0000
-@@ -177,9 +177,6 @@
- self.mime_resources = []
+diff -Naur calibre-3.48.0.orig/src/calibre/linux.py calibre-3.48.0/src/calibre/linux.py
+--- calibre-3.48.0.orig/src/calibre/linux.py 2019-09-13 04:46:46.000000000 +0200
++++ calibre-3.48.0/src/calibre/linux.py 2020-03-04 15:02:49.789055000 +0100
+@@ -725,10 +725,6 @@
+ self.appdata_resources = []
if islinux or isbsd:
self.setup_completion()
- if islinux or isbsd:
- self.setup_desktop_integration()
-- self.create_uninstaller()
+- if not getattr(self.opts, 'staged_install', False):
+- self.create_uninstaller()
from calibre.utils.config import config_dir
if os.path.exists(config_dir):