summaryrefslogtreecommitdiffstats
path: root/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild')
-rw-r--r--network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild66
1 files changed, 40 insertions, 26 deletions
diff --git a/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild b/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild
index bd5b6f5697..738a1af006 100644
--- a/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild
+++ b/network/transmission-remote-gtk/transmission-remote-gtk.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for transmission-remote-gtk
# Copyright 2012-2016 Chris Walker Copperas Cove, TX
-# Copyright 2020 B. Watson <yalhcru@gmail.com>
+# Copyright 2020-2023 B. Watson <urchlay@slackware.uk>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -32,6 +32,11 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230713 bkw: update for v1.6.0.
+# - new hard dep libsoup3.
+# - no more optional mrss dep (upstream dropped the RSS reader).
+
+# 20220623 bkw: update for v1.5.1.
# 20210926 bkw: BUILD=2, make NOTIFY=no also disable libappindicator.
# 20200526 bkw:
# - take over maintenance
@@ -47,14 +52,14 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=transmission-remote-gtk
-VERSION=${VERSION:-1.4.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.6.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -69,8 +74,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -95,34 +100,43 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-[ "${NOTIFY:-yes}" = "no" ] && \
- NOTIFYOPT="--without-libnotify --without-libappindicator"
-
-patch -p1 < $CWD/gcc10.patch
+# 20230713 bkw: mangle the meson.build so it works with Slackware
+# 15.0's meson-0.59.x. Eventually this will become difficult or
+# impossible, hopefully by then we have a new Slackware release with a
+# new enough meson.
+sed -i -e '/meson_version:/s,0.60.0,0.59.0,' \
+ -e "s/'ayatana-appindicator3-0.1', //" \
+ meson.build
+
+[ "${NOTIFY:-yes}" = "no" ] && NOTIFYOPT="-Dlibappindicator=disabled"
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ $NOTIFYOPT \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- $NOTIFYOPT \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --build=$ARCH-slackware-linux
-
-make V=1
-make install-strip DESTDIR=$PKG
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
# 20200526 bkw: lots of optional deps, let the slack-desc keep track of them
-ldd $PKG/usr/bin/$PRGNAM > ldd.tmp
-for i in libnotify libmrss GeoIP; do
+objdump -p $PKG/usr/bin/$PRGNAM | grep NEEDED > ldd.tmp
+for i in libappindicator GeoIP; do
opts+="$i:"
grep -q $i ldd.tmp && opts+="yes " || opts+="no "
done
-# 20200526 bkw: this doesn't belong in a package
-rm -f $PKG/usr/share/applications/mimeinfo.cache
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING ChangeLog README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild