summaryrefslogtreecommitdiffstats
path: root/network/sslstrip
diff options
context:
space:
mode:
Diffstat (limited to 'network/sslstrip')
-rw-r--r--network/sslstrip/README6
-rw-r--r--network/sslstrip/slack-desc19
-rw-r--r--network/sslstrip/sslstrip.SlackBuild97
-rw-r--r--network/sslstrip/sslstrip.info10
4 files changed, 0 insertions, 132 deletions
diff --git a/network/sslstrip/README b/network/sslstrip/README
deleted file mode 100644
index 3dc16f6912..0000000000
--- a/network/sslstrip/README
+++ /dev/null
@@ -1,6 +0,0 @@
-sslstrip (HTTPS ssl stripping)
-
-This tool provides a demonstration of the HTTPS stripping attacks.
-It will transparently hijack HTTP traffic on a network, watch for
-HTTPS links and redirects, then map those links into either
-look-alike HTTP links or homograph-similar HTTPS links.
diff --git a/network/sslstrip/slack-desc b/network/sslstrip/slack-desc
deleted file mode 100644
index 9c9d6bc6d4..0000000000
--- a/network/sslstrip/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-sslstrip: sslstrip (HTTPS ssl stripping)
-sslstrip:
-sslstrip: This tool provides a demonstration of the HTTPS stripping attacks.
-sslstrip: It will transparently hijack HTTP traffic on a network, watch for
-sslstrip: HTTPS links and redirects, then map those links into either
-sslstrip: look-alike HTTP links or homograph-similar HTTPS links.
-sslstrip:
-sslstrip: Homepage: http://www.thoughtcrime.org/software/sslstrip/
-sslstrip:
-sslstrip:
-sslstrip:
diff --git a/network/sslstrip/sslstrip.SlackBuild b/network/sslstrip/sslstrip.SlackBuild
deleted file mode 100644
index 623410080c..0000000000
--- a/network/sslstrip/sslstrip.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for sslstrip
-
-# Copyright 2011 Vincent Batts, Vienna, VA, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=sslstrip
-VERSION=${VERSION:-0.9}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README COPYING \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/sslstrip/sslstrip.info b/network/sslstrip/sslstrip.info
deleted file mode 100644
index a10d8137c4..0000000000
--- a/network/sslstrip/sslstrip.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="sslstrip"
-VERSION="0.9"
-HOMEPAGE="http://www.thoughtcrime.org/software/sslstrip/"
-DOWNLOAD="http://www.thoughtcrime.org/software/sslstrip/sslstrip-0.9.tar.gz"
-MD5SUM="944020144e4f5528888b3dfbb107dd78"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pyOpenSSL python-twisted"
-MAINTAINER="Vincent Batts"
-EMAIL="vbatts@hashbangbash.com"