summaryrefslogtreecommitdiffstats
path: root/network/qutebrowser
diff options
context:
space:
mode:
Diffstat (limited to 'network/qutebrowser')
-rw-r--r--network/qutebrowser/README52
-rw-r--r--network/qutebrowser/qutebrowser.SlackBuild42
-rw-r--r--network/qutebrowser/qutebrowser.info12
-rw-r--r--network/qutebrowser/slack-desc6
4 files changed, 71 insertions, 41 deletions
diff --git a/network/qutebrowser/README b/network/qutebrowser/README
index c2a70f0fb8..f5269d0514 100644
--- a/network/qutebrowser/README
+++ b/network/qutebrowser/README
@@ -1,19 +1,53 @@
-qutebrowser (qt5 keyboard driven webbrowser)
+Qutebrowser (qt5 keyboard driven web browser)
-qutebrowser is a keyboard-focused browser with a minimal
+Qutebrowser is a keyboard-focused browser with a minimal
GUI. It's based on Python and PyQt5 and free software,
licensed under the GPL. It was inspired by other
browsers/addons like dwb and Vimperator/Pentadactyl.
-Optional dependency:
+ADBLOCK NOTE:
-qt5-webkit (for the webkit backend)
+If the Python `adblock' library is available, it is now used to
+integrate Brave's Rust adblocker library for improved adblocking based
+on ABP-like filter lists (such as EasyList). If it is unavailable,
+Qutebrowser falls back to host-blocking.
-NOTE:
+There are 36 rust requirements for python-adblock, and they aren't
+available on SBo yet, so the easiest way to install it is with pip3,
+which requires a working network connection.
-pyPEG2 needs building for python3:
+Instructions to install it into ~/.local/lib with pip3:
-PYTHON3=yes ./pyPEG2.SlackBuild
+1. Update llvm to the package in extra/
-If you are using sbopkg you can add this as an option on
-their pages before starting the build queue.
+To update with slackpkg:
+
+Edit /etc/slackpkg/slackpkg.conf and change the order of PRIORITY so
+that `extra' is before `%PKGMAIN' in the list:
+
+ PRIORITY=( extra patches %PKGMAIN pasture testing )
+
+Run `slackpkg upgrade llvm'
+
+Reset PRIORITY back to the default order. The pip3 commands should be
+run as your normal user:
+
+2. Update pip3 to the latest version: pip3 install --user --upgrade pip
+
+3. Install adblock: pip3 install --user adblock
+
+Now start Qutebrowser and check `:version;'. It should list adblock
+with the version number, e.g.:
+
+adblock: 0.4.2
+
+Next, run the update command:
+
+:adblock-update
+
+To see what options there are:
+
+:set content.blocking<TAB>
+
+llvm can be added to /etc/slackpkg/blacklist to keep this version, or
+run the slackpkg command again to revert back to the stock version.
diff --git a/network/qutebrowser/qutebrowser.SlackBuild b/network/qutebrowser/qutebrowser.SlackBuild
index 206fcd5b5b..66a1688230 100644
--- a/network/qutebrowser/qutebrowser.SlackBuild
+++ b/network/qutebrowser/qutebrowser.SlackBuild
@@ -1,30 +1,16 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for qutebrowser
-# Copyright 2017 Dave Woodfall <dave@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# written by Dave Woodfall <dave@slackbuilds.org>
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=qutebrowser
-VERSION=${VERSION:-2.0.2}
+VERSION=${VERSION:-2.5.4}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -34,7 +20,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -56,6 +49,9 @@ find -L . \
make -f misc/Makefile install DESTDIR=$PKG PREFIX=/usr MANDIR=/usr/man
+# shouldn't be executable
+chmod -x $PKG/usr/share/$PRGNAM/userscripts/README.md
+
find $PKG -name \*\.opt-1.pyc -exec rm -f {} \;
install -D -m 0644 icons/qutebrowser.xpm \
@@ -72,4 +68,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/qutebrowser/qutebrowser.info b/network/qutebrowser/qutebrowser.info
index ed94b12ef4..6e55f18a6f 100644
--- a/network/qutebrowser/qutebrowser.info
+++ b/network/qutebrowser/qutebrowser.info
@@ -1,10 +1,10 @@
PRGNAM="qutebrowser"
-VERSION="2.0.2"
-HOMEPAGE="http://qutebrowser.org/"
-DOWNLOAD="https://github.com/qutebrowser/qutebrowser/releases/download/v2.0.2/qutebrowser-2.0.2.tar.gz"
-MD5SUM="506184a80f36fc287bf6e52e65eceac8"
+VERSION="2.5.4"
+HOMEPAGE="https://qutebrowser.org/"
+DOWNLOAD="https://github.com/qutebrowser/qutebrowser/releases/download/v2.5.4/qutebrowser-2.5.4.tar.gz"
+MD5SUM="121f4329ec6b36604da73f7563cea384"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-attrs python3-PyYAML Pygments Jinja2 pyPEG2 python3-PyQtWebEngine python-toml importlib-resources python-zipp"
-MAINTAINER="Dave Woodfall"
+REQUIRES="python3-PyQtWebEngine"
+MAINTAINER="D Woodfall"
EMAIL="dave@slackbuilds.org"
diff --git a/network/qutebrowser/slack-desc b/network/qutebrowser/slack-desc
index d0989d4c8a..1c39aaee95 100644
--- a/network/qutebrowser/slack-desc
+++ b/network/qutebrowser/slack-desc
@@ -10,10 +10,10 @@ qutebrowser: qutebrowser (qt5 keyboard driven webbrowser)
qutebrowser:
qutebrowser: qutebrowser is a keyboard-focused browser with a minimal GUI. It's
qutebrowser: based on Python and PyQt5 and free software, licensed under the GPL.
-qutebrowser: It was inspired by other browsers/addons like dwb and
-qutebrowser: Vimperator/Pentadactyl.
qutebrowser:
-qutebrowser: qt5-webkit is an optional dependency for the webkit backend.
+qutebrowser: It was inspired by other browsers/addons like Vimperator/Pentadactyl
+qutebrowser: and dwb.
qutebrowser:
qutebrowser: https://qutebrowser.org
qutebrowser:
+qutebrowser: