summaryrefslogtreecommitdiffstats
path: root/network/openl2tp
diff options
context:
space:
mode:
Diffstat (limited to 'network/openl2tp')
-rw-r--r--network/openl2tp/Makefile.diff11
-rw-r--r--network/openl2tp/README17
-rw-r--r--network/openl2tp/README.SLACKWARE24
-rw-r--r--network/openl2tp/doinst.sh27
-rw-r--r--network/openl2tp/openl2tp.SlackBuild88
-rw-r--r--network/openl2tp/openl2tp.info10
-rw-r--r--network/openl2tp/sample.conf17
-rw-r--r--network/openl2tp/slack-desc19
8 files changed, 0 insertions, 213 deletions
diff --git a/network/openl2tp/Makefile.diff b/network/openl2tp/Makefile.diff
deleted file mode 100644
index 3f136aac2c..0000000000
--- a/network/openl2tp/Makefile.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Makefile.orig 2010-11-22 11:47:26.000000000 +0200
-+++ ./Makefile 2011-06-21 22:51:24.000000000 +0300
-@@ -158,7 +158,7 @@
- $(CPPFLAGS) $(CPPFLAGS.dmalloc) \
- -DSYS_LIBDIR=$(SYS_LIBDIR)
- LDFLAGS.l2tpd= -Wl,-E -L. -Lusl -lusl -ldl $(LIBS.dmalloc) -lc
--LDFLAGS.l2tpconfig= -Lcli -lcli -lreadline $(LIBS.dmalloc) $(READLINE_LDFLAGS) -lc
-+LDFLAGS.l2tpconfig= -Lcli -lcli -lreadline -ltermcap $(LIBS.dmalloc) $(READLINE_LDFLAGS) -lc
-
- OPT_CFLAGS?= -O
-
diff --git a/network/openl2tp/README b/network/openl2tp/README
deleted file mode 100644
index fe4ea05077..0000000000
--- a/network/openl2tp/README
+++ /dev/null
@@ -1,17 +0,0 @@
-OpenL2TP is a complete implementation of RFC2661 - Layer Two Tunneling
-Protocol Version 2, able to operate as both a server and a client.
-
-OpenL2TP has been written specifically for Linux. It consists of
-- a daemon, openl2tpd, handling the L2TP control protocol exchanges
- for all tunnels and sessions
-- a plugin for pppd to allow its PPP connections to run over L2TP
- sessions
-- a Linux kernel driver for efficient datapath (packaged separately).
-- a command line application for management.
-
-All data packets are handled by the Linux kernel in order that the
-datapath be as efficient as possible. The Linux PPP-over-L2TP kernel
-driver (pppol2tp.o) must be loaded either dynamically as a kernel
-module or linked in statically.
-
-See README.SLACKWARE for post-installation configuration notes.
diff --git a/network/openl2tp/README.SLACKWARE b/network/openl2tp/README.SLACKWARE
deleted file mode 100644
index 204e78ad81..0000000000
--- a/network/openl2tp/README.SLACKWARE
+++ /dev/null
@@ -1,24 +0,0 @@
-To start openl2tpd at boot, you will need to add the following
-lines to /etc/rc.d/rc.local:
-
- if [ -x /etc/rc.d/rc.openl2tpd ]; then
- /etc/rc.d/rc.openl2tpd start
- fi
-
-Then add the following lines to /etc/rc.d/rc.local_shutdown:
-
- if [ -x /etc/rc.d/rc.openl2tpd ]; then
- /etc/rc.d/rc.openl2tpd stop
- fi
-
-Then make sure /etc/rc.d/rc.rpc is executable:
- # chmod 0755 /etc/rc.d/rc.rpc
-
-##############################################################
-
-If you want to start it without a reboot, first follow the
-above directions, and then do this:
-
- # /etc/rc.d/rc.rpc start
- # /etc/rc.d/rc.openl2tpd start
-
diff --git a/network/openl2tp/doinst.sh b/network/openl2tp/doinst.sh
deleted file mode 100644
index f62e4e7af9..0000000000
--- a/network/openl2tp/doinst.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-preserve_perms() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- if [ -e $OLD ]; then
- cp -a $OLD ${NEW}.incoming
- cat $NEW > ${NEW}.incoming
- mv ${NEW}.incoming $NEW
- fi
- config $NEW
-}
-
-preserve_perms etc/rc.d/rc.openl2tpd.new
-config etc/sysconfig/openl2tpd.new
-config etc/openl2tpd.conf.new
-
diff --git a/network/openl2tp/openl2tp.SlackBuild b/network/openl2tp/openl2tp.SlackBuild
deleted file mode 100644
index a16d787436..0000000000
--- a/network/openl2tp/openl2tp.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for openl2tp
-#
-# Written by Eugene P. <pieu@mail.ru>
-#
-
-PRGNAM=openl2tp
-VERSION=${VERSION:-1.8}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch -p1 < $CWD/Makefile.diff
-
-make OPT_CFLAGS="$SLKCFLAGS -Wno-error=unused-but-set-variable" \
- SYS_LIBDIR=/usr/lib${LIBDIRSUFFIX}
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Move and fix perms on manpages
-mv $PKG/usr/share/man $PKG/usr ; rmdir $PKG/usr/share
-find $PKG/usr/man -type f -exec chmod 0644 {} \;
-
-mkdir -p $PKG/etc/rc.d
-cat etc/rc.d/init.d/openl2tpd > $PKG/etc/rc.d/rc.openl2tpd.new
-chmod 0755 $PKG/etc/rc.d/rc.openl2tpd.new
-
-mkdir -p $PKG/etc/sysconfig
-sed -e "s,^OPENL2TPD_CONFIG_FILE=.*$,OPENL2TPD_CONFIG_FILE=/etc/openl2tpd.conf," \
- etc/sysconfig/openl2tpd > $PKG/etc/sysconfig/openl2tpd.new
-
-# Copy config files for the OpenL2TP daemon
-cat $CWD/sample.conf > $PKG/etc/openl2tpd.conf.new
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README CHANGES LICENSE COPYING INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/openl2tp/openl2tp.info b/network/openl2tp/openl2tp.info
deleted file mode 100644
index d38d0ca354..0000000000
--- a/network/openl2tp/openl2tp.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="openl2tp"
-VERSION="1.8"
-HOMEPAGE="http://www.openl2tp.org/"
-DOWNLOAD="http://downloads.sourceforge.net/openl2tp/openl2tp-1.8.tar.gz"
-MD5SUM="e3d08dedfb9e6a9a1e24f6766f6dadd0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Eugene P."
-EMAIL="pieu@mail.ru"
diff --git a/network/openl2tp/sample.conf b/network/openl2tp/sample.conf
deleted file mode 100644
index fba34766c7..0000000000
--- a/network/openl2tp/sample.conf
+++ /dev/null
@@ -1,17 +0,0 @@
-system modify deny_remote_tunnel_creates=yes \
- tunnel_establish_timeout=60 \
- session_establish_timeout=30 \
- tunnel_persist_pend_timeout=60 \
- session_persist_pend_timeout=30
-
-peer profile modify profile_name=default lac_lns=lac
-
-ppp profile modify profile_name=default \
- auth_pap=no auth_eap=no auth_none=no auth_mschapv1=no auth_mschapv2=yes \
- default_route=no proxy_arp=no
-
-tunnel create tunnel_name=CONNECTION_NAME dest_ipaddr=VPN_SERVER_IP persist=yes
-
-session create tunnel_name=CONNECTION_NAME session_name=CONNECTION_NAME \
- user_name="LOGIN" user_password="PASSWORD"
-
diff --git a/network/openl2tp/slack-desc b/network/openl2tp/slack-desc
deleted file mode 100644
index 82de4fc13b..0000000000
--- a/network/openl2tp/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-openl2tp: openl2tp (Layer Two Tunneling Protocol Version 2)
-openl2tp:
-openl2tp: OpenL2TP has been written specifically for Linux. It consists of
-openl2tp: - a daemon, openl2tpd, handling the L2TP control protocol exchanges
-openl2tp: for all tunnels and sessions
-openl2tp: - a plugin for pppd to allow its PPP connections to run over L2TP
-openl2tp: - a kernel driver for efficient datapath (packaged separately)
-openl2tp: - a command line application for management.
-openl2tp:
-openl2tp: http://www.openl2tp.org/
-openl2tp: