summaryrefslogtreecommitdiffstats
path: root/network/nicotine+
diff options
context:
space:
mode:
Diffstat (limited to 'network/nicotine+')
-rw-r--r--network/nicotine+/README9
-rw-r--r--network/nicotine+/nicotine+.SlackBuild26
-rw-r--r--network/nicotine+/nicotine+.info14
-rw-r--r--network/nicotine+/slack-desc14
4 files changed, 37 insertions, 26 deletions
diff --git a/network/nicotine+/README b/network/nicotine+/README
index 893f99ddb8..b1a132acdd 100644
--- a/network/nicotine+/README
+++ b/network/nicotine+/README
@@ -1,5 +1,6 @@
-Nicotine+ is a client for the SoulSeek filesharing network. It was
-"forked" from Nicotine, Hyriand's Soulseek client, which in turn was
-forked from the PySoulSeek project by Alexander Kanavin.
+Nicotine+ is a graphical client for the Soulseek peer-to-peer file
+sharing network.
-Optional dependencies are GeoIP-Python and miniupnpc.
+Nicotine+ aims to be a pleasant, Free and Open Source (FOSS)
+alternative to the official Soulseek client, providing additional
+functionality while keeping current with the Soulseek protocol.
diff --git a/network/nicotine+/nicotine+.SlackBuild b/network/nicotine+/nicotine+.SlackBuild
index 9313aebb91..7c5c828c06 100644
--- a/network/nicotine+/nicotine+.SlackBuild
+++ b/network/nicotine+/nicotine+.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for nicotine+
@@ -23,11 +23,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=nicotine+
SRCNAM=nicotine-plus
-VERSION=${VERSION:-1.4.1}
+VERSION=${VERSION:-3.3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -37,7 +40,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -59,15 +69,15 @@ find -L . \
# Fix paths.
sed -i 's|share/man|man|' setup.py
-sed -i "s|share/doc/nicotine|doc/$PRGNAM-$VERSION|" \
- setup.py pynicotine/gtkgui/frame.py
+sed -i "s|share/doc/nicotine|doc/$PRGNAM-$VERSION|" setup.py
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-cp -a AUTHORS.md COPYING NEWS README.md $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -75,4 +85,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/nicotine+/nicotine+.info b/network/nicotine+/nicotine+.info
index 5485d503bb..cf73ff8d7e 100644
--- a/network/nicotine+/nicotine+.info
+++ b/network/nicotine+/nicotine+.info
@@ -1,10 +1,10 @@
PRGNAM="nicotine+"
-VERSION="1.4.1"
-HOMEPAGE="http://nicotine-plus.org/"
-DOWNLOAD="https://github.com/Nicotine-Plus/nicotine-plus/archive/1.4.1/nicotine-plus-1.4.1.tar.gz"
-MD5SUM="43a6a38ba276dc2a13dce7fd66bdb467"
+VERSION="3.3.2"
+HOMEPAGE="https://nicotine-plus.org/"
+DOWNLOAD="https://github.com/Nicotine-Plus/nicotine-plus/archive/3.3.2/nicotine-plus-3.3.2.tar.gz"
+MD5SUM="40dd230cfac61eda0c0500e5aab6e586"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="mutagen"
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
+REQUIRES=""
+MAINTAINER="Sasha Abbott"
+EMAIL="sashaa@disroot.org"
diff --git a/network/nicotine+/slack-desc b/network/nicotine+/slack-desc
index d81df9e3d4..cd5c55343a 100644
--- a/network/nicotine+/slack-desc
+++ b/network/nicotine+/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-nicotine+: nicotine+ (SoulSeek client written in Python)
+nicotine+: nicotine+ (graphical client for Soulseek)
nicotine+:
-nicotine+: Nicotine+ is a SoulSeek client written in Python, based on the
-nicotine+: PySoulSeek project by Alexander Kanavin. It features, among other
-nicotine+: things, a completely rewritten graphical user interface which
-nicotine+: uses the PyGTK-2 toolkit and a less strict user request policy.
-nicotine+: Nicotine+ is a fork of Hyriand's original Nicotine Soulseek client.
+nicotine+: Nicotine+ is a graphical client for the Soulseek peer-to-peer file
+nicotine+: sharing network.
nicotine+:
-nicotine+: Homepage: http://nicotine-plus.org/
+nicotine+: Nicotine+ aims to be a pleasant, Free and Open Source (FOSS)
+nicotine+: alternative to the official Soulseek client, providing additional
+nicotine+: functionality while keeping current with the Soulseek protocol.
nicotine+:
+nicotine+: Homepage: https://nicotine-plus.org/
nicotine+: