summaryrefslogtreecommitdiffstats
path: root/network/iperf/patches
diff options
context:
space:
mode:
Diffstat (limited to 'network/iperf/patches')
-rw-r--r--network/iperf/patches/0_iperf-2.0.8-debuginfo.patch17
-rw-r--r--network/iperf/patches/1_iperf-2.0.8-bindfail.patch42
-rw-r--r--network/iperf/patches/2_iperf-2.0.8-math.patch75
3 files changed, 134 insertions, 0 deletions
diff --git a/network/iperf/patches/0_iperf-2.0.8-debuginfo.patch b/network/iperf/patches/0_iperf-2.0.8-debuginfo.patch
new file mode 100644
index 0000000000..2a3ad246ee
--- /dev/null
+++ b/network/iperf/patches/0_iperf-2.0.8-debuginfo.patch
@@ -0,0 +1,17 @@
+diff -NarpU5 iperf-2.0.8/configure.ac iperf-2.0.8.debuginfo/configure.ac
+--- iperf-2.0.8/configure.ac 2015-04-02 16:51:48.000000000 -0400
++++ iperf-2.0.8.debuginfo/configure.ac 2015-04-10 10:11:33.287445003 -0400
+@@ -42,13 +42,11 @@ AC_ARG_ENABLE(kalman, AC_HELP_STRING([--
+ dnl ===================================================================
+ dnl Checks for programs
+ dnl ===================================================================
+
+ AC_PROG_CXX
+-CXXFLAGS=`echo " $CXXFLAGS " | sed -e "s/ -g / /"` # do not want it implicitly
+ AC_PROG_CC
+-CFLAGS=`echo " $CFLAGS " | sed -e "s/ -g / /"` # do not want it implicitly
+ AC_ISC_POSIX
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+ AC_PROG_RANLIB
+ AC_LANG(C)
diff --git a/network/iperf/patches/1_iperf-2.0.8-bindfail.patch b/network/iperf/patches/1_iperf-2.0.8-bindfail.patch
new file mode 100644
index 0000000000..b18b2cffed
--- /dev/null
+++ b/network/iperf/patches/1_iperf-2.0.8-bindfail.patch
@@ -0,0 +1,42 @@
+diff -NarpU5 iperf-2.0.8/src/Client.cpp iperf-2.0.8.bindfail/src/Client.cpp
+--- iperf-2.0.8/src/Client.cpp 2015-04-02 16:51:48.000000000 -0400
++++ iperf-2.0.8.bindfail/src/Client.cpp 2015-04-10 10:05:38.279936555 -0400
+@@ -701,20 +701,20 @@ void Client::Connect( ) {
+ AF_INET
+ #endif
+ : AF_INET);
+
+ mSettings->mSock = socket( domain, type, 0 );
+- WARN_errno( mSettings->mSock == INVALID_SOCKET, "socket" );
++ FAIL_errno( mSettings->mSock == INVALID_SOCKET, "socket", mSettings );
+
+ SetSocketOptions( mSettings );
+
+ SockAddr_localAddr( mSettings );
+ if ( mSettings->mLocalhost != NULL ) {
+ // bind socket to local address
+ rc = bind( mSettings->mSock, (sockaddr*) &mSettings->local,
+ SockAddr_get_sizeof_sockaddr( &mSettings->local ) );
+- WARN_errno( rc == SOCKET_ERROR, "bind" );
++ FAIL_errno( rc == SOCKET_ERROR, "bind", mSettings );
+ }
+ // connect socket
+ rc = connect( mSettings->mSock, (sockaddr*) &mSettings->peer,
+ SockAddr_get_sizeof_sockaddr( &mSettings->peer ));
+ FAIL_errno( rc == SOCKET_ERROR, "connect", mSettings );
+diff -NarpU5 iperf-2.0.8/src/Listener.cpp iperf-2.0.8.bindfail/src/Listener.cpp
+--- iperf-2.0.8/src/Listener.cpp 2015-04-02 16:51:48.000000000 -0400
++++ iperf-2.0.8.bindfail/src/Listener.cpp 2015-04-10 10:06:23.279699885 -0400
+@@ -342,11 +342,11 @@ void Listener::Listen( ) {
+ WARN_errno( rc == SOCKET_ERROR, "WSAJoinLeaf (aka bind)" );
+ } else
+ #endif
+ {
+ rc = bind( mSettings->mSock, (sockaddr*) &mSettings->local, mSettings->size_local );
+- WARN_errno( rc == SOCKET_ERROR, "bind" );
++ FAIL_errno( rc == SOCKET_ERROR, "bind", mSettings );
+ }
+ // listen for connections (TCP only).
+ // default backlog traditionally 5
+ if ( !isUDP( mSettings ) ) {
+ rc = listen( mSettings->mSock, 5 );
diff --git a/network/iperf/patches/2_iperf-2.0.8-math.patch b/network/iperf/patches/2_iperf-2.0.8-math.patch
new file mode 100644
index 0000000000..1a943f5f2c
--- /dev/null
+++ b/network/iperf/patches/2_iperf-2.0.8-math.patch
@@ -0,0 +1,75 @@
+diff -NarU5 a/include/headers.h b/include/headers.h
+--- a/include/headers.h 2015-04-02 16:51:48.000000000 -0400
++++ b/include/headers.h 2016-03-16 14:52:14.386853750 -0400
+@@ -80,11 +80,10 @@
+ #include <assert.h>
+ #include <ctype.h>
+ #include <errno.h>
+ #include <string.h>
+ #include <time.h>
+-#include <math.h>
+ #include <float.h>
+ #include <sys/types.h>
+
+ #ifdef WIN32
+
+diff -NarU5 a/src/Client.cpp b/src/Client.cpp
+--- a/src/Client.cpp 2015-04-02 16:51:48.000000000 -0400
++++ b/src/Client.cpp 2016-03-16 14:52:14.387853701 -0400
+@@ -50,10 +50,11 @@
+ * A client thread initiates a connect to the server and handles
+ * sending and receiving data, then closes the socket.
+ * ------------------------------------------------------------------- */
+
+ #include <time.h>
++#include <cmath>
+ #include "headers.h"
+ #include "Client.hpp"
+ #include "Thread.h"
+ #include "SocketAddr.h"
+ #include "PerfSocket.hpp"
+diff -NarU5 a/src/ReportDefault.c b/src/ReportDefault.c
+--- a/src/ReportDefault.c 2015-04-02 16:51:49.000000000 -0400
++++ b/src/ReportDefault.c 2016-03-16 14:52:14.387853701 -0400
+@@ -47,10 +47,11 @@
+ * ReportDefault.c
+ * by Kevin Gibbs <kgibbs@nlanr.net>
+ *
+ * ________________________________________________________________ */
+
++#include <math.h>
+ #include "headers.h"
+ #include "Settings.hpp"
+ #include "util.h"
+ #include "Reporter.h"
+ #include "report_default.h"
+diff -NarU5 a/src/Reporter.c b/src/Reporter.c
+--- a/src/Reporter.c 2015-04-02 16:51:49.000000000 -0400
++++ b/src/Reporter.c 2016-03-16 14:52:14.388853652 -0400
+@@ -47,10 +47,11 @@
+ * Reporter.c
+ * by Kevin Gibbs <kgibbs@nlanr.net>
+ *
+ * ________________________________________________________________ */
+
++#include <math.h>
+ #include "headers.h"
+ #include "Settings.hpp"
+ #include "util.h"
+ #include "Reporter.h"
+ #include "Thread.h"
+diff -NarU5 a/src/Server.cpp b/src/Server.cpp
+--- a/src/Server.cpp 2015-04-02 16:51:49.000000000 -0400
++++ b/src/Server.cpp 2016-03-16 14:52:14.388853652 -0400
+@@ -52,10 +52,11 @@
+ * Handles sending and receiving data, and then closes socket.
+ * Changes to this version : The server can be run as a daemon
+ * ------------------------------------------------------------------- */
+
+ #define HEADERS()
++#include <cmath>
+ #include "headers.h"
+ #include "Server.hpp"
+ #include "List.h"
+ #include "Extractor.h"
+ #include "Reporter.h"