summaryrefslogtreecommitdiffstats
path: root/network/icecat/icecat.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/icecat/icecat.SlackBuild')
-rw-r--r--network/icecat/icecat.SlackBuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/network/icecat/icecat.SlackBuild b/network/icecat/icecat.SlackBuild
index b7b8272b66..82d05008f5 100644
--- a/network/icecat/icecat.SlackBuild
+++ b/network/icecat/icecat.SlackBuild
@@ -14,8 +14,11 @@
# and/or very being, up to and including the end of all existence and
# the Universe as we know it.
+# You can get the latest version of this slackbuild early at
+# http://melikamp.com/features/slackbuilds.shtml
+
PRGNAM="icecat"
-VERSION="5.0"
+VERSION="6.0.2"
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -52,7 +55,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}-$VERSION.tar.bz2 || exit 1
+tar xvf $CWD/${PRGNAM}-$VERSION.tar.xz || exit 1
cd ${PRGNAM}-$VERSION
chown -R root:root .
find . \
@@ -70,6 +73,9 @@ CXXFLAGS="$SLKCFLAGS" \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--build=$ARCH-slackware-linux || exit 1
+# Work around bug 679006 which prevents building with latest kernels.
+cp security/coreconf/Linux3.0.mk security/coreconf/Linux3.1.mk
+
make || exit 1
make install DESTDIR=$PKG