summaryrefslogtreecommitdiffstats
path: root/network/graphite-carbon
diff options
context:
space:
mode:
Diffstat (limited to 'network/graphite-carbon')
-rw-r--r--network/graphite-carbon/README8
-rw-r--r--network/graphite-carbon/README.SLACKWARE15
-rw-r--r--network/graphite-carbon/doinst.sh26
-rw-r--r--network/graphite-carbon/graphite-carbon.SlackBuild134
-rw-r--r--network/graphite-carbon/graphite-carbon.info10
-rw-r--r--network/graphite-carbon/graphite-carbon.logrotate13
-rw-r--r--network/graphite-carbon/man1/carbon-aggregator.156
-rw-r--r--network/graphite-carbon/man1/carbon-cache.150
-rw-r--r--network/graphite-carbon/man1/carbon-client.143
-rw-r--r--network/graphite-carbon/man1/carbon-relay.151
-rw-r--r--network/graphite-carbon/man1/validate-storage-schemas.117
-rw-r--r--network/graphite-carbon/patches/carbon.conf.example.diff41
-rw-r--r--network/graphite-carbon/patches/setup.cfg.diff12
-rw-r--r--network/graphite-carbon/patches/validate-storage-schemas.py.diff11
-rw-r--r--network/graphite-carbon/rc.carbon-cache57
-rw-r--r--network/graphite-carbon/slack-desc19
16 files changed, 0 insertions, 563 deletions
diff --git a/network/graphite-carbon/README b/network/graphite-carbon/README
deleted file mode 100644
index adac9f0ee4..0000000000
--- a/network/graphite-carbon/README
+++ /dev/null
@@ -1,8 +0,0 @@
-graphite-carbon (Backend data caching and persistence daemon for Graphite)
-
-Graphite is a web application using the Twisted framework to provide real-time
-visualization and storage of numeric time-series data. The Carbon daemon
-processes the incoming time-series data and saves it as Whisper database files.
-
-See README.SLACKWARE (which is also installed with the package docs) for
-setup, configuration, and usage hints.
diff --git a/network/graphite-carbon/README.SLACKWARE b/network/graphite-carbon/README.SLACKWARE
deleted file mode 100644
index 0f97aacb9f..0000000000
--- a/network/graphite-carbon/README.SLACKWARE
+++ /dev/null
@@ -1,15 +0,0 @@
-You may wish to add these lines to /etc/rc.d/rc.local to start the service:
-
-if [ -x /etc/rc.d/rc.carbon-cache ]; then
- /etc/rc.d/rc.carbon-cache start
-fi
-
-You may also add these lines to /etc/rc.d/rc.local_shutdown:
-
-if [ -x /etc/rc.d/rc.carbon-cache ]; then
- /etc/rc.d/rc.carbon-cache stop
-fi
-
-Remember to give executable permission to /etc/rc.d/rc.local_shutdown:
-
- chmod 0755 /etc/rc.d/rc.local_shutdown
diff --git a/network/graphite-carbon/doinst.sh b/network/graphite-carbon/doinst.sh
deleted file mode 100644
index b11adc4f0f..0000000000
--- a/network/graphite-carbon/doinst.sh
+++ /dev/null
@@ -1,26 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-preserve_perms() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- if [ -e $OLD ]; then
- cp -a $OLD ${NEW}.incoming
- cat $NEW > ${NEW}.incoming
- mv ${NEW}.incoming $NEW
- fi
- config $NEW
-}
-
-for i in etc/rc.d/rc.carbon-*.new ; do preserve_perms $i ; done
-for i in etc/carbon/*.new etc/logrotate.d/graphite-carbon.new ; do config $i ; done
diff --git a/network/graphite-carbon/graphite-carbon.SlackBuild b/network/graphite-carbon/graphite-carbon.SlackBuild
deleted file mode 100644
index 62823d82ef..0000000000
--- a/network/graphite-carbon/graphite-carbon.SlackBuild
+++ /dev/null
@@ -1,134 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for graphite-carbon
-
-# Copyright 2015 Mario Preksavec, Zagreb, Croatia
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=graphite-carbon
-VERSION=${VERSION:-0.9.15}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=carbon
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-# Bail if user or group isn't valid on your system
-if ! grep ^graphite: /etc/passwd 2>&1 > /dev/null; then
-
-cat << EOF
-
- You must have graphite user and a group to run this script
-
- # groupadd -g 299 graphite
- # useradd -u 299 -d /var/lib/graphite -s /bin/false -g graphite graphite
-
-EOF
-
- exit
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Set some sane defaults
-patch -p1 <$CWD/patches/carbon.conf.example.diff
-# We don't have a RedHat system
-patch -p1 <$CWD/patches/setup.cfg.diff
-# Look for config file in /etc/carbon
-patch -p1 <$CWD/patches/validate-storage-schemas.py.diff
-
-python setup.py install --root=$PKG
-
-# Need some dirs
-mkdir -p $PKG/etc/{rc.d,logrotate.d} $PKG/var/{lib/graphite/whisper,log/carbon}
-chown -R graphite:graphite $PKG/var/lib/graphite $PKG/var/log/carbon
-
-# Install rc script
-install -D -m0644 -oroot -groot $CWD/rc.carbon-cache \
- $PKG/etc/rc.d/rc.carbon-cache.new
-
-# Logrotate script
-install -D -m0644 -oroot -groot $CWD/graphite-carbon.logrotate \
- $PKG/etc/logrotate.d/graphite-carbon.new
-
-# Configuration goes into /etc/carbon
-mv $PKG/usr/conf $PKG/etc/carbon
-for i in $PKG/etc/carbon/*.example ; do mv $i ${i/.example/.new} ; done
-
-# Do we really want .py suffix in /usr/bin
-for i in $PKG/usr/bin/*.py ; do mv $i ${i/.py/} ; done
-
-# Cruft removal
-rm -rf $PKG/usr/{storage,examples}
-
-# Manpages thanks to Debian folks!
-mkdir -p $PKG/usr/man
-cp -r $CWD/man1 $PKG/usr/man
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE $CWD/README.SLACKWARE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/graphite-carbon/graphite-carbon.info b/network/graphite-carbon/graphite-carbon.info
deleted file mode 100644
index 7bc565d938..0000000000
--- a/network/graphite-carbon/graphite-carbon.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="graphite-carbon"
-VERSION="0.9.15"
-HOMEPAGE="https://github.com/graphite-project/"
-DOWNLOAD="https://github.com/graphite-project/carbon/archive/0.9.15/carbon-0.9.15.tar.gz"
-MD5SUM="1962b92b8b672b33d99b00c303fdd5aa"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-whisper python-twisted"
-MAINTAINER="Mario Preksavec"
-EMAIL="mario at slackware dot hr"
diff --git a/network/graphite-carbon/graphite-carbon.logrotate b/network/graphite-carbon/graphite-carbon.logrotate
deleted file mode 100644
index 7b769425a8..0000000000
--- a/network/graphite-carbon/graphite-carbon.logrotate
+++ /dev/null
@@ -1,13 +0,0 @@
-/var/log/carbon/*.log {
- weekly
- missingok
- rotate 7
- compress
- delaycompress
- notifempty
- create 644 graphite graphite
- sharedscripts
- postrotate
- /etc/rc.d/rc.carbon-cache restart > /dev/null
- endscript
-}
diff --git a/network/graphite-carbon/man1/carbon-aggregator.1 b/network/graphite-carbon/man1/carbon-aggregator.1
deleted file mode 100644
index a8ab95294d..0000000000
--- a/network/graphite-carbon/man1/carbon-aggregator.1
+++ /dev/null
@@ -1,56 +0,0 @@
-.TH CARBON-AGGREGATOR 1
-.SH NAME
-carbon-aggregator \- buffer metrics over time before reporting to carbon-cache
-.SH SYNOPSYS
-.nf
-.fam C
-\fbcarbon-aggregator\fP [options] start
-.fam T
-.fi
-.SH DESCRIPTION
-carbon-aggregator can be run in front of carbon-cache to buffer metrics over
-time before reporting them into whisper.
-.PP
-The options are described below.
-.SH OPTIONS
-.TP
-.B
-\-h, \-\-help
-Show the embedded help.
-.TP
-.B
-\-\-debug
-Run in the foreground, log to stdout
-.TP
-.B
-\-\-profile=PROFILE
-Record performance profile data to the given file
-.TP
-.B
-\-\-pidfile=PIDFILE
-Write pid to the given file
-.TP
-.B
-\-\-config=CONFIG
-Use the given config file
-.TP
-.B
-\-\-logdir=LOGDIR
-Write logs in the given directory
-.TP
-.B
-\-\-instance=INSTANCE
-Manage a specific carbon instance
-.TP
-.B
-\-\-rules=RULES
-Use the given aggregation rules file.
-.TP
-.B
-\-\-rewrite-rules=REWRITE_RULES
-Use the given rewrite rules file.
-.SH AUTHOR
-\fBcarbon-aggregator\fP, created by Chris Davis.
-.PP
-This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de, for
-the Debian project (but may be used by others).
diff --git a/network/graphite-carbon/man1/carbon-cache.1 b/network/graphite-carbon/man1/carbon-cache.1
deleted file mode 100644
index 39174d7449..0000000000
--- a/network/graphite-carbon/man1/carbon-cache.1
+++ /dev/null
@@ -1,50 +0,0 @@
-.TH CARBON-CACHE 1
-.SH NAME
-carbon-cache \- accepts metrics over various protocols and writes them to disk
-.SH SYNOPSYS
-.nf
-.fam C
-\fbcarbon-cache\fP [options] start
-.fam T
-.fi
-.SH DESCRIPTION
-carbon-cache accepts metrics over various protocols and writes them to disk as
-efficiently as possible. This requires caching metric values in RAM as they are
-received, and flushing them to disk on an interval using the underlying
-whisper library.
-.PP
-The options are described below.
-.SH OPTIONS
-.TP
-.B
-\-h, \-\-help
-Show the embedded help.
-.TP
-.B
-\-\-debug
-Run in the foreground, log to stdout
-.TP
-.B
-\-\-profile=PROFILE
-Record performance profile data to the given file
-.TP
-.B
-\-\-pidfile=PIDFILE
-Write pid to the given file
-.TP
-.B
-\-\-config=CONFIG
-Use the given config file
-.TP
-.B
-\-\-logdir=LOGDIR
-Write logs in the given directory
-.TP
-.B
-\-\-instance=INSTANCE
-Manage a specific carbon instance
-.SH AUTHOR
-\fBcarbon-cache\fP, created by Chris Davis.
-.PP
-This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de, for
-the Debian project (but may be used by others).
diff --git a/network/graphite-carbon/man1/carbon-client.1 b/network/graphite-carbon/man1/carbon-client.1
deleted file mode 100644
index d954d4158f..0000000000
--- a/network/graphite-carbon/man1/carbon-client.1
+++ /dev/null
@@ -1,43 +0,0 @@
-.TH CARBON-CLIENT 1
-.SH NAME
-carbon-client \- Graphite client to reroute carbon data
-.SH SYNOPSYS
-.nf
-.fam C
-\fbcarbon-client\fP [options]
-.fam T
-.fi
-.SH DESCRIPTION
-Graphite client to reroute carbon data
-.PP
-The options are described below.
-.SH OPTIONS
-.TP
-.B
-\-h, \-\-help
-Show the embedded help.
-.TP
-.B
-\-\-debug
-Log debug info to stdout
-.TP
-.B
-\-\-keyfunc=KEYFUNC
-Use a custom key function (path/to/module.py:myFunc)
-.TP
-.B
-\-\-replication=REPLICATION
-Replication factor
-.TP
-.B
-\-\-routing=ROUTING
-Routing method: "consistent-hashing" (default) or "relay"
-.TP
-.B
-\-\-relayrules=RELAYRULES
-relay-rules.conf file to use for relay routing
-.SH AUTHOR
-\fBcarbon-client\fP, created by Chris Davis.
-.PP
-This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de, for
-the Debian project (but may be used by others).
diff --git a/network/graphite-carbon/man1/carbon-relay.1 b/network/graphite-carbon/man1/carbon-relay.1
deleted file mode 100644
index 0ee27548b3..0000000000
--- a/network/graphite-carbon/man1/carbon-relay.1
+++ /dev/null
@@ -1,51 +0,0 @@
-.TH CARBON-RELAY 1
-.SH NAME
-carbon-relay \- replication and sharding data
-.SH SYNOPSYS
-.nf
-.fam C
-\fbcarbon-relay\fP [options] start
-.fam T
-.fi
-.SH DESCRIPTION
-carbon-relay serves two distinct purposes: replication and sharding.
-.PP
-The options are described below.
-.SH OPTIONS
-.TP
-.B
-\-h, \-\-help
-Show the embedded help.
-.TP
-.B
-\-\-debug
-Run in the foreground, log to stdout
-.TP
-.B
-\-\-profile=PROFILE
-Record performance profile data to the given file
-.TP
-.B
-\-\-pidfile=PIDFILE
-Write pid to the given file
-.TP
-.B
-\-\-config=CONFIG
-Use the given config file
-.TP
-.B
-\-\-logdir=LOGDIR
-Write logs in the given directory
-.TP
-.B
-\-\-instance=INSTANCE
-Manage a specific carbon instance
-.TP
-.B
-\-\-rules=RULES
-se the given relay rules file.
-.SH AUTHOR
-\fBcarbon-relay\fP, created by Chris Davis.
-.PP
-This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de, for
-the Debian project (but may be used by others).
diff --git a/network/graphite-carbon/man1/validate-storage-schemas.1 b/network/graphite-carbon/man1/validate-storage-schemas.1
deleted file mode 100644
index 07eadb3358..0000000000
--- a/network/graphite-carbon/man1/validate-storage-schemas.1
+++ /dev/null
@@ -1,17 +0,0 @@
-.TH VALIDATE-STORAGE-SCHEMAS 1
-.SH NAME
-validate-storage-schemas \- validates the storage schemas
-.SH SYNOPSYS
-.nf
-.fam C
-\fbvalidate-storage-schemas\fP
-.fam T
-.fi
-.SH DESCRIPTION
-validates the storage schemas from the configuration
-file /etc/carbon/storage-schemas.conf.
-.SH AUTHOR
-\fBvalidate-storage-schemas\fP, created by Chris Davis.
-.PP
-This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de, for
-the Debian project (but may be used by others).
diff --git a/network/graphite-carbon/patches/carbon.conf.example.diff b/network/graphite-carbon/patches/carbon.conf.example.diff
deleted file mode 100644
index cd72206d45..0000000000
--- a/network/graphite-carbon/patches/carbon.conf.example.diff
+++ /dev/null
@@ -1,41 +0,0 @@
---- carbon-0.9.13-pre1/conf/carbon.conf.example.orig 2014-12-31 17:50:50.000000000 +0100
-+++ carbon-0.9.13-pre1/conf/carbon.conf.example 2015-02-04 00:36:17.680898110 +0100
-@@ -14,30 +14,21 @@
- # To change other directory paths, add settings to this file. The following
- # configuration variables are available with these default values:
- #
--# STORAGE_DIR = $GRAPHITE_STORAGE_DIR
--# LOCAL_DATA_DIR = STORAGE_DIR/whisper/
--# WHITELISTS_DIR = STORAGE_DIR/lists/
--# CONF_DIR = STORAGE_DIR/conf/
--# LOG_DIR = STORAGE_DIR/log/
--# PID_DIR = STORAGE_DIR/
--#
--# For FHS style directory structures, use:
--#
--# STORAGE_DIR = /var/lib/carbon/
--# CONF_DIR = /etc/carbon/
--# LOG_DIR = /var/log/carbon/
--# PID_DIR = /var/run/
--#
--#LOCAL_DATA_DIR = /opt/graphite/storage/whisper/
-+STORAGE_DIR = /var/lib/graphite/
-+CONF_DIR = /etc/carbon/
-+LOG_DIR = /var/log/carbon/
-+PID_DIR = /var/run/
-+
-+LOCAL_DATA_DIR = /var/lib/graphite/whisper/
-
- # Enable daily log rotation. If disabled, carbon will automatically re-open
- # the file if it's rotated out of place (e.g. by logrotate daemon)
--ENABLE_LOGROTATION = True
-+ENABLE_LOGROTATION = False
-
- # Specify the user to drop privileges to
- # If this is blank carbon runs as the user that invokes it
- # This user must have write access to the local data directory
--USER =
-+USER = graphite
- #
- # NOTE: The above settings must be set under [relay] and [aggregator]
- # to take effect for those daemons as well
diff --git a/network/graphite-carbon/patches/setup.cfg.diff b/network/graphite-carbon/patches/setup.cfg.diff
deleted file mode 100644
index 67f266d360..0000000000
--- a/network/graphite-carbon/patches/setup.cfg.diff
+++ /dev/null
@@ -1,12 +0,0 @@
---- carbon-0.9.13-pre1/setup.cfg.orig 2015-02-04 00:37:23.199169196 +0100
-+++ carbon-0.9.13-pre1/setup.cfg 2015-02-04 00:37:45.198588654 +0100
-@@ -1,9 +0,0 @@
--[install]
--prefix = /opt/graphite
--install-lib = %(prefix)s/lib
--
--[bdist_rpm]
--requires = python-twisted
-- whisper
--
--post-install = distro/redhat/misc/postinstall
diff --git a/network/graphite-carbon/patches/validate-storage-schemas.py.diff b/network/graphite-carbon/patches/validate-storage-schemas.py.diff
deleted file mode 100644
index ed6dad7b0f..0000000000
--- a/network/graphite-carbon/patches/validate-storage-schemas.py.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- carbon-0.9.13-pre1/bin/validate-storage-schemas.py.orig 2014-12-31 17:50:50.000000000 +0100
-+++ carbon-0.9.13-pre1/bin/validate-storage-schemas.py 2015-02-04 00:40:16.244602801 +0100
-@@ -22,7 +22,7 @@
- SCHEMAS_FILE = sys.argv[1]
- print "Loading storage-schemas configuration from: '%s'" % SCHEMAS_FILE
- else:
-- SCHEMAS_FILE = realpath(join(dirname(__file__), '..', 'conf', 'storage-schemas.conf'))
-+ SCHEMAS_FILE = '/etc/carbon/storage-schemas.conf'
- print "Loading storage-schemas configuration from default location at: '%s'" % SCHEMAS_FILE
-
- config_parser = ConfigParser()
diff --git a/network/graphite-carbon/rc.carbon-cache b/network/graphite-carbon/rc.carbon-cache
deleted file mode 100644
index ee7c98630e..0000000000
--- a/network/graphite-carbon/rc.carbon-cache
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh
-#
-# Start/stop/restart the carbon-cache daemon
-# Written by Mario Preksavec <mario@slackware.hr>
-
-BIN_FILE=/usr/bin/carbon-cache
-PID_FILE=/var/run/carbon-cache.pid
-CONF_FILE=/etc/carbon/carbon.conf
-
-rc_start() {
- if [ -x $BIN_FILE ] && [ -f $CONF_FILE ]; then
- if [ -f $PID_FILE ] && kill -0 $(cat $PID_FILE) 2>/dev/null; then
- echo "carbon-cache daemon already running"
- else
- echo "Starting carbon-cache daemon: $BIN"
- $BIN_FILE --config=$CONF_FILE --pidfile=$PID_FILE start
- fi
- fi
-}
-
-rc_stop() {
- if [ -f $PID_FILE ] && kill -0 $(cat $PID_FILE) 2>/dev/null; then
- echo "Stopping carbon-cache daemon: $BIN"
- $BIN_FILE --config=$CONF_FILE --pidfile=$PID_FILE stop \
- && rm -f $PID_FILE
- fi
-}
-
-rc_status() {
- if [ -f $PID_FILE ] && kill -0 $(cat $PID_FILE) 2>/dev/null; then
- $BIN_FILE --config=$CONF_FILE --pidfile=$PID_FILE status
- fi
-}
-
-rc_restart() {
- rc_stop
- sleep 1
- rc_start
-}
-
-case "$1" in
- 'start')
- rc_start
- ;;
- 'stop')
- rc_stop
- ;;
- 'restart')
- rc_restart
- ;;
- 'status')
- rc_status
- ;;
- *)
- echo "usage $0 start|stop|restart|status"
- ;;
-esac
diff --git a/network/graphite-carbon/slack-desc b/network/graphite-carbon/slack-desc
deleted file mode 100644
index 4136bf704b..0000000000
--- a/network/graphite-carbon/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-graphite-carbon: graphite-carbon (Backend data caching and daemon for Graphite)
-graphite-carbon:
-graphite-carbon: Graphite is a web application using the Twisted framework to provide
-graphite-carbon: real-time visualization and storage of numeric time-series data.
-graphite-carbon: The Carbon daemon processes the incoming time-series data and saves
-graphite-carbon: it as Whisper database files.
-graphite-carbon:
-graphite-carbon: Homepage: https://github.com/graphite-project/
-graphite-carbon:
-graphite-carbon:
-graphite-carbon: