summaryrefslogtreecommitdiffstats
path: root/network/flexget
diff options
context:
space:
mode:
Diffstat (limited to 'network/flexget')
-rw-r--r--network/flexget/flexget.SlackBuild42
-rw-r--r--network/flexget/flexget.info12
2 files changed, 32 insertions, 22 deletions
diff --git a/network/flexget/flexget.SlackBuild b/network/flexget/flexget.SlackBuild
index 28b1d8da06..f10b85810b 100644
--- a/network/flexget/flexget.SlackBuild
+++ b/network/flexget/flexget.SlackBuild
@@ -5,6 +5,7 @@
# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Written by Lionel Young <redtricycle@gmail.com>
#
# All rights reserved.
@@ -26,19 +27,28 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220515 46and2: Updated version, removed python2, New maintainer.
+# 20220908 46and2: Updated version.
+# -build process changed to fix issue with versions >3.3.20.
+# 20230915 46and2: Updated version, deps, various fixes.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=flexget
-VERSION=${VERSION:-2.11.9}
+SRCNAM=FlexGet
+VERSION=${VERSION:-3.9.19}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=FlexGet
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -48,14 +58,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
set -e
rm -rf $PKG
@@ -67,14 +69,22 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Remove versions from requirements
sed -i "s/==.*//" requirements.txt
-python setup.py install --root=$PKG
+# remove modules already included in python3.9 or win32
+sed -i -E -e '/^(backports-zoneinfo|pkgutil-resolve-name)/d' \
+ -e '/^(pywin32|win32-setctime)/d' requirements.txt
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/network/flexget/flexget.info b/network/flexget/flexget.info
index b309cd24ed..3aeb1d5c53 100644
--- a/network/flexget/flexget.info
+++ b/network/flexget/flexget.info
@@ -1,10 +1,10 @@
PRGNAM="flexget"
-VERSION="2.11.9"
+VERSION="3.9.19"
HOMEPAGE="https://flexget.com/"
-DOWNLOAD="https://pypi.python.org/packages/d7/e4/e543975ddfee11b138af0096cdcb21fe730d0297bb0f43d014b7818e14b9/FlexGet-2.11.9.tar.gz"
-MD5SUM="d6c6636c25d96e3c1ee7eb4628cef4d0"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flexget/FlexGet-3.9.19.tar.gz"
+MD5SUM="148a5eb3cb226fec011f568a42a5f573"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="feedparser SQLAlchemy PyYAML BeautifulSoup4 html5lib PyRSS2Gen pynzb rpyc path.py pathlib guessit APScheduler terminaltables colorclass CherryPy Flask-RESTful flask-restplus Flask-Compress Flask-Login Flask-Cors zxcvbn-python"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+REQUIRES="feedparser SQLAlchemy BeautifulSoup4 html5lib python3-PyRSS2Gen python3-pynzb python3-rpyc python3-guessit python3-APScheduler python3-CherryPy python3-Flask-RESTful python3-Flask-RESTX python3-Flask-Compress python3-Flask-Login python3-Flask-Cors python3-zxcvbn python3-rich pytz-deprecation-shim python3-loguru tzdata python3-psutil colorama CommonMark python3-brotlicffi"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"