summaryrefslogtreecommitdiffstats
path: root/network/deluge
diff options
context:
space:
mode:
Diffstat (limited to 'network/deluge')
-rw-r--r--network/deluge/README6
-rw-r--r--network/deluge/deluge.SlackBuild27
-rw-r--r--network/deluge/deluge.info8
3 files changed, 20 insertions, 21 deletions
diff --git a/network/deluge/README b/network/deluge/README
index 3a1a831f39..f52da898d7 100644
--- a/network/deluge/README
+++ b/network/deluge/README
@@ -1,3 +1,3 @@
-Deluge is a bittorrent client for Linux and other Unix-Like operating
-systems. Deluge was created because of the lack of a good, native, GTK based
-torrent solution for Linux.
+Deluge is a bittorrent client for Linux and other Unix-Like operating
+systems. Deluge was created because of the lack of a good, native, GTK
+based torrent solution for Linux.
diff --git a/network/deluge/deluge.SlackBuild b/network/deluge/deluge.SlackBuild
index fbac53a519..18ead3ad4a 100644
--- a/network/deluge/deluge.SlackBuild
+++ b/network/deluge/deluge.SlackBuild
@@ -1,9 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for deluge.
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2019 Logan Rathbone <poprocks@gmail.com>
+# Copyright 2019-2022 Logan Rathbone <poprocks@gmail.com>
#
# All rights reserved.
#
@@ -24,18 +24,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# CHANGELOG
-#
-# 20191118 Logan Rathbone <poprocks@gmail.com> 2.0.3-1
-# - Update for 2.0.3
-# - Additional dependencies: MarkupSafe, setproctitle, rencode,
-# service_identity
-#
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=deluge
-VERSION=${VERSION:-2.0.3}
+VERSION=${VERSION:-2.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -45,7 +41,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -78,8 +78,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python3 setup.py install --root=$PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -99,4 +98,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/deluge/deluge.info b/network/deluge/deluge.info
index eaa430858e..3b04ed5b43 100644
--- a/network/deluge/deluge.info
+++ b/network/deluge/deluge.info
@@ -1,10 +1,10 @@
PRGNAM="deluge"
-VERSION="2.0.3"
+VERSION="2.1.1"
HOMEPAGE="https://www.deluge-torrent.org/"
-DOWNLOAD="https://ftp.osuosl.org/pub/deluge/source/2.0/deluge-2.0.3.tar.xz"
-MD5SUM="fbe784ebed006cd93c9a50f7c0530051"
+DOWNLOAD="https://ftp.osuosl.org/pub/deluge/source/2.1/deluge-2.1.1.tar.xz"
+MD5SUM="2f132a55217fd250967678c9a555bad5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Mako MarkupSafe libtorrent-rasterbar pyOpenSSL python-chardet python-twisted pyxdg rencode service_identity setproctitle"
+REQUIRES="rencode python3-twisted pyOpenSSL libtorrent-rasterbar"
MAINTAINER="Logan Rathbone"
EMAIL="poprocks@gmail.com"