summaryrefslogtreecommitdiffstats
path: root/network/PyRSS2Gen
diff options
context:
space:
mode:
Diffstat (limited to 'network/PyRSS2Gen')
-rw-r--r--network/PyRSS2Gen/PyRSS2Gen.SlackBuild65
-rw-r--r--network/PyRSS2Gen/PyRSS2Gen.info10
-rw-r--r--network/PyRSS2Gen/README6
-rw-r--r--network/PyRSS2Gen/slack-desc19
4 files changed, 0 insertions, 100 deletions
diff --git a/network/PyRSS2Gen/PyRSS2Gen.SlackBuild b/network/PyRSS2Gen/PyRSS2Gen.SlackBuild
deleted file mode 100644
index 28ac2027d0..0000000000
--- a/network/PyRSS2Gen/PyRSS2Gen.SlackBuild
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/bin/bash
-# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
-# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
-# Slackware build script for PyRSS2Gen
-# Written by Lionel Young <redtricycle@gmail.com>
-# Based on http://slackbuilds.org/template.SlackBuild
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=PyRSS2Gen
-VERSION=${VERSION:-1.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
- arm*) export ARCH=arm ;;
- *) export ARCH=$( uname -m ) ;;
- esac
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README LICENSE PKG-INFO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/PyRSS2Gen/PyRSS2Gen.info b/network/PyRSS2Gen/PyRSS2Gen.info
deleted file mode 100644
index 0d47049559..0000000000
--- a/network/PyRSS2Gen/PyRSS2Gen.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="PyRSS2Gen"
-VERSION="1.1"
-HOMEPAGE="http://www.dalkescientific.com/Python/PyRSS2Gen.html"
-DOWNLOAD="http://www.dalkescientific.com/Python/PyRSS2Gen-1.1.tar.gz"
-MD5SUM="c56b9453d52b0a70be4f3e95112058aa"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Lionel Young"
-EMAIL="redtricycle@gmail.com"
diff --git a/network/PyRSS2Gen/README b/network/PyRSS2Gen/README
deleted file mode 100644
index f5b22bb47d..0000000000
--- a/network/PyRSS2Gen/README
+++ /dev/null
@@ -1,6 +0,0 @@
-PyRSS2Gen is a Python module that makes it easy to generate valid RSS
-feeds. You can use it to generate RSS feeds for web pages that don't
-have them.
-
-There is also RSSLib which looks like it does the same thing in a slightly
-different way.
diff --git a/network/PyRSS2Gen/slack-desc b/network/PyRSS2Gen/slack-desc
deleted file mode 100644
index a859f9cc7a..0000000000
--- a/network/PyRSS2Gen/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-PyRSS2Gen: PyRSS2Gen (python RSS feed generator)
-PyRSS2Gen:
-PyRSS2Gen: PyRSS2Gen is a Python module that makes it easy to generate valid
-PyRSS2Gen: RSS feeds. You can use it to generate RSS feeds for web pages that
-PyRSS2Gen: don't have them.
-PyRSS2Gen:
-PyRSS2Gen: Home: http://www.dalkescientific.com/Python/PyRSS2Gen.html
-PyRSS2Gen:
-PyRSS2Gen:
-PyRSS2Gen:
-PyRSS2Gen: