summaryrefslogtreecommitdiffstats
path: root/network/FireWorks
diff options
context:
space:
mode:
Diffstat (limited to 'network/FireWorks')
-rw-r--r--network/FireWorks/FireWorks.SlackBuild26
-rw-r--r--network/FireWorks/FireWorks.info8
-rw-r--r--network/FireWorks/README2
3 files changed, 23 insertions, 13 deletions
diff --git a/network/FireWorks/FireWorks.SlackBuild b/network/FireWorks/FireWorks.SlackBuild
index e2993feddb..457a25009e 100644
--- a/network/FireWorks/FireWorks.SlackBuild
+++ b/network/FireWorks/FireWorks.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for FireWorks
-# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=FireWorks
-VERSION=${VERSION:-1.3.4}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-2.0.3}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,13 +79,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst CHANGES.txt LICENSE PKG-INFO docs/*.rst \
+cp -a README.md CHANGES.txt LICENSE docs/*.html \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -84,4 +94,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/network/FireWorks/FireWorks.info b/network/FireWorks/FireWorks.info
index 10584b6020..3b62f2a824 100644
--- a/network/FireWorks/FireWorks.info
+++ b/network/FireWorks/FireWorks.info
@@ -1,10 +1,10 @@
PRGNAM="FireWorks"
-VERSION="1.3.4"
+VERSION="2.0.3"
HOMEPAGE="https://github.com/materialsproject/fireworks"
-DOWNLOAD="https://pypi.python.org/packages/2e/36/15de68d74d5dc4927cdbb92b4ae0a658885eb08f2974894ff30fe000d6bc/FireWorks-1.3.4.tar.gz"
-MD5SUM="7268d2457124d472162406f59ec00452"
+DOWNLOAD="https://files.pythonhosted.org/packages/d1/9a/54d72f7b09995155f513064d1e6207b3ac87f73306b4c0522c3dd68b6a57/FireWorks-2.0.3.tar.gz"
+MD5SUM="418b196f2710938380e374ca85ac12e7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pymongo monty python-dateutil python-tabulate flask-paginate gunicorn"
+REQUIRES="pymongo monty python3-dateutil python3-tabulate python3-flask-paginate gunicorn python3-ruamel.yaml tqdm"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/FireWorks/README b/network/FireWorks/README
index 1039ff7a8d..7bfbf7feda 100644
--- a/network/FireWorks/README
+++ b/network/FireWorks/README
@@ -7,4 +7,4 @@ Some features that distinguish FireWorks are the capability to program
dynamic workflows and built-in tools for running high-throughput
computations at large computing centers.
-Optional dependencies: python-requests, fabric
+Optional dependency: fabric