summaryrefslogtreecommitdiffstats
path: root/multimedia/vlc
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/vlc')
-rw-r--r--multimedia/vlc/README37
-rw-r--r--multimedia/vlc/cache.patch (renamed from multimedia/vlc/patch_vlc_cache_gen.diff)12
-rw-r--r--multimedia/vlc/dvdnav.patch13
-rw-r--r--multimedia/vlc/dvdread.patch15
-rw-r--r--multimedia/vlc/patch-opencv4.diff24
-rw-r--r--multimedia/vlc/projectM.patch (renamed from multimedia/vlc/patch-projectM-fontpath.diff)6
-rw-r--r--multimedia/vlc/slack-desc2
-rw-r--r--multimedia/vlc/vlc.SlackBuild153
-rw-r--r--multimedia/vlc/vlc.info12
9 files changed, 143 insertions, 131 deletions
diff --git a/multimedia/vlc/README b/multimedia/vlc/README
index 5490cd6e4c..b823fbc0f4 100644
--- a/multimedia/vlc/README
+++ b/multimedia/vlc/README
@@ -12,30 +12,25 @@ are detected at build time, they will be included. Conversely if
optional packages are not available at build time, vlc will generally
continue to build with a reduced feature set.
-Support for OpenCV is supported using either the "default" opencv
-package or the opencv-legacy package (version 3.1.0) from SBo. Either
-package will be detected and used if already installed. If opencv support
-is not wanted despite the presence of opencv or opencv-legacy, it can be
-explicitly disabled by setting the the OPENCV environment variable
-to "no" e.g.
- OPENCV=no sh vlc.SlackBuild
-
Support for Wayland is a special case. It is not supported by default
but can be enabled setting the WAYLAND environment variable to "yes"
when running the SlackBuild e.g.
WAYLAND=yes sh vlc.SlackBuild
-This support also requires additional SBo packages wayland-egl and
-wayland-protocols. It also depends on the qt5 package having been
-built with wayland support i.e. wayland package was installed when the
-qt5 package was built.
-
-Please advise the maintainer to suggest support for any further options.
+By default, the vlc runtime is not able to be run as root. This
+security feature may be side stepped by building vlc with the RUNASROOT
+environment variable set e.g.
+ RUNASROOT=yes sh vlc.SlackBuild
+
+Playing of AV1 encoded video is supported when either of SBo's
+multimedia/aom or libraries/dav1d packages is detected when vlc
+is built. One of these is expected to become required in a future
+release. Some versions of the automatically detected optional aom
+package are incompatible with this version of vlc and in this case
+the build will fail. This can be avoided by setting the AOM environment
+variable to "no" e.g.
+ AOM=no sh vlc.SlackBuild
-*NOTES*
-- the qt4 interface seems not to be working ATM so the qt5 one is
- enabled by default: this means qt5 is a new mandatory dependency
-- you *need* to version-bump the libva and libva-intel-driver in
- Slackware to versions 1.7.3 for VAAPI support: as we suppose
- a standard install, "--enable-libva=no" is added between the
- configure options, instead
+You may disable LUA support by setting the LUA environment variable.
+This will remove the lua dependency e.g.
+ LUA=no sh vlc.SlackBuild
diff --git a/multimedia/vlc/patch_vlc_cache_gen.diff b/multimedia/vlc/cache.patch
index 957e6e96df..4225d33ad4 100644
--- a/multimedia/vlc/patch_vlc_cache_gen.diff
+++ b/multimedia/vlc/cache.patch
@@ -1,6 +1,6 @@
---- bin/Makefile.am.orig 2015-06-03 10:49:51.266282736 +1000
-+++ bin/Makefile.am 2015-06-03 10:50:20.469282310 +1000
-@@ -72,6 +72,10 @@
+--- a/bin/Makefile.am 2015-06-03 10:49:51.266282736 +1000
++++ b/bin/Makefile.am 2015-06-03 10:50:20.469282310 +1000
+@@ -124,6 +124,10 @@
vlc_cache_gen_DEPENDENCIES = vlc_win32_rc.$(OBJEXT)
endif
@@ -11,9 +11,9 @@
#
# Plug-ins cache
#
---- configure.ac.orig 2015-06-03 10:53:22.299279657 +1000
-+++ configure.ac 2015-06-03 09:44:33.338339889 +1000
-@@ -762,6 +762,12 @@
+--- a/configure.ac 2015-06-03 10:53:22.299279657 +1000
++++ b/configure.ac 2015-06-03 09:44:33.338339889 +1000
+@@ -888,6 +888,12 @@
])
])
diff --git a/multimedia/vlc/dvdnav.patch b/multimedia/vlc/dvdnav.patch
new file mode 100644
index 0000000000..e5ecc80d75
--- /dev/null
+++ b/multimedia/vlc/dvdnav.patch
@@ -0,0 +1,13 @@
+--- a/modules/access/dvdnav.c 2020-04-07 23:35:05.000000000 +1000
++++ b/modules/access/dvdnav.c 2020-04-16 22:32:34.175000000 +1000
+@@ -59,6 +59,10 @@
+
+
+ #include <dvdnav/dvdnav.h>
++/* libdvdnav-5.0.3 doesn't define DVDNAV_VERSION */
++#ifndef DVDNAV_VERSION
++#define DVDNAV_VERSION (50003)
++#endif
+ /* Expose without patching headers */
+ dvdnav_status_t dvdnav_jump_to_sector_by_time(dvdnav_t *, uint64_t, int32_t);
+
diff --git a/multimedia/vlc/dvdread.patch b/multimedia/vlc/dvdread.patch
new file mode 100644
index 0000000000..0f2912d7e0
--- /dev/null
+++ b/multimedia/vlc/dvdread.patch
@@ -0,0 +1,15 @@
+--- a/modules/access/dvdread.c 2020-03-28 23:39:33.000000000 +1000
++++ b/modules/access/dvdread.c 2020-04-16 22:10:43.065000000 +1000
+@@ -55,6 +55,12 @@
+ #include <unistd.h>
+
+ #include <dvdread/dvd_reader.h>
++#ifndef DVDREAD_VERSION_CODE
++#define DVDREAD_VERSION_CODE(major, minor, micro) \
++ (((major) * 10000) + \
++ ((minor) * 100) + \
++ ((micro) * 1))
++#endif
+ #include <dvdread/ifo_types.h>
+ #include <dvdread/ifo_read.h>
+ #include <dvdread/nav_read.h>
diff --git a/multimedia/vlc/patch-opencv4.diff b/multimedia/vlc/patch-opencv4.diff
deleted file mode 100644
index da158371d7..0000000000
--- a/multimedia/vlc/patch-opencv4.diff
+++ /dev/null
@@ -1,24 +0,0 @@
---- configure.ac.prev 2019-03-10 13:15:05.033000000 +1000
-+++ configure.ac 2019-03-10 13:19:03.840000000 +1000
-@@ -1848,7 +1848,7 @@
- dnl
- dnl OpenCV wrapper and example filters
- dnl
--PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_example opencv_wrapper], [opencv > 2.0], (OpenCV (computer vision) filter), [auto])
-+PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_wrapper], [opencv4 > 4.0], (OpenCV (computer vision) filter), [auto])
-
-
- dnl
---- modules/video_filter/Makefile.am.orig 2017-11-25 01:29:18.000000000 +1000
-+++ modules/video_filter/Makefile.am 2019-03-12 14:21:25.417000000 +1000
-@@ -147,8 +147,8 @@
- libdeinterlace_plugin_la_LIBADD = libdeinterlace_common.la
- video_filter_LTLIBRARIES += libdeinterlace_plugin.la
-
--libopencv_wrapper_plugin_la_SOURCES = video_filter/opencv_wrapper.c
--libopencv_wrapper_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) $(OPENCV_CFLAGS)
-+libopencv_wrapper_plugin_la_SOURCES = video_filter/opencv_wrapper.cpp
-+libopencv_wrapper_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) $(OPENCV_CFLAGS) -fpermissive
- libopencv_wrapper_plugin_la_LIBADD = $(OPENCV_LIBS)
- libopencv_wrapper_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(video_filterdir)'
- video_filter_LTLIBRARIES += $(LTLIBopencv_wrapper)
diff --git a/multimedia/vlc/patch-projectM-fontpath.diff b/multimedia/vlc/projectM.patch
index 5c4726296c..0eafc24628 100644
--- a/multimedia/vlc/patch-projectM-fontpath.diff
+++ b/multimedia/vlc/projectM.patch
@@ -1,6 +1,6 @@
---- modules/visualization/projectm.cpp.orig 2013-09-13 01:18:34.000000000 +1000
-+++ modules/visualization/projectm.cpp 2014-09-04 14:53:21.510242036 +1000
-@@ -79,8 +79,8 @@
+--- a/modules/visualization/projectm.cpp 2013-09-13 01:18:34.000000000 +1000
++++ b/modules/visualization/projectm.cpp 2014-09-04 14:53:21.510242036 +1000
+@@ -82,8 +82,8 @@
# define FONT_PATH_MENU "C:\\WINDOWS\\Fonts\\arial.ttf"
# define PRESET_PATH NULL
#else
diff --git a/multimedia/vlc/slack-desc b/multimedia/vlc/slack-desc
index 4ff7f2d288..7ae947d4c2 100644
--- a/multimedia/vlc/slack-desc
+++ b/multimedia/vlc/slack-desc
@@ -15,5 +15,5 @@ vlc: video codecs and file formats as well as DVDs, VCDs, and various
vlc: streaming protocols. It is able to stream over networks and to
vlc: transcode multimedia files and save them into various formats.
vlc:
-vlc: homepage: http://www.videolan.org/vlc/
+vlc: homepage: http://www.videolan.org/vlc
vlc:
diff --git a/multimedia/vlc/vlc.SlackBuild b/multimedia/vlc/vlc.SlackBuild
index e35b99cbed..15f5b8c261 100644
--- a/multimedia/vlc/vlc.SlackBuild
+++ b/multimedia/vlc/vlc.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for VLC media player
# Written by Andrea De Pasquale <andrea@de-pasquale.name>
@@ -6,31 +6,49 @@
# modified to build VLC only, shared libraries needed.
# Copyright (c) 2007,2008,2009,2010,2011 Eric Hameleers, Eindhoven, Netherlands
-# Copyright (c) 2014-2019 Christoph Willing, Brisbane, Australia
+# Copyright (c) 2014-2022 Christoph Willing, Brisbane, Australia
+# Copyright (c) 2022 Bill Kirkpatrick, Bay City, Texas, USA
+# Copyright (c) 2023 Tim Dickson, Scotland
+# Copyright (c) 2024 Steven Voges <Oregon, USA>
+# All rights reserved.
#
-# Permission to use, copy, modify, and distribute this software for
-# any purpose with or without fee is hereby granted, provided that
-# the above copyright notice and this permission notice appear in all
+# Redistribution and use of this script, with or without modification is
+# permitted, provided that the following conditions are met:
+
+# 1. Redistribution of this script must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
# copies.
#
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
+# THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
-# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
-# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
-# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
-# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-# SUCH DAMAGE.
+# IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
+# BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
+# CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
+# WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
# -----------------------------------------------------------------------------
+# 20221224 bkw: Modified by SlackBuilds.org, BUILD=4:
+# - libebml builds are OK now, get rid of "stop the build" code.
+# - don't install useless INSTALL and ABOUT-NLS in doc dir.
+
+# 20220215 bkw: Modified by SlackBuilds.org:
+# - stop the build if libebml is installed, since it will fail.
+
+# 20230224 tjd: updated for 3.0.18 added patch to disable libplacebo
+# thanks to bkw
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=vlc
-VERSION=${VERSION:-3.0.7.1}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-3.0.20}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -40,13 +58,17 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
@@ -57,21 +79,6 @@ else
fi
SLKLDFLAGS="-lrt"
-DOCS="ABOUT-NLS AUTHORS COPYING INSTALL NEWS README THANKS"
-qtversion="--enable-qt=4" ; [ "${QTVERSION:-5}" != "4" ] && qtversion="--enable-qt=5"
-wayland="--disable-wayland" ; [ "${WAYLAND:-no}" != "no" ] && wayland="--enable-wayland"
-
-# In an ordinary virtual machine, since a different kernal is running,
-# a unique dbus id is needed.
-# However with LXC, the same kernel is used in each container,
-# so we insert an arbitrary value
-#
-grep "container=" /etc/rc.d/rc.S >/dev/null 2>/dev/null
-if [ $? -eq 0 ]; then
- mkdir -p /var/lib/dbus/
- echo "4349d719fcf875a557a8c00400000014" > /var/lib/dbus/machine-id
-fi
-
set -e
rm -rf $PKG
@@ -81,33 +88,33 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
-patch -p0 < $CWD/patch-projectM-fontpath.diff
-patch -p0 < $CWD/patch_vlc_cache_gen.diff
+sed -i '/DEPRECATED/s:^://:' modules/text_renderer/freetype/text_layout.c
-opencv=""
-if [ "${OPENCV:-yes}" != "yes" ]; then
- opencv="--disable-opencv" ;
-else
- if pkg-config --exists opencv4 ; then
- opencv="--enable-opencv"
- patch -p0 < $CWD/patch-opencv4.diff
- mv modules/video_filter/opencv_wrapper.c modules/video_filter/opencv_wrapper.cpp
- elif pkg-config --exists opencv ; then
- # opencv-legacy
- opencv="--enable-opencv"
- else
- opencv="--disable-opencv"
- fi
-fi
+patch -p1 < $CWD/dvdread.patch
+patch -p1 < $CWD/dvdnav.patch
+patch -p1 < $CWD/projectM.patch
+patch -p1 < $CWD/cache.patch
+
+# Don't enable wayland by default
+wayland="--disable-wayland" ; [ "${WAYLAND:-no}" != "no" ] && wayland="--enable-wayland"
+
+# Enable vlc to be run as root
+runasroot=""; [ "${RUNASROOT:-no}" != "no" ] && runasroot="--enable-run-as-root"
+
+# Give the possibility to explicitly disable aom support
+aom=""; [ "${AOM:-yes}" = "no" ] && aom="--disable-aom"
+
+# Allow to build without lua
+lua=""; [ "${LUA:-yes}" = "no" ] && lua="--disable-lua"
autoreconf -fiv
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -120,36 +127,42 @@ LDFLAGS="$SLKLDFLAGS" \
--docdir=/usr/doc/vlc-$VERSION \
--localstatedir=/var \
--build=$ARCH-slackware-linux \
- $qtversion \
- $wayland \
- $opencv \
+ --enable-qt=5 \
--enable-merge-ffmpeg \
- --enable-libva=no \
- --with-kde-solid=no \
-
+ --disable-libplacebo \
+ --disable-upnp \
+ $wayland \
+ $runasroot \
+ $aom \
+ $lua
make
make DESTDIR=$PKG install
-mkdir -p $PKG/usr/man/man1
-gzip -9c doc/vlc.1 > $PKG/usr/man/man1/vlc.1.gz
+install -D -m0644 extras/analyser/vlc.vim $PKG/usr/share/vim/vimfiles/syntax/vlc.vim
-mkdir -p $PKG/$(cd /usr/share/vim/vim*/syntax ; pwd)
-cp extras/analyser/vlc.vim $PKG/$(cd /usr/share/vim/vim*/syntax ; pwd)/
+rm -f $PKG/usr/lib*/*.la
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-find $PKG/usr/doc -type f -exec chmod 644 {} \;
-chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION/*
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+mkdir -p $PKG/usr/man/man1
+gzip -9c doc/vlc.1 > $PKG/usr/man/man1/vlc.1.gz
find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
for i in $(find $PKG/usr/man -type l -name "*.?") ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING NEWS README THANKS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 644 {} \;
+chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION/*
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+###sbolint off
sed -e s/%LIBDIRSUFFIX%/$LIBDIRSUFFIX/g $CWD/doinst.sh.in > $PKG/install/doinst.sh
+###sbolint on
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/multimedia/vlc/vlc.info b/multimedia/vlc/vlc.info
index b496d5de59..92eb2e2fa9 100644
--- a/multimedia/vlc/vlc.info
+++ b/multimedia/vlc/vlc.info
@@ -1,10 +1,10 @@
PRGNAM="vlc"
-VERSION="3.0.7.1"
+VERSION="3.0.20"
HOMEPAGE="https://www.videolan.org/vlc/"
-DOWNLOAD="https://get.videolan.org/vlc/3.0.7.1/vlc-3.0.7.1.tar.xz"
-MD5SUM="1adf2fe21070378b0e45ad163d3b232d"
+DOWNLOAD="https://get.videolan.org/vlc/3.0.20/vlc-3.0.20.tar.xz"
+MD5SUM="e8337fcd2df92f3901dad091fb85f545"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libass libdc1394 libdvbpsi libmpeg2 libupnp lua portaudio twolame opus ffmpeg libwebp gsm libtar libkate faac libdca libmatroska libshout speex avahi projectM jack-audio-connection-kit libsidplay2 zvbi faad2 libavc1394 libmodplug musepack-tools vcdimager dirac gnome-vfs live555 qt5 rtmpdump libdvdcss fluidsynth schroedinger libminizip chromaprint x264 x265 libbluray libnfs protobuf"
-MAINTAINER="Christoph Willing"
-EMAIL="chris.willing@linux.com"
+REQUIRES="libass libdc1394 libdvbpsi libmpeg2 lua portaudio twolame gsm libtar libkate faac libdca libshout avahi projectM jack libsidplay2 zvbi faad2 libavc1394 libmodplug musepack-tools vcdimager dirac gnome-vfs live555 rtmpdump libdvdcss schroedinger libminizip chromaprint x264 x265 libnfs protobuf3"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"