summaryrefslogtreecommitdiffstats
path: root/multimedia/smplayer/smplayer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/smplayer/smplayer.SlackBuild')
-rw-r--r--multimedia/smplayer/smplayer.SlackBuild65
1 files changed, 20 insertions, 45 deletions
diff --git a/multimedia/smplayer/smplayer.SlackBuild b/multimedia/smplayer/smplayer.SlackBuild
index 1b789a81aa..360ff5590d 100644
--- a/multimedia/smplayer/smplayer.SlackBuild
+++ b/multimedia/smplayer/smplayer.SlackBuild
@@ -2,8 +2,8 @@
# Slackware build script for SMPlayer
+# Copyright 2023 Andrzej Telszewski, Koszalin
# Copyright 2011-2015 Fridrich von Stauffenberg <cancellor2@gmail.com>
-# Copyright 2020 Andrzej Telszewski, Szczecin
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,13 +26,13 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=smplayer
-VERSION=${VERSION:-20.6.0}
+VERSION=${VERSION:-23.12.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-THEMES=${THEMES:-18.6.0}
-SKINS=${SKINS:-15.2.0}
+THEMES=${THEMES:-20.11.0}
+SKINS=${SKINS:-20.11.0}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -42,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -68,38 +65,28 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
+
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
+
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+chmod -R a-st,u+rwX,go-w+rX .
+
+# Disable -Werror (helps building with newer GCC).
-# Disable -Werror (helps building with the newer gcc)
sed -i "s|-W\ -Wall\ -Werror|-W -Wall|" webserver/Makefile
# Fix man page path.
-sed -i "s/share\/man/man/g" Makefile
-if [ ${USE_QT5:-no} = yes ]; then
- QMAKE=qmake-qt5
- LRELEASE=lrelease-qt5
-else
- QMAKE=qmake
- LRELEASE=lrelease
-fi
+sed -i "s/share\/man/man/g" Makefile
make \
- QMAKE=$QMAKE \
- LRELEASE=$LRELEASE \
PREFIX=/usr \
DOC_PATH="\\\"/usr/doc/$PRGNAM-$VERSION/\\\"" \
QMAKE_OPTS="QMAKE_CXXFLAGS=\"$SLKCFLAGS\""
@@ -113,50 +100,38 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt Changelog $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cd $TMP
rm -rf $PRGNAM-themes-$THEMES
tar xvf $CWD/$PRGNAM-themes-$THEMES.tar.bz2
+
cd $PRGNAM-themes-$THEMES
+
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-if [ ${USE_QT5:-no} = yes ]; then
- sed -i "s/rcc -binary/rcc-qt5 -binary/g" themes/Makefile
-fi
+chmod -R a-st,u+rwX,go-w+rX .
make
make install PREFIX=/usr DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/themes
-cp -a *.txt Changelog $PKG/usr/doc/$PRGNAM-$VERSION/themes
+cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION/themes
cd $TMP
rm -rf $PRGNAM-skins-$SKINS
tar xvf $CWD/$PRGNAM-skins-$SKINS.tar.bz2
+
cd $PRGNAM-skins-$SKINS
+
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-if [ ${USE_QT5:-no} = yes ]; then
- sed -i "s/rcc -binary/rcc-qt5 -binary/g" themes/Makefile
-fi
+chmod -R a-st,u+rwX,go-w+rX .
make
make install PREFIX=/usr DESTDIR=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/skins
-cp -a *.txt Changelog $PKG/usr/doc/$PRGNAM-$VERSION/skins
+cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION/skins
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc