summaryrefslogtreecommitdiffstats
path: root/multimedia/cinelerra/cinelerra.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/cinelerra/cinelerra.SlackBuild')
-rw-r--r--multimedia/cinelerra/cinelerra.SlackBuild51
1 files changed, 31 insertions, 20 deletions
diff --git a/multimedia/cinelerra/cinelerra.SlackBuild b/multimedia/cinelerra/cinelerra.SlackBuild
index dfc6c9308c..424392f9a9 100644
--- a/multimedia/cinelerra/cinelerra.SlackBuild
+++ b/multimedia/cinelerra/cinelerra.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for cinelerra
@@ -22,11 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230126 bkw: Modified by SlackBuilds.org:
+# - remove false imlib2 dependency from .info file (no script changes)
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=cinelerra
-SRCNAM=CinelerraCV
-VERSION=${VERSION:-2.3}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-20231006_bfc2f6c}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -36,7 +41,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -66,9 +78,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
-cd $SRCNAM-$VERSION
+rm -rf $PRGNAM-gg-$VERSION
+tar xvf $CWD/$PRGNAM-gg-$VERSION.tar.xz
+cd $PRGNAM-gg-$VERSION/cinelerra-5.1
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -76,33 +88,32 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s|ffplay|ffplay --disable-htmlpages|" thirdparty/Makefile
+
./autogen.sh
-LDFLAGS="-ldl" \
-CFLAGS="$SLKCFLAGS -D__STDC_CONSTANT_MACROS" \
-CXXFLAGS="$SLKCFLAGS -D__STDC_CONSTANT_MACROS" \
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--libdir=/usr/lib${LIBDIRSUFFIX} \
- --with-plugindir=/usr/lib${LIBDIRSUFFIX}/cinelerra \
- --disable-static \
+ --with-plugin-dir=/usr/lib${LIBDIRSUFFIX}/cin \
--mandir=/usr/man \
- --with-pic \
- --with-x \
- --enable-opengl \
--build=$ARCH-slackware-linux \
$mmx
make
-make install DESTDIR=$PKG
+make -j1 install DESTDIR=$PKG
+
+rm -f $PKG/usr/share/applications/cin.desktop
+install -D -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README* TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README* *.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -110,4 +121,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE