summaryrefslogtreecommitdiffstats
path: root/misc/txt2tags/txt2tags.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/txt2tags/txt2tags.SlackBuild')
-rw-r--r--misc/txt2tags/txt2tags.SlackBuild112
1 files changed, 45 insertions, 67 deletions
diff --git a/misc/txt2tags/txt2tags.SlackBuild b/misc/txt2tags/txt2tags.SlackBuild
index 4955489aaa..1cd087aaa0 100644
--- a/misc/txt2tags/txt2tags.SlackBuild
+++ b/misc/txt2tags/txt2tags.SlackBuild
@@ -1,55 +1,50 @@
-#!/bin/sh
+#!/bin/bash
# Slackware Build script for txt2tags
-# Copyright (c) 2009, eviljames <storgeek [at] gmail [dot] com>
-#
-# Permission to use, copy, modify, and/or distribute this software for any
-# purpose with or without fee is hereby granted, provided that the above
-# copyright notice and this permission notice appear in all copies.
-#
-# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
-# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
-# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
-# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
-# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-#
-# Modified by the SlackBuilds.org project
+# Originally written 2009, eviljames <storgeek [at] gmail [dot] com>
+# Now maintained by B. Watson <urchlay@slackware.uk>
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20231120 bkw: update for v3.9.
+# 20230711 bkw: update for v3.8.
+# 20220110 bkw:
+# - take over maintenance.
+# - update for v3.7.
+
+# Note: the old version had a lot of things that are missing from
+# the 3.x branch. See https://github.com/txt2tags/txt2tags/ for
+# details. The 3.x branch has the sole advantage of being written in
+# python 3. Since this is only included on SBo as a dependency for
+# xdgmenumaker, I don't care... but maybe someone might want to do a
+# txt2tags-legacy2 build if they need it.
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=txt2tags
-VERSION=${VERSION:-r1172}
+VERSION=${VERSION:-3.9}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -59,42 +54,25 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/man/man1
-gzip -9 -c doc/English/manpage.man > $PKG/usr/man/man1/$PRGNAM.1.gz
-# Install the available translations
-for i in pt de fr es zh eu ca it; do mkdir -p $PKG/usr/man/$i/man1; done
-gzip -9 -c doc/Portuguese/manpage-pt.man > $PKG/usr/man/pt/man1/$PRGNAM.1.gz
-gzip -9 -c doc/German/manpage-de.man > $PKG/usr/man/de/man1/$PRGNAM.1.gz
-gzip -9 -c doc/French/manpage-fr.man > $PKG/usr/man/fr/man1/$PRGNAM.1.gz
-gzip -9 -c doc/Spanish/manpage-es.man > $PKG/usr/man/es/man1/$PRGNAM.1.gz
-gzip -9 -c doc/Chinese/manpage-zh.man > $PKG/usr/man/zh/man1/$PRGNAM.1.gz
-gzip -9 -c doc/Basque/manpage-eu.man > $PKG/usr/man/eu/man1/$PRGNAM.1.gz
-gzip -9 -c doc/Catalan/manpage-ca.man > $PKG/usr/man/ca/man1/$PRGNAM.1.gz
-gzip -9 -c doc/Italian/manpage-it.man > $PKG/usr/man/it/man1/$PRGNAM.1.gz
-
-mkdir -p $PKG/usr/share/applications
-install -m 0644 dist/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
-mkdir -p $PKG/usr/share/pixmaps
-install -m 0644 $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS COPYING ChangeLog README extras samples test \
- doc/English/txt2tags-quickref.pdf doc/English/userguide.pdf \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG
+
+export PATH=$PATH:$PKG/usr/bin
+export PYTHONPATH=$PKG/$(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())"):$PYTHONPATH
+cd docs
+sh build-docs.sh
+rm */*.t2t *.sh
+cd -
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a COPYING *.md extras samples test docs/* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE