summaryrefslogtreecommitdiffstats
path: root/misc/gprename/gprename-makefile-fixups.patch
diff options
context:
space:
mode:
Diffstat (limited to 'misc/gprename/gprename-makefile-fixups.patch')
-rw-r--r--misc/gprename/gprename-makefile-fixups.patch81
1 files changed, 65 insertions, 16 deletions
diff --git a/misc/gprename/gprename-makefile-fixups.patch b/misc/gprename/gprename-makefile-fixups.patch
index cba26e8a96..1d8431fa68 100644
--- a/misc/gprename/gprename-makefile-fixups.patch
+++ b/misc/gprename/gprename-makefile-fixups.patch
@@ -1,27 +1,43 @@
-diff -u -r gprename-20160905/Makefile gprename-20160905-patched/Makefile
---- gprename-20160905/Makefile 2016-09-05 21:13:20.000000000 +0100
-+++ gprename-20160905-patched/Makefile 2017-08-29 16:24:44.033333612 +0100
-@@ -45,8 +45,8 @@
+diff -Naur gprename-20230429/Makefile gprename-20230429.patched/Makefile
+--- gprename-20230429/Makefile 2023-04-29 10:08:28.000000000 -0400
++++ gprename-20230429.patched/Makefile 2023-05-06 17:49:43.123635034 -0400
+@@ -27,7 +27,7 @@
+ perl -ne 's!\@INSTALLDIR\@!$(PREFIX)!g ; print' < bin/gprename > build/gprename
+ perl -ne 's!\@INSTALLDIR\@!$(PREFIX)!g ; print' < bin/gprename.desktop > build/gprename.desktop
+
+-install: uninstall build
++install: build
+ # Compile all .po files to .mo
+ msgfmt -o build/locale/ca.mo locale/ca.po
+ msgfmt -o build/locale/de.mo locale/de.po
+@@ -47,11 +47,11 @@
# Create directories
install -d "$(DESTDIR)"
install -d "$(DESTDIR)/bin"
- install -d "/usr/share"
- install -d "/usr/share/icons"
+ install -d "$(DESTDIR)/share"
-+ install -d "$(DESTDIR)/share/icons"
++ install -d "$(DESTDIR)/share/pixmaps"
install -d "$(DESTDIR)/share/applications"
- install -d "$(DESTDIR)/share/man"
- install -d "$(DESTDIR)/share/man/man1"
-@@ -67,7 +67,7 @@
+- install -d "$(DESTDIR)/share/man"
+- install -d "$(DESTDIR)/share/man/man1"
++ install -d "$(DESTDIR)/man"
++ install -d "$(DESTDIR)/man/man1"
+ install -d "$(DESTDIR)/share/locale/ca/LC_MESSAGES"
+ install -d "$(DESTDIR)/share/locale/de/LC_MESSAGES"
+ install -d "$(DESTDIR)/share/locale/es/LC_MESSAGES"
+@@ -69,8 +69,8 @@
+
# Copy all files in the filesystem
install -m 755 build/gprename "$(DESTDIR)/bin/"
- install -m 644 gprename-nautilus-actions.xml "$(DESTDIR)/share/applications/"
- install -m 644 icon/gprename.png "/usr/share/icons/"
-+ install -m 644 icon/gprename.png "$(DESTDIR)/share/icons/"
- install -m 644 man/gprename.1 "$(DESTDIR)/share/man/man1/"
+- install -m 644 man/gprename.1 "$(DESTDIR)/share/man/man1/"
++ install -m 644 icon/gprename.png "$(DESTDIR)/share/pixmaps/"
++ install -m 644 man/gprename.1 "$(DESTDIR)/man/man1/"
install -m 644 build/locale/ca.mo "$(DESTDIR)/share/locale/ca/LC_MESSAGES/gprename.mo"
install -m 644 build/locale/de.mo "$(DESTDIR)/share/locale/de/LC_MESSAGES/gprename.mo"
-@@ -82,13 +82,12 @@
+ install -m 644 build/locale/es.mo "$(DESTDIR)/share/locale/es/LC_MESSAGES/gprename.mo"
+@@ -85,13 +85,12 @@
install -m 644 build/locale/ru.mo "$(DESTDIR)/share/locale/ru/LC_MESSAGES/gprename.mo"
install -m 644 build/locale/sv.mo "$(DESTDIR)/share/locale/sv/LC_MESSAGES/gprename.mo"
install -m 644 build/locale/zh_CN.mo "$(DESTDIR)/share/locale/zh_CN/LC_MESSAGES/gprename.mo"
@@ -33,17 +49,50 @@ diff -u -r gprename-20160905/Makefile gprename-20160905-patched/Makefile
uninstall: clean
rm -f "$(DESTDIR)/bin/gprename"
- rm -f "/usr/share/applications/gprename.desktop"
-+ rm -f "$(DESTDIR)/share/applications/gprename.desktop"
- rm -f "$(DESTDIR)/share/applications/gprename-nautilus-actions.xml"
++ rm -f "$(DESTDIR)/applications/gprename.desktop"
rm -f "$(DESTDIR)/share/man/man1/gprename.1"
rm -f "$(DESTDIR)/share/locale/ca/LC_MESSAGES/gprename.mo"
-@@ -104,8 +103,7 @@
+ rm -f "$(DESTDIR)/share/locale/de/LC_MESSAGES/gprename.mo"
+@@ -107,8 +106,7 @@
rm -f "$(DESTDIR)/share/locale/ru/LC_MESSAGES/gprename.mo"
rm -f "$(DESTDIR)/share/locale/sv/LC_MESSAGES/gprename.mo"
rm -f "$(DESTDIR)/share/locale/zh_CN/LC_MESSAGES/gprename.mo"
- rm -fr "/usr/share/icons/gprename"
- update-desktop-database
-+ rm -fr "$(DESTDIR)/share/icons/gprename"
++ rm -fr "$(DESTDIR)/icons/gprename"
clean:
rm -rf build
+diff -Naur gprename-20230429/bin/gprename gprename-20230429.patched/bin/gprename
+--- gprename-20230429/bin/gprename 2023-04-29 10:19:08.000000000 -0400
++++ gprename-20230429.patched/bin/gprename 2023-05-06 17:49:43.123635034 -0400
+@@ -137,7 +137,7 @@
+ $window->add_accel_group( $accel_group );
+
+ # Set the window icon
+-my $icon = '/usr/share/icons/gprename.png';
++my $icon = '/usr/share/pixmaps/gprename.png';
+ my $pixbuf = Gtk3::Gdk::Pixbuf->new_from_file( $icon );
+ $window->set_icon( $pixbuf );
+
+@@ -1508,7 +1508,7 @@
+ $buffer->create_tag( 'big', size => 20 * 1024 );
+ $buffer->create_tag( 'italic', style => 'italic' );
+ my $iter = $buffer->get_start_iter;
+- my $icon = '/usr/share/icons/gprename.png';
++ my $icon = '/usr/share/pixmaps/gprename.png';
+ my $pixbuf = Gtk3::Gdk::Pixbuf->new_from_file( $icon );
+
+ $buffer->insert_pixbuf ($iter, $pixbuf);
+diff -Naur gprename-20230429/bin/gprename.desktop gprename-20230429.patched/bin/gprename.desktop
+--- gprename-20230429/bin/gprename.desktop 2023-04-29 10:08:28.000000000 -0400
++++ gprename-20230429.patched/bin/gprename.desktop 2023-05-06 17:49:43.123635034 -0400
+@@ -4,7 +4,7 @@
+ Name=GPRename
+ Comment=Rename files and directories in batch
+ Exec=gprename
+-Icon=gprename
++Icon=/usr/share/pixmaps/gprename.png
+ Terminal=false
+ Keywords=renamer;utility;
+ Categories=Utility;