summaryrefslogtreecommitdiffstats
path: root/libraries/zope.proxy/zope.proxy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/zope.proxy/zope.proxy.SlackBuild')
-rw-r--r--libraries/zope.proxy/zope.proxy.SlackBuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/libraries/zope.proxy/zope.proxy.SlackBuild b/libraries/zope.proxy/zope.proxy.SlackBuild
index dea8ddc33b..d57dda4671 100644
--- a/libraries/zope.proxy/zope.proxy.SlackBuild
+++ b/libraries/zope.proxy/zope.proxy.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for zope.proxy
# Copyright 2014 Mikko Värri, Finland
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=zope.proxy
-VERSION=${VERSION:-4.1.4}
+VERSION=${VERSION:-5.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -60,12 +61,12 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true