summaryrefslogtreecommitdiffstats
path: root/libraries/tomcat-native
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/tomcat-native')
-rw-r--r--libraries/tomcat-native/tomcat-native.SlackBuild15
-rw-r--r--libraries/tomcat-native/tomcat-native.info6
2 files changed, 10 insertions, 11 deletions
diff --git a/libraries/tomcat-native/tomcat-native.SlackBuild b/libraries/tomcat-native/tomcat-native.SlackBuild
index d008f3a0b1..489e31b610 100644
--- a/libraries/tomcat-native/tomcat-native.SlackBuild
+++ b/libraries/tomcat-native/tomcat-native.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for tomcat-native
-# Copyright 2019 Thibaut Notteboom, Paris, FRANCE
+# Copyright 2019-2023 Thibaut Notteboom, Paris, FRANCE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tomcat-native
-VERSION=${VERSION:-1.2.23}
+VERSION=${VERSION:-1.2.39}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -59,6 +56,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -96,12 +96,11 @@ find -L . \
make install DESTDIR=$PKG
)
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Don't ship .la files:
-rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
CHANGELOG.txt CMakeLists.txt LICENSE NOTICE README.txt TODO.txt docs/ \
diff --git a/libraries/tomcat-native/tomcat-native.info b/libraries/tomcat-native/tomcat-native.info
index 4f9b78bde7..50f5f7adb1 100644
--- a/libraries/tomcat-native/tomcat-native.info
+++ b/libraries/tomcat-native/tomcat-native.info
@@ -1,8 +1,8 @@
PRGNAM="tomcat-native"
-VERSION="1.2.23"
+VERSION="1.2.39"
HOMEPAGE="https://tomcat.apache.org/native-doc/"
-DOWNLOAD="https://archive.apache.org/dist/tomcat/tomcat-connectors/native/1.2.23/source/tomcat-native-1.2.23-src.tar.gz"
-MD5SUM="feb49fa49373423afae28c36b62d82df"
+DOWNLOAD="https://archive.apache.org/dist/tomcat/tomcat-connectors/native/1.2.39/source/tomcat-native-1.2.39-src.tar.gz"
+MD5SUM="267a5f753f31f2150fdc7beecbe9f054"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="zulu-openjdk11"