summaryrefslogtreecommitdiffstats
path: root/libraries/properties-cpp/properties-cpp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/properties-cpp/properties-cpp.SlackBuild')
-rw-r--r--libraries/properties-cpp/properties-cpp.SlackBuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/libraries/properties-cpp/properties-cpp.SlackBuild b/libraries/properties-cpp/properties-cpp.SlackBuild
index 56a716a862..e90b005dc2 100644
--- a/libraries/properties-cpp/properties-cpp.SlackBuild
+++ b/libraries/properties-cpp/properties-cpp.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for properties-cpp
-# Copyright 2017 Jeremy Hansen <jebrhansen+SBo -at- gmail.com
+# Copyright 2017-2023 Jeremy Hansen <jebrhansen+SBo -at- gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220424 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - move HTML docs to proper Slackware doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=properties-cpp
-VERSION=${VERSION:-0.0.1}
-SRCVER=${SRCVER:-0.0.1+14.10.20140730}
+VERSION=${VERSION:-0.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -70,20 +69,24 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/${PRGNAM}_${SRCVER}.orig.tar.gz
-cd $PRGNAM-$SRCVER
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}-${VERSION}.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Remove building tests which require extra deps that aren't needed.
truncate -s 0 tests/CMakeLists.txt
sed -i '/include(cmake\/PrePush.cmake)/d' CMakeLists.txt
+# Disable coverage report to bypass error.
+# Thanks AUR!
+sed -i '/^find_package(CoverageReport)/,$d' CMakeLists.txt
+
mkdir -p build
cd build
cmake \
@@ -92,13 +95,13 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+[ -e $PKG/usr/share/doc/$PRGNAM/html ] && \
+ mv $PKG/usr/share/doc/$PRGNAM/html $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share # 20220424 bkw: nothing here but doc/
cp -a COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild