summaryrefslogtreecommitdiffstats
path: root/libraries/paho-mqtt
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/paho-mqtt')
-rw-r--r--libraries/paho-mqtt/README19
-rw-r--r--libraries/paho-mqtt/paho-mqtt.SlackBuild85
-rw-r--r--libraries/paho-mqtt/paho-mqtt.info10
-rw-r--r--libraries/paho-mqtt/slack-desc19
4 files changed, 133 insertions, 0 deletions
diff --git a/libraries/paho-mqtt/README b/libraries/paho-mqtt/README
new file mode 100644
index 0000000000..df98524431
--- /dev/null
+++ b/libraries/paho-mqtt/README
@@ -0,0 +1,19 @@
+This document describes the source code for the Eclipse Paho MQTT
+Python client library, which implements versions 5.0, 3.1.1, and 3.1
+of the MQTT protocol.
+
+This code provides a client class which enable applications to
+connect to an MQTT broker to publish messages, and to subscribe to
+topics and receive published messages. It also provides some helper
+functions to make publishing one off messages to an MQTT server very
+straightforward.
+
+It supports Python 2.7.9+ or 3.6+.
+
+The MQTT protocol is a machine-to-machine (M2M)/"Internet of
+Things" connectivity protocol. Designed as an extremely lightweight
+publish/subscribe messaging transport, it is useful for connections
+with remote locations where a small code footprint is required and/or
+network bandwidth is at a premium.
+
+Paho is an Eclipse Foundation project.
diff --git a/libraries/paho-mqtt/paho-mqtt.SlackBuild b/libraries/paho-mqtt/paho-mqtt.SlackBuild
new file mode 100644
index 0000000000..08b7218f1b
--- /dev/null
+++ b/libraries/paho-mqtt/paho-mqtt.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/bash
+
+# Slackware build script for paho-mqtt
+
+# Copyright 2022 Christoph Willing Brisbane, Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=paho-mqtt
+SRCNAM=paho.mqtt.python
+VERSION=${VERSION:-1.6.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+# 20220312 bkw: no compiled code, no need for CFLAGS.
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+# 20220312 bkw: no compiled code, no need to strip anything.
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE.* README.* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/paho-mqtt/paho-mqtt.info b/libraries/paho-mqtt/paho-mqtt.info
new file mode 100644
index 0000000000..c7b6319c77
--- /dev/null
+++ b/libraries/paho-mqtt/paho-mqtt.info
@@ -0,0 +1,10 @@
+PRGNAM="paho-mqtt"
+VERSION="1.6.1"
+HOMEPAGE="http://eclipse.org/paho"
+DOWNLOAD="https://github.com/eclipse/paho.mqtt.python/archive/refs/tags/v1.6.1/paho.mqtt.python-1.6.1.tar.gz"
+MD5SUM="00c3381d7deacc7ac8b220f3b9d689c6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Christoph Willing"
+EMAIL="chris.willing@linux.com"
diff --git a/libraries/paho-mqtt/slack-desc b/libraries/paho-mqtt/slack-desc
new file mode 100644
index 0000000000..cadb396332
--- /dev/null
+++ b/libraries/paho-mqtt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+paho-mqtt: paho-mqtt (MQTT Python client library)
+paho-mqtt:
+paho-mqtt: This code provides a client class which enable applications to
+paho-mqtt: connect to an MQTT broker to publish messages, and to subscribe to
+paho-mqtt: topics and receive published messages. It supports Python 2.7.9+ or
+paho-mqtt: 3.6+.
+paho-mqtt:
+paho-mqtt: Paho is an Eclipse Foundation project.
+paho-mqtt:
+paho-mqtt:
+paho-mqtt: