summaryrefslogtreecommitdiffstats
path: root/libraries/opal/opal.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/opal/opal.SlackBuild')
-rw-r--r--libraries/opal/opal.SlackBuild72
1 files changed, 54 insertions, 18 deletions
diff --git a/libraries/opal/opal.SlackBuild b/libraries/opal/opal.SlackBuild
index ab4de8a733..ca382bc4ef 100644
--- a/libraries/opal/opal.SlackBuild
+++ b/libraries/opal/opal.SlackBuild
@@ -25,12 +25,12 @@
PRGNAM=opal
VERSION=${VERSION:-3.10.10}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,21 +41,17 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-# The -D__STDC_CONSTANT_MACROS thing is required to build against ffmpeg 0.6
-# Retrieved from
-# http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-libs/opal/opal-3.6.7.ebuild?r1=1.3&r2=1.4
-# Thanks to the Gentoo folks for coming up with this fix!
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686 -D__STDC_CONSTANT_MACROS"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686 -D__STDC_CONSTANT_MACROS"
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC -D__STDC_CONSTANT_MACROS"
+ SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
- SLKCFLAGS="-O2 -D__STDC_CONSTANT_MACROS"
+ SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
@@ -68,12 +64,6 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
-(
- cd plugins
- aclocal
- autoconf
-)
-
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -81,7 +71,22 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/opal-ffmpeg.patch
+# patch and seds from lfs:
+# http://www.linuxfromscratch.org/blfs/view/svn/multimedia/opal.html
+patch -p1 --verbose < $CWD/ffmpeg2.patch
+
+sed -e 's/CODEC_ID/AV_&/' \
+ -e 's/PIX_FMT_/AV_&/' \
+ -i plugins/video/H.263-1998/h263-1998.cxx \
+ plugins/video/common/dyna.cxx \
+ plugins/video/H.264/h264-x264.cxx \
+ plugins/video/MPEG4-ffmpeg/mpeg4.cxx
+
+sed -e '/<< mime.PrintContents/ s/mime/(const std::string\&)&/' \
+ -i src/im/msrp.cxx &&
+
+sed -e '/abs(/s/MPI.*)/(int)(&)/' \
+ -i ./plugins/video/common/mpi.cxx
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -91,6 +96,37 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--enable-shared \
+ --enable-ivr \
+ --enable-rfc4175 \
+ --enable-rfc2435 \
+ --enable-aec \
+ --enable-g711plc \
+ --enable-rtcpxr \
+ --enable-statistics \
+ --enable-mixer \
+ --enable-pcss \
+ --enable-rfc4103 \
+ --enable-fax \
+ --enable-h450 \
+ --enable-h460 \
+ --enable-h239 \
+ --enable-h501 \
+ --enable-lid \
+ --enable-zrtp \
+ --enable-srtp \
+ --enable-capi \
+ --enable-java \
+ --enable-ruby \
+ --enable-video \
+ --enable-sip \
+ --enable-h323 \
+ --enable-iax2 \
+ --enable-h224 \
+ --enable-h281 \
+ --enable-t38 \
+ --enable-msrp \
+ --enable-sipim \
+ --enable-plugins \
--build=$ARCH-slackware-linux
make VERBOSE=1