summaryrefslogtreecommitdiffstats
path: root/libraries/libwebp
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libwebp')
-rw-r--r--libraries/libwebp/README18
-rw-r--r--libraries/libwebp/libwebp.SlackBuild98
-rw-r--r--libraries/libwebp/libwebp.info10
-rw-r--r--libraries/libwebp/slack-desc19
4 files changed, 0 insertions, 145 deletions
diff --git a/libraries/libwebp/README b/libraries/libwebp/README
deleted file mode 100644
index 1ea4235291..0000000000
--- a/libraries/libwebp/README
+++ /dev/null
@@ -1,18 +0,0 @@
-WebP is a method of lossy compression that can be used on photographic
-images. The degree of compression is adjustable so a user can choose
-the trade-off between file size and image quality.
-WebP typically achieves an average of 39% more compression than JPEG
-and JPEG 2000, without loss of image quality.
-
-WebP is a new image format that provides lossless and lossy compression for
-images on the web. WebP lossless images are 26% smaller in size compared to
-PNGs. WebP lossy images are 25-34% smaller in size compared to JPEG images at
-equivalent SSIM index.
-
-WebP supports lossless transparency (also known as alpha channel) with just 22%
-additional bytes. Transparency is also supported with lossy compression and
-typically provides 3x smaller file sizes compared to PNG when lossy compression
-is acceptable for the red/green/blue color channels.
-
-Webmasters and web developers can use the WebP image format to create smaller
-and richer images that can help make the web faster.
diff --git a/libraries/libwebp/libwebp.SlackBuild b/libraries/libwebp/libwebp.SlackBuild
deleted file mode 100644
index f475557d10..0000000000
--- a/libraries/libwebp/libwebp.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for webP
-# written by powtrix (@gmail.com)
-
-PRGNAM=libwebp
-VERSION=${VERSION:-1.0.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --disable-static \
- --disable-silent-rules \
- --enable-everything \
- --enable-swap-16bit-csp \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-(
- cd swig
- # Fix temporary working directory.
- sed -i "/^tmpdir/s|=.*|= 'tmpdir'|" setup.py
- CFLAGS="$SLKCFLAGS -I$PKG/usr/include" \
- LDFLAGS="-L$PKG/usr/lib${LIBDIRSUFFIX} -lwebp" \
- python setup.py install --root=$PKG
- # Install the python3 module if python3 is installed
- if $(python3 -c 'import sys' 2>/dev/null); then
- CFLAGS="$SLKCFLAGS -I$PKG/usr/include" \
- LDFLAGS="-L$PKG/usr/lib${LIBDIRSUFFIX} -lwebp" \
- python3 setup.py install --root=$PKG
- fi
-)
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog NEWS PATENTS README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libwebp/libwebp.info b/libraries/libwebp/libwebp.info
deleted file mode 100644
index 26252a0e77..0000000000
--- a/libraries/libwebp/libwebp.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="libwebp"
-VERSION="1.0.1"
-HOMEPAGE="https://developers.google.com/speed/webp/"
-DOWNLOAD="https://storage.googleapis.com/downloads.webmproject.org/releases/webp/libwebp-1.0.1.tar.gz"
-MD5SUM="ba72dfa7588c751a3a9b735a6746a23e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="powtrix"
-EMAIL="powtrix@gmail.com"
diff --git a/libraries/libwebp/slack-desc b/libraries/libwebp/slack-desc
deleted file mode 100644
index c37e841aaf..0000000000
--- a/libraries/libwebp/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-libwebp: libwebp (WebP photo compression library)
-libwebp:
-libwebp: WebP is a method of lossy compression that can be used on
-libwebp: photographic images. The degree of compression is adjustable so a
-libwebp: user can choose the trade-off between file size and image quality.
-libwebp: WebP typically achieves an average of 39% more compression than
-libwebp: JPEG and JPEG 2000, without loss of image quality.
-libwebp:
-libwebp: Homepage: https://developers.google.com/speed/webp/
-libwebp:
-libwebp: