summaryrefslogtreecommitdiffstats
path: root/libraries/jansson
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/jansson')
-rw-r--r--libraries/jansson/0001-Enable-Bsymbolic-functions-linker-flag-whenever-poss.patch76
-rw-r--r--libraries/jansson/README1
-rw-r--r--libraries/jansson/jansson.SlackBuild104
-rw-r--r--libraries/jansson/jansson.info10
-rw-r--r--libraries/jansson/slack-desc19
5 files changed, 0 insertions, 210 deletions
diff --git a/libraries/jansson/0001-Enable-Bsymbolic-functions-linker-flag-whenever-poss.patch b/libraries/jansson/0001-Enable-Bsymbolic-functions-linker-flag-whenever-poss.patch
deleted file mode 100644
index 509a28c3fb..0000000000
--- a/libraries/jansson/0001-Enable-Bsymbolic-functions-linker-flag-whenever-poss.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From c14f07092f76b5bc4098cee528122bd0d418e10e Mon Sep 17 00:00:00 2001
-Message-Id: <c14f07092f76b5bc4098cee528122bd0d418e10e.1533366596.git.mprivozn@redhat.com>
-From: Michal Privoznik <mprivozn@redhat.com>
-Date: Sat, 4 Aug 2018 08:58:26 +0200
-Subject: [PATCH] Enable -Bsymbolic-functions linker flag whenever possible
-
-It was discovered fairly recently that JSON parsing libraries use
-common pattern to name their exported symbols (they all use
-json_ prefix). So eventually it happens that two symbols from two
-different libraries have the same name. This will lead to cryptic
-crashes (see [1] and [2]). Linking with -Bsymbolic-functions
-prevents this.
-
-1: https://gitlab.gnome.org/GNOME/json-glib/issues/33
-2: https://groups.google.com/forum/#!topic/jansson-users/7Efx-RI45IU
-
-Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
----
- configure.ac | 29 +++++++++++++++++++++++++++++
- src/Makefile.am | 3 ++-
- 2 files changed, 31 insertions(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index ca12b59..735fe89 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -107,6 +107,35 @@ AC_ARG_ENABLE([initial-hashtable-order],
- AC_DEFINE_UNQUOTED([INITIAL_HASHTABLE_ORDER], [$initial_hashtable_order],
- [Number of buckets new object hashtables contain is 2 raised to this power. E.g. 3 -> 2^3 = 8.])
-
-+AC_ARG_ENABLE([Bsymbolic],
-+ [AS_HELP_STRING([--disable-Bsymbolic],
-+ [Avoid linking with -Bsymbolic-function])],
-+ [], [with_Bsymbolic=check])
-+
-+if test "x$with_Bsymbolic" != "xno" ; then
-+ AC_MSG_CHECKING([for -Bsymbolic-functions linker flag])
-+ saved_LDFLAGS="${LDFLAGS}"
-+ LDFLAGS=-Wl,-Bsymbolic-functions
-+ AC_TRY_LINK(
-+ [], [int main (void) { return 0; }],
-+ [AC_MSG_RESULT([yes])
-+ have_Bsymbolic=yes],
-+ [AC_MSG_RESULT([no])
-+ have_Bsymbolic=no]
-+ )
-+ LDFLAGS="${saved_LDFLAGS}"
-+
-+ if test "x$with_Bsymbolic" = "xcheck" ; then
-+ with_Bsymbolic=$have_Bsymbolic;
-+ fi
-+ if test "x$with_Bsymbolic:x$have_Bsymbolic" = "xyes:xno" ; then
-+ AC_MSG_ERROR([linker support is required for -Bsymbolic])
-+ fi
-+fi
-+
-+AS_IF([test "x$with_Bsymbolic" = "xyes"], [JSON_BSYMBOLIC_LDFLAGS=-Wl[,]-Bsymbolic-functions])
-+AC_SUBST(JSON_BSYMBOLIC_LDFLAGS)
-+
- if test x$GCC = xyes; then
- AC_MSG_CHECKING(for -Wno-format-truncation)
- wnoformat_truncation="-Wno-format-truncation"
-diff --git a/src/Makefile.am b/src/Makefile.am
-index f823195..63ff7c1 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -24,4 +24,5 @@ libjansson_la_SOURCES = \
- libjansson_la_LDFLAGS = \
- -no-undefined \
- -export-symbols-regex '^json_' \
-- -version-info 15:0:11
-+ -version-info 15:0:11 \
-+ @JSON_BSYMBOLIC_LDFLAGS@
---
-2.16.4
-
diff --git a/libraries/jansson/README b/libraries/jansson/README
deleted file mode 100644
index 658898eea1..0000000000
--- a/libraries/jansson/README
+++ /dev/null
@@ -1 +0,0 @@
-Jansson is a C library for encoding, decoding and manipulating JSON data.
diff --git a/libraries/jansson/jansson.SlackBuild b/libraries/jansson/jansson.SlackBuild
deleted file mode 100644
index 49bc52ca0a..0000000000
--- a/libraries/jansson/jansson.SlackBuild
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for jansson
-
-# Copyright 2014-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=jansson
-VERSION=${VERSION:-2.11}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Patch to fix conflicting json_* symbols.
-# Ref: https://groups.google.com/forum/#!topic/jansson-users/7Efx-RI45IU
-patch -p1 < $CWD/0001-Enable-Bsymbolic-functions-linker-flag-whenever-poss.patch
-autoreconf -ivf
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-static=no \
- --disable-silent-rules \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/jansson/jansson.info b/libraries/jansson/jansson.info
deleted file mode 100644
index 40aff8df23..0000000000
--- a/libraries/jansson/jansson.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="jansson"
-VERSION="2.11"
-HOMEPAGE="http://www.digip.org/jansson/"
-DOWNLOAD="http://www.digip.org/jansson/releases/jansson-2.11.tar.bz2"
-MD5SUM="289ca8cbd2df31de9bda7e5220754d25"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/libraries/jansson/slack-desc b/libraries/jansson/slack-desc
deleted file mode 100644
index 9379939173..0000000000
--- a/libraries/jansson/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-jansson: jansson (C library)
-jansson:
-jansson: Jansson is a C library for encoding, decoding and manipulating JSON
-jansson: data.
-jansson:
-jansson: Homepage: http://www.digip.org/jansson/
-jansson:
-jansson:
-jansson:
-jansson:
-jansson: