summaryrefslogtreecommitdiffstats
path: root/libraries/Impacket
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/Impacket')
-rw-r--r--libraries/Impacket/Impacket.SlackBuild39
-rw-r--r--libraries/Impacket/Impacket.info10
-rw-r--r--libraries/Impacket/README8
-rw-r--r--libraries/Impacket/slack-desc2
4 files changed, 36 insertions, 23 deletions
diff --git a/libraries/Impacket/Impacket.SlackBuild b/libraries/Impacket/Impacket.SlackBuild
index 1d22002ffa..929d02518a 100644
--- a/libraries/Impacket/Impacket.SlackBuild
+++ b/libraries/Impacket/Impacket.SlackBuild
@@ -1,9 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for Impacket.
# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
-# Copyright 2015-2016, 2018 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2015-2020, Brenton Earl <brent@exitstatusone.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,12 +23,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220422 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - remove /usr/share/doc.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=Impacket
SRCNAM=impacket
-SRCVER=_0_9_17
-VERSION=${VERSION:-0.9.17}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.9.21}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -38,7 +43,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -64,21 +73,25 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$SRCNAM$SRCVER
-tar -xzvf $CWD/$SRCNAM-$SRCNAM$SRCVER.tar.gz
-cd $SRCNAM-$SRCNAM$SRCVER
+rm -rf $SRCNAM-$VERSION
+tar -xzvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220422 bkw: nothing in share except redundant doc.
+rm -rf $PKG/usr/share
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -87,4 +100,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/Impacket/Impacket.info b/libraries/Impacket/Impacket.info
index 41652e8617..b259b7b4fd 100644
--- a/libraries/Impacket/Impacket.info
+++ b/libraries/Impacket/Impacket.info
@@ -1,10 +1,10 @@
PRGNAM="Impacket"
-VERSION="0.9.17"
-HOMEPAGE="https://www.coresecurity.com/corelabs-research/open-source-tools/impacket"
-DOWNLOAD="https://github.com/CoreSecurity/impacket/archive/impacket_0_9_17/impacket-impacket_0_9_17.tar.gz"
-MD5SUM="a53a34898856307c79c02fcd8b8b1cb4"
+VERSION="0.9.21"
+HOMEPAGE="https://github.com/SecureAuthCorp/impacket"
+DOWNLOAD="https://pypi.io/packages/source/i/impacket/impacket-0.9.21.tar.gz"
+MD5SUM="c0a71706c09c7343905c9395076d7e31"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="pyasn1 pycrypto six"
+REQUIRES="python2-pyasn1 python2-pycrypto python3-pyasn1"
MAINTAINER="Brenton Earl"
EMAIL="brent@exitstatusone.com"
diff --git a/libraries/Impacket/README b/libraries/Impacket/README
index 00e4b5f792..6b9de911f9 100644
--- a/libraries/Impacket/README
+++ b/libraries/Impacket/README
@@ -3,7 +3,7 @@ to network packets. Impacket allows Python developers to craft and
decode network packets in simple and consistent manner. It includes
support for low-level protocols such as IP, UDP and TCP, as well as
higher-level protocols such as NMB and SMB. Impacket is highly effective
-when used in conjunction with a packet capture utility or package such as
-Pcapy. Packets can be constructed from scratch, as well as parsed from
-raw data. Furthermore, the object oriented API makes it simple to work
-with deep protocol hierarchies.
+when used in conjunction with a packet capture utility or package such
+as Pcapy. Packets can be constructed from scratch, as well as parsed
+from raw data. Furthermore, the object oriented API makes it simple to
+work with deep protocol hierarchies.
diff --git a/libraries/Impacket/slack-desc b/libraries/Impacket/slack-desc
index 76de7c50f6..90a47a07d9 100644
--- a/libraries/Impacket/slack-desc
+++ b/libraries/Impacket/slack-desc
@@ -14,6 +14,6 @@ Impacket: decode network packets in simple and consistent manner. It includes
Impacket: support for low-level protocols such as IP, UDP and TCP, as well as
Impacket: higher-level protocols such as NMB and SMB.
Impacket:
-Impacket: Home page: https://github.com/CoreSecurity/impacket
+Impacket: Home page: https://github.com/SecureAuthCorp/impacket
Impacket:
Impacket: