summaryrefslogtreecommitdiffstats
path: root/libraries/FreeImage/Makefile.fip.DESTDIR.diff
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/FreeImage/Makefile.fip.DESTDIR.diff')
-rw-r--r--libraries/FreeImage/Makefile.fip.DESTDIR.diff39
1 files changed, 18 insertions, 21 deletions
diff --git a/libraries/FreeImage/Makefile.fip.DESTDIR.diff b/libraries/FreeImage/Makefile.fip.DESTDIR.diff
index acb9af1a4a..4861adf272 100644
--- a/libraries/FreeImage/Makefile.fip.DESTDIR.diff
+++ b/libraries/FreeImage/Makefile.fip.DESTDIR.diff
@@ -1,36 +1,33 @@
-Patch generated 20071214 by Robby Workman <rworkman@slackbuilds.org>
-Permission granted to use this patch as you see fit.
-
---- FreeImage/Makefile.fip.orig 2007-12-14 13:53:23.424826247 -0600
-+++ FreeImage/Makefile.fip 2007-12-14 14:21:10.427625070 -0600
-@@ -14,13 +14,13 @@
- # Converts cr/lf to just lf
- DOS2UNIX = dos2unix
-
--COMPILERFLAGS = -O3 -fexceptions -fvisibility=hidden
-+COMPILERFLAGS = -fexceptions -fvisibility=hidden
- LIBRARIES = -lstdc++
+--- FreeImage/Makefile.fip.orig 2009-09-07 01:09:47.000000000 -0500
++++ FreeImage/Makefile.fip 2009-09-07 01:27:12.000000000 -0500
+@@ -15,16 +15,11 @@
MODULES = $(SRCS:.c=.o)
MODULES := $(MODULES:.cpp=.o)
--CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
--CXXFLAGS = $(COMPILERFLAGS) -Wno-ctor-dtor-privacy $(INCLUDE)
-+CFLAGS += $(COMPILERFLAGS) $(INCLUDE)
-+CXXFLAGS += $(COMPILERFLAGS) -Wno-ctor-dtor-privacy $(INCLUDE)
+-CFLAGS ?= -O3 -fexceptions -fvisibility=hidden
++CFLAGS ?= -fexceptions -fvisibility=hidden
+ CFLAGS += $(INCLUDE)
+-CXXFLAGS ?= -O3 -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
++CXXFLAGS ?= -fexceptions -fvisibility=hidden -Wno-ctor-dtor-privacy
+ CXXFLAGS += $(INCLUDE)
+-ifeq ($(shell sh -c 'uname -m 2>/dev/null || echo not'),x86_64)
+- CFLAGS += -fPIC
+- CXXFLAGS += -fPIC
+-endif
+-
TARGET = freeimageplus
STATICLIB = lib$(TARGET).a
-@@ -59,13 +59,14 @@
- $(CC) -s -shared -Wl,-soname,$(VERLIBNAME) -o $@ $(MODULES) $(LIBRARIES)
+ SHAREDLIB = lib$(TARGET)-$(VER_MAJOR).$(VER_MINOR).so
+@@ -62,11 +57,14 @@
+ $(CC) -shared -Wl,-soname,$(VERLIBNAME) $(LDFLAGS) -o $@ $(MODULES) $(LIBRARIES)
install:
+- install -d $(INCDIR) $(INSTALLDIR)
- install -m 644 -o root -g root $(HEADER) $(INCDIR)
- install -m 644 -o root -g root $(HEADERFIP) $(INCDIR)
- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
-- ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(VERLIBNAME)
-- ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
-- ldconfig
+ install -d 755 $(DESTDIR)/$(INCDIR)
+ install -m 644 $(HEADER) $(DESTDIR)/$(INCDIR)
+ install -m 644 $(HEADERFIP) $(DESTDIR)/$(INCDIR)