summaryrefslogtreecommitdiffstats
path: root/graphics/mcomix
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mcomix')
-rw-r--r--graphics/mcomix/README20
-rw-r--r--graphics/mcomix/doinst.sh13
-rw-r--r--graphics/mcomix/mcomix.SlackBuild86
-rw-r--r--graphics/mcomix/mcomix.info10
-rw-r--r--graphics/mcomix/slack-desc19
5 files changed, 0 insertions, 148 deletions
diff --git a/graphics/mcomix/README b/graphics/mcomix/README
deleted file mode 100644
index 0bb478ae18..0000000000
--- a/graphics/mcomix/README
+++ /dev/null
@@ -1,20 +0,0 @@
-mcomix (comic book viewer)
-
-MComix is a user-friendly, customizable image viewer. It is specifically
-designed to handle comic books, but also serves as a generic viewer. It
-reads images in ZIP, RAR, 7Zip or tar archives as well as plain image files. It
-is written in Python and uses GTK+ through the PyGTK bindings.
-
-MComix is a fork of the Comix project, and aims to add bug fixes and stability
-improvements after Comix development came to a halt in late 2009.
-
-OPTIONAL DEPENDENCIES:
-You also need either the "unrar" or the "rar" program installed if you wish
-to read RAR (.cbr) archives.
-
-Alternatively, MComix can be built over the optional dependency libunrar
-from Rarlab.
-
-To read 7Zip archives, you need to have the "7z" program installed. Likewise,
-"lha" is needed to open LHA/LZA archives. Note that "7z" can be used as
-substitute for both "unrar" and "lha".
diff --git a/graphics/mcomix/doinst.sh b/graphics/mcomix/doinst.sh
deleted file mode 100644
index aea0f894eb..0000000000
--- a/graphics/mcomix/doinst.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/graphics/mcomix/mcomix.SlackBuild b/graphics/mcomix/mcomix.SlackBuild
deleted file mode 100644
index 03a72c7275..0000000000
--- a/graphics/mcomix/mcomix.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for mcomix
-
-# written by Joze Zobec <jozze.zepl@gmail.com>
-
-# modified by B. Watson <yalhcru@gmail.com>
-
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
-# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
-# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=mcomix
-VERSION=${VERSION:-1.2.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-mkdir -p $PKG/usr
-
-python setup.py install --single-version-externally-managed \
- --root=$PKG \
- --prefix=/usr \
- --record mcomix-files.txt
-
-# man page already gzipped, nice
-mv $PKG/usr/share/man $PKG/usr/man
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README PKG-INFO COPYING $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/mcomix/mcomix.info b/graphics/mcomix/mcomix.info
deleted file mode 100644
index 235888c5d2..0000000000
--- a/graphics/mcomix/mcomix.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mcomix"
-VERSION="1.2.1"
-HOMEPAGE="http://mcomix.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/project/mcomix/MComix-1.2.1/mcomix-1.2.1.tar.bz2"
-MD5SUM="1d05ed7596bd670e5b3a97896e6d4d47"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/graphics/mcomix/slack-desc b/graphics/mcomix/slack-desc
deleted file mode 100644
index f13a70e456..0000000000
--- a/graphics/mcomix/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-mcomix: mcomix (comic book viewer)
-mcomix:
-mcomix: MComix is a user-friendly, customizable image viewer. It is
-mcomix: specifically designed to handle comic books, but also serves as a
-mcomix: generic viewer. It reads images in ZIP, RAR, 7Zip or tar archives as
-mcomix: well as plain image files. It is written in Python and uses GTK+
-mcomix: through the PyGTK bindings.
-mcomix:
-mcomix: Homepage: mcomix.sourceforge.net
-mcomix:
-mcomix: