summaryrefslogtreecommitdiffstats
path: root/graphics/fontmatrix/fontmatrix.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/fontmatrix/fontmatrix.SlackBuild')
-rw-r--r--graphics/fontmatrix/fontmatrix.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/fontmatrix/fontmatrix.SlackBuild b/graphics/fontmatrix/fontmatrix.SlackBuild
index d3c032bc90..3919641d27 100644
--- a/graphics/fontmatrix/fontmatrix.SlackBuild
+++ b/graphics/fontmatrix/fontmatrix.SlackBuild
@@ -6,7 +6,7 @@
PRGNAM=fontmatrix
VERSION=${VERSION:-r1220}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -55,6 +55,9 @@ find -L . \
echo "StartupNotify=false" >> $PRGNAM.desktop
sed -i 's|share/man|man|' CMakeLists.txt
+# Fix fontmatrix build against icu 0.56.
+patch -p1 < $CWD/fontmatrix-0.9.99-adapt-to-icu-56.patch
+
# Cmake uses the static python lib. Let's use the shared lib instead.
PYVER=$(python -c 'import sys; print sys.version[:3]')
PY_LIB_SHARED="/usr/lib${LIBDIRSUFFIX}/libpython${PYVER}.so"