summaryrefslogtreecommitdiffstats
path: root/gis/pyproj
diff options
context:
space:
mode:
Diffstat (limited to 'gis/pyproj')
-rw-r--r--gis/pyproj/README16
-rw-r--r--gis/pyproj/pyproj.SlackBuild87
-rw-r--r--gis/pyproj/pyproj.info10
-rw-r--r--gis/pyproj/slack-desc19
4 files changed, 0 insertions, 132 deletions
diff --git a/gis/pyproj/README b/gis/pyproj/README
deleted file mode 100644
index b86dd367a6..0000000000
--- a/gis/pyproj/README
+++ /dev/null
@@ -1,16 +0,0 @@
-Performs cartographic transformations and geodetic computations.
-
-The Proj class can convert from geographic (longitude,latitude) to native map
-projection (x,y) coordinates and vice versa, or from one map projection
-coordinate system directly to another.
-
-The Geod class can perform forward and inverse geodetic, or Great Circle,
-computations. The forward computation involves determining latitude, longitude
-and back azimuth of a terminus point given the latitude and longitude of an
-initial point, plus azimuth and distance. The inverse computation involves
-determining the forward and back azimuths and distance given the latitudes and
-longitudes of an initial and terminus point.
-
-Input coordinates can be given as python arrays, lists/tuples, scalars or
-numpy/Numeric/numarray arrays. Optimized for objects that support the Python
-buffer protocol (regular python and numpy array objects).
diff --git a/gis/pyproj/pyproj.SlackBuild b/gis/pyproj/pyproj.SlackBuild
deleted file mode 100644
index 6c538e4cae..0000000000
--- a/gis/pyproj/pyproj.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyproj
-
-# Copyright 2013-2020 Benjamin Trigona-Harany
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pyproj
-VERSION=${VERSION:-2.5.0}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-${VERSION}rel
-tar xvf $CWD/$PRGNAM-${VERSION}rel.tar.gz
-cd $PRGNAM-${VERSION}rel
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/pyproj/pyproj.info b/gis/pyproj/pyproj.info
deleted file mode 100644
index a9bd577dfb..0000000000
--- a/gis/pyproj/pyproj.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyproj"
-VERSION="2.5.0"
-HOMEPAGE="https://github.com/jswhit/pyproj"
-DOWNLOAD="https://github.com/jswhit/pyproj/archive/v2.5.0rel/pyproj-2.5.0rel.tar.gz"
-MD5SUM="1d5e32caaf1b17f9b15f71beed999597"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="proj python3-Cython"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/pyproj/slack-desc b/gis/pyproj/slack-desc
deleted file mode 100644
index b7fe3654f8..0000000000
--- a/gis/pyproj/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyproj: pyproj (Python interface to the PROJ.4 library)
-pyproj:
-pyproj: pyproj can convert from geographic (longitude,latitude) to native
-pyproj: map projection (x,y) coordinates and vice versa, or from one map
-pyproj: projection coordinate system directly to another.
-pyproj:
-pyproj: Homepage: http://code.google.com/p/pyproj/
-pyproj:
-pyproj:
-pyproj:
-pyproj: