summaryrefslogtreecommitdiffstats
path: root/gis/OWSLib
diff options
context:
space:
mode:
Diffstat (limited to 'gis/OWSLib')
-rw-r--r--gis/OWSLib/OWSLib.SlackBuild27
-rw-r--r--gis/OWSLib/OWSLib.info12
-rw-r--r--gis/OWSLib/pytz-not-required.patch13
3 files changed, 38 insertions, 14 deletions
diff --git a/gis/OWSLib/OWSLib.SlackBuild b/gis/OWSLib/OWSLib.SlackBuild
index 217ad4bbca..afdb8084e9 100644
--- a/gis/OWSLib/OWSLib.SlackBuild
+++ b/gis/OWSLib/OWSLib.SlackBuild
@@ -1,8 +1,9 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for OWSLib
-# Copyright 2013-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2023-2024 Giancarlo Dessi, Cagliari, IT
+# Copyright 2013-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=OWSLib
-VERSION=${VERSION:-0.19.1}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-0.30.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +39,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -68,19 +76,22 @@ find -L . \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if [ -x /usr/bin/python3.11 ]; then
+ patch -p1 < $CWD/pytz-not-required.patch
+fi
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.rst LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/OWSLib/OWSLib.info b/gis/OWSLib/OWSLib.info
index 95184e2fab..09f5fb5be7 100644
--- a/gis/OWSLib/OWSLib.info
+++ b/gis/OWSLib/OWSLib.info
@@ -1,10 +1,10 @@
PRGNAM="OWSLib"
-VERSION="0.19.1"
+VERSION="0.30.0"
HOMEPAGE="https://pypi.python.org/pypi/OWSLib/"
-DOWNLOAD="https://github.com/geopython/OWSLib/archive/0.19.1/OWSLib-0.19.1.tar.gz"
-MD5SUM="198befd5de54cd909e2efbda45f73e1c"
+DOWNLOAD="https://github.com/geopython/OWSLib/archive/0.30.0/OWSLib-0.30.0.tar.gz"
+MD5SUM="c2ba9d5fd13b4c8795153e89c0c65322"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-dateutil python3-dateutil pytz lxml six python3-six"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python3-dateutil pytz python3-lxml"
+MAINTAINER="Giancarlo Dessi"
+EMAIL="slack@giand.it"
diff --git a/gis/OWSLib/pytz-not-required.patch b/gis/OWSLib/pytz-not-required.patch
new file mode 100644
index 0000000000..03471b2d4d
--- /dev/null
+++ b/gis/OWSLib/pytz-not-required.patch
@@ -0,0 +1,13 @@
+python-pytz has been removed from Slackware -current because
+not needed with Python 3.11
+This patch prevents pip check from indicating the lack of
+pytz as dependency required by OWSLib in -current
+--- ./requirements.txt 2024-04-05 23:42:52.864498274 +0200
++++ ./requirements.txt 2024-04-05 23:43:13.322499915 +0200
+@@ -1,6 +1,5 @@
+ dataclasses; python_version < '3.7'
+ lxml
+ python-dateutil>=1.5
+-pytz
+ pyyaml
+ requests>=1.0