summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
Diffstat (limited to 'gis')
-rw-r--r--gis/opencpn/README8
-rw-r--r--gis/opencpn/doinst.sh10
-rw-r--r--gis/opencpn/opencpn.SlackBuild137
-rw-r--r--gis/opencpn/opencpn.info10
-rw-r--r--gis/opencpn/slack-desc19
5 files changed, 0 insertions, 184 deletions
diff --git a/gis/opencpn/README b/gis/opencpn/README
deleted file mode 100644
index 7b1dd96ad5..0000000000
--- a/gis/opencpn/README
+++ /dev/null
@@ -1,8 +0,0 @@
-OpenCPN is a free software (GPLv2) project to create a concise chart
-plotter and navigation software, for use underway or as a planning
-tool. OpenCPN is developed by a team of active sailors using real
-world conditions for program testing and refinement.
-
-If you are upgrading or installing new, OpenCPN 5.2.x needs wxGTK3
-to be built with webkit support. So you will have to install
-webkit2gtk, available here at SBo, then build and install wxGTK3.
diff --git a/gis/opencpn/doinst.sh b/gis/opencpn/doinst.sh
deleted file mode 100644
index 3d2e9538d1..0000000000
--- a/gis/opencpn/doinst.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/gis/opencpn/opencpn.SlackBuild b/gis/opencpn/opencpn.SlackBuild
deleted file mode 100644
index 0204b254d9..0000000000
--- a/gis/opencpn/opencpn.SlackBuild
+++ /dev/null
@@ -1,137 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for opencpn
-
-# Copyright 2021 Matt Dinslage, Springfield, MO
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=opencpn
-VERSION=${VERSION:-5.2.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/OpenCPN-$VERSION.tar.gz
-cd OpenCPN-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Fix LIBDIR
-if [ "$ARCH" = "x86_64" ]; then
- sed -i '0,/"i386"/{s/"i386"/"x86_64"/}' cmake/GetArch.cmake
- sed -i '0,/"lib"/{s/"lib"/"lib64"/}' cmake/GetArch.cmake
-fi
-
-# Fix MANDIR
-sed -i 's,${PREFIX_DATA}/man/man1,/usr/man/man1,g' CMakeLists.txt
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DOPCPN_FORCE_GTK3=ON \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \
- -DBUNDLE_GSHHS=CRUDE \
- -DBUNDLE_TCDATA=ON \
- -DBUNDLE_DOCS=ON \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
-cd ..
-
-# Don't ship .la files:
-rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a INSTALL README data/doc/help_en_US.html data/license.txt $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
-rm -rf $PKG/usr/share/doc
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-rm -r $PKG/usr/share/icons/hicolor/*
-mkdir -p $PKG/usr/share/icons/hicolor/scalable/apps
-cp $TMP/OpenCPN-$VERSION/src/bitmaps/other_svg_src/opencpn_logo.svg \
- $PKG/usr/share/icons/hicolor/scalable/apps/opencpn.svg
-
-mkdir -p $PKG/usr/share/pixmaps
-convert $PKG/usr/share/icons/hicolor/scalable/apps/opencpn.svg -resize 256x256 \
- $PKG/usr/share/pixmaps/opencpn.png
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/opencpn/opencpn.info b/gis/opencpn/opencpn.info
deleted file mode 100644
index a44554b6bb..0000000000
--- a/gis/opencpn/opencpn.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="opencpn"
-VERSION="5.2.4"
-HOMEPAGE="https://opencpn.org/"
-DOWNLOAD="https://github.com/OpenCPN/OpenCPN/archive/v5.2.4/OpenCPN-5.2.4.tar.gz"
-MD5SUM="9ca81bed7bca1706ecaac98a7578d6bb"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="gpsd tinyxml libmspack portaudio lsb-release webkit2gtk wxGTK3"
-MAINTAINER="M.Dinslage"
-EMAIL="daedra1980@gmail.com"
diff --git a/gis/opencpn/slack-desc b/gis/opencpn/slack-desc
deleted file mode 100644
index db7e4e4e3d..0000000000
--- a/gis/opencpn/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-opencpn: opencpn (A Chartplotter and GPS Navigation Software)
-opencpn:
-opencpn: OpenCPN is a free software (GPLv2) project to create a concise chart
-opencpn: plotter and navigation software, for use underway or as a planning
-opencpn: tool. OpenCPN is developed by a team of active sailors using real
-opencpn: world conditions for program testing and refinement.
-opencpn:
-opencpn:
-opencpn:
-opencpn:
-opencpn: