summaryrefslogtreecommitdiffstats
path: root/games/prboom-plus
diff options
context:
space:
mode:
Diffstat (limited to 'games/prboom-plus')
-rw-r--r--games/prboom-plus/README9
-rw-r--r--games/prboom-plus/doinst.sh10
-rw-r--r--games/prboom-plus/prboom-plus.SlackBuild18
-rw-r--r--games/prboom-plus/prboom-plus.info8
4 files changed, 38 insertions, 7 deletions
diff --git a/games/prboom-plus/README b/games/prboom-plus/README
index 8269961fd1..2cd75e32f9 100644
--- a/games/prboom-plus/README
+++ b/games/prboom-plus/README
@@ -14,8 +14,10 @@ shareware doom1.wad) may be placed. The IWAD directory is
/usr/share/games/doom. If you don't have any IWADs, install
doom_shareware_data to play shareware Doom.
-Optional dependency, autodetected:
+Optional dependencies, autodetected:
portmidi - for the PortMIDI backend. Most users won't need this.
+dumb - somehow, this can be used for music. No idea how to enable it,
+ but if dumb is detected, prboom-plus will link with it.
*** NOTE ***
@@ -26,3 +28,8 @@ file that sets snd_midiplayer to "sdl", the music will sound *really*
messed up. If this happens, simply edit ~/.prboom-plus/prboom-plus.cfg
and remove the line containing snd_midiplayer. Or just delete the
file, to start with default settings.
+
+If you don't like the sound of the OPL2 music, you can try using
+FluidSynth instead (Options -> General -> Preferred MIDI Player in the
+user interface). Other options (PortMIDI and ALSA) may be usable but
+will require more setup, outside the scope of this README.
diff --git a/games/prboom-plus/doinst.sh b/games/prboom-plus/doinst.sh
new file mode 100644
index 0000000000..daf1ce3148
--- /dev/null
+++ b/games/prboom-plus/doinst.sh
@@ -0,0 +1,10 @@
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/prboom-plus/prboom-plus.SlackBuild b/games/prboom-plus/prboom-plus.SlackBuild
index 1798871c25..373411b1ad 100644
--- a/games/prboom-plus/prboom-plus.SlackBuild
+++ b/games/prboom-plus/prboom-plus.SlackBuild
@@ -3,10 +3,16 @@
# Slackware build script for prboom-plus
# Originally written by Dugan Chen (email removed)
-# Modified and now maintained by B. Watson <yalhcru@gmail.com>.
+# Modified and now maintained by B. Watson <urchlay@slackware.uk>.
# Original had no license. Modified version released under the WTFPL. See
# http://www.wtfpl.net/txt/copying/ for details.
+# 20230714 bkw: update for v2.6.66. SDL MIDI is still broken.
+# - change default fluidsynth soundfont to one that exists in Slackware.
+# - document optional dependency dumb.
+
+# 20220622 bkw: update for v2.6.2, add missing doinst.sh.
+
# 20211027 bkw:
# - update for v2.6.1um.
# - band-aid for segfaults on -current (see below). this isn't
@@ -26,7 +32,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=prboom-plus
-VERSION=${VERSION:-2.6.1um}
+VERSION=${VERSION:-2.6.66}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,6 +86,11 @@ find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
sed -i '/install/s,/bin,/games,' src/CMakeLists.txt
sed -i '/^set(CMAKE_INSTALL_DOCDIR/d' CMakeLists.txt
+# 20230714 bkw: use a default soundfont that exists. allows choosing the
+# fluidsynth midi option. personally I think opl2 sounds better, but *shrug*.
+US="/usr/share"
+sed -i '/snd_soundfont/s,"'$US'[^"]*","'$US'/minuet/soundfonts/GeneralUser-v1.47.sf2",' src/m_misc.c
+
MIXEROPT=ON
if [ "${BANDAID:-yes}" = "yes" ]; then
# 20211027 bkw: Band-aid. The game segfaults when the midi backend
@@ -88,6 +99,8 @@ if [ "${BANDAID:-yes}" = "yes" ]; then
# backend to "opl2", which doesn't sound as nice, but allows the game
# to run. Also it increases the default volume, since the opl2 synth
# is quieter.
+ # 20230714 bkw: this is still needed for v2.6.66. the fault is in
+ # Slackware 15.0, so it's not going to change soon.
MIXEROPT=OFF
sed -i -e '/"snd_midiplayer"/s,"sdl","opl2",' \
-e '/"music_volume"/s,8,12,' \
@@ -129,6 +142,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/prboom-plus/prboom-plus.info b/games/prboom-plus/prboom-plus.info
index 3296e63a1d..0b35a74d52 100644
--- a/games/prboom-plus/prboom-plus.info
+++ b/games/prboom-plus/prboom-plus.info
@@ -1,10 +1,10 @@
PRGNAM="prboom-plus"
-VERSION="2.6.1um"
+VERSION="2.6.66"
HOMEPAGE="http://prboom-plus.sourceforge.net"
-DOWNLOAD="https://github.com/coelckers/prboom-plus/archive/v2.6.1um/prboom-plus-2.6.1um.tar.gz"
-MD5SUM="e887e6032912be38a8c3d47ef1c78194"
+DOWNLOAD="https://github.com/coelckers/prboom-plus/archive/v2.6.66/prboom-plus-2.6.66.tar.gz"
+MD5SUM="62b29843ba4ab1f442be8fe469ee523f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"